HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 30, 2012, 11:16 PM
Registered User
United States, FL, Apopka
Joined May 2012
65 Posts
Desperate for help. Just got my devo and bricked it already. I tried to update firmware dfu file and now it just blinks the usb screen when I power off. Can anyone guid me through how to save this thing? I can not get the walkera dfuse tool to work. I know there is a version 1.4 that some people use but I can not find a link anywhere. I am using STMicroelectronics dfuse tool but it is much more confusing. I think this is how I really messed it up. Cry for help - please and thank you
NotFastEnuf is offline Find More Posts by NotFastEnuf
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 30, 2012, 11:26 PM
Registered User
Joined Jan 2012
682 Posts
Quote:
Originally Posted by NotFastEnuf View Post
Desperate for help. Just got my devo and bricked it already. I tried to update firmware dfu file and now it just blinks the usb screen when I power off. Can anyone guid me through how to save this thing? I can not get the walkera dfuse tool to work. I know there is a version 1.4 that some people use but I can not find a link anywhere. I am using STMicroelectronics dfuse tool but it is much more confusing. I think this is how I really messed it up. Cry for help - please and thank you
See my response on the Deviation site. When you say it blinks the USB screen I don't understand? you power off and it keeps coming back to the programming screen? Does it stop flashing when you flip the power back on? This is a classic reponse to using a dfu with a bad CRC (which is likely due to using the STMicro vs DFuse tool). As I said on the other boards. If you can get to the programming screen, your Tx is not bricked.

Edit: I've ziped up my copy of the devention usb tools which works great in Win7-64 (for me). I dunno if it will work for you in this form, since I no longer have the installer.
PhracturedBlue is offline Find More Posts by PhracturedBlue
Reply With Quote
Old Oct 30, 2012, 11:50 PM
<Marty>
United States, KY, Springfield
Joined Jul 2011
1,758 Posts
same thing happened to my devo8 once and i had to format it then use the dfsu to install a fresh copy of deviation...but had to get to the usb screen before i could get it to work...
magic_marty is offline Find More Posts by magic_marty
Reply With Quote
Old Oct 31, 2012, 06:37 AM
Registered User
United States, FL, Apopka
Joined May 2012
65 Posts
Yes Marty, I read you origional post too. i am still stuck though. I can not get the walkera dfuse to run. It crashes immediately no matter which version I use. What do you mean by format it first then install deviation.

So far the usb screen is all I get. Steady lit with power on or blinking with power off. Fingers crossed dfuse will operate on another computer when i get home tonight.
NotFastEnuf is offline Find More Posts by NotFastEnuf
Reply With Quote
Old Oct 31, 2012, 06:51 AM
Registered User
United States, FL, Apopka
Joined May 2012
65 Posts
Yes Marty, I read you origional post too. i am still stuck though. I can not get the walkera dfuse to run. It crashes immediately no matter which version I use. What do you mean by format it first then install deviation.

So far the usb screen is all I get. Steady lit with power on or blinking with power off. Fingers crossed dfuse will operate on another computer when i get home tonight.
NotFastEnuf is offline Find More Posts by NotFastEnuf
Reply With Quote
Old Oct 31, 2012, 07:10 AM
Registered User
j35u5fr34k's Avatar
United States, MI, East Tawas
Joined Aug 2011
119 Posts
Quote:
Originally Posted by NotFastEnuf View Post
Yes Marty, I read you origional post too. i am still stuck though. I can not get the walkera dfuse to run. It crashes immediately no matter which version I use. What do you mean by format it first then install deviation.

So far the usb screen is all I get. Steady lit with power on or blinking with power off. Fingers crossed dfuse will operate on another computer when i get home tonight.
Do you have a PC with Windows XP? I could not get DFuSe to work on Win 7 and had to pull an old XP machine out of the closet. Worked great on XP. Won't open on seven. Also make sure your TX battery is fully charged or it will corrupt the update. You are not bricked you simply need dfuse to work.

It may be possible to do this in an XP VM (virtual machine).
j35u5fr34k is offline Find More Posts by j35u5fr34k
Reply With Quote
Old Oct 31, 2012, 07:16 AM
Registered User
United States, FL, Apopka
Joined May 2012
65 Posts
That is not good. It is my xp machine that will not run dfuse. The only other option I have is a win7 machine.
NotFastEnuf is offline Find More Posts by NotFastEnuf
Reply With Quote
Old Oct 31, 2012, 07:26 AM
Registered User
j35u5fr34k's Avatar
United States, MI, East Tawas
Joined Aug 2011
119 Posts
Quote:
Originally Posted by NotFastEnuf View Post
That is not good. It is my xp machine that will not run dfuse. The only other option I have is a win7 machine.
Have you tried uninstalling. Delete everything in registry with dfuse or walkera. Reinstalling dfuse. Delete stm driver?

Try a different PC or go to a friends PC.

At a very last resort, reformat.

Some people have had luck with 7.
j35u5fr34k is offline Find More Posts by j35u5fr34k
Reply With Quote
Old Oct 31, 2012, 07:59 AM
Deviant
sbstnp's Avatar
Joined Jul 2012
1,138 Posts
Quote:
Originally Posted by NotFastEnuf View Post
That is not good. It is my xp machine that will not run dfuse. The only other option I have is a win7 machine.
Put DFuse in XPSP3 compatibiity mode, that's the way I can run it on my win7 x64 machine. If I don't put in compatibility mode, it will not detect anything.
sbstnp is offline Find More Posts by sbstnp
Reply With Quote
Old Oct 31, 2012, 08:40 AM
Registered User
j35u5fr34k's Avatar
United States, MI, East Tawas
Joined Aug 2011
119 Posts
Quote:
Originally Posted by sbstnp View Post
Put DFuse in XPSP3 compatibiity mode, that's the way I can run it on my win7 x64 machine. If I don't put in compatibility mode, it will not detect anything.
For my Win7 box, dfuse won't open even in compatibility mode. It just crashes.
j35u5fr34k is offline Find More Posts by j35u5fr34k
Reply With Quote
Old Oct 31, 2012, 09:23 AM
Deviant
sbstnp's Avatar
Joined Jul 2012
1,138 Posts
Quote:
Originally Posted by j35u5fr34k View Post
For my Win7 box, dfuse won't open even in compatibility mode. It just crashes.
Then there must be something wrong with your machine. Try a reinstall/restore, maybe it will fix things.
sbstnp is offline Find More Posts by sbstnp
Reply With Quote
Old Oct 31, 2012, 09:26 AM
Registered User
j35u5fr34k's Avatar
United States, MI, East Tawas
Joined Aug 2011
119 Posts
I have Win 8 on that machine now but I have an XP box that has dfuse working so no need for me to reformat my laptop.
j35u5fr34k is offline Find More Posts by j35u5fr34k
Reply With Quote
Old Oct 31, 2012, 11:32 AM
Registered User
United States, FL, Apopka
Joined May 2012
65 Posts
Well i am hearing on the deviation site that there are different dfuse tools for xp 32 and 64 bit systems. Also getting conflicting stories on drivers that either need or don't need to be installed seperately. Can anyone clarify where to get the dfuse I need for xp 32
NotFastEnuf is offline Find More Posts by NotFastEnuf
Reply With Quote
Old Oct 31, 2012, 11:39 AM
Registered User
j35u5fr34k's Avatar
United States, MI, East Tawas
Joined Aug 2011
119 Posts
Quote:
Originally Posted by NotFastEnuf View Post
Well i am hearing on the deviation sire that there are different dfuse tools for xp 32 and 64 bit systems. Also getting conflicting stories on drivers that either need or don't need to be installed seperately. Can anyone clarify where to get the dfuse I need for xp 32
Go to www.walkera.com
Login or register
Click the Software Update tab at top
Download:
Devention Dfuse USB Upgrade Tools(Devo12/S、Devo8/S、Devo10、Devo6)
Version:V1.5
Date:2012-06-27


If the program is crashing before you can even see it or you are getting a pop-up error I doubt that it has anything to do with the driver for the TX.

If you do happen to get the software to load and you see the main screen, plug in your TX and see if it is recognized. If it is not recognized in Dfuse, you can go to device manager and you should see something to the effect of "STM Microelectronics USB" (don't have exact wording right now). If you have a yellow yield sign with an exclamation mark then your drivers are not installed properly. THey are located in the folder where dfuse is installed and you would need to go to Device Manager and manually point the device to the correct drivers.

The drivers were automatically installed for me but the program still crashed on my Win7 machine. If you happened to plug in your TX in while in "upgrade mode" (the mode you get while holding EXT, I believe - not USB mode which entered by holding ENT), it is possible that your drivers did not install. Upon installing dfuse, Windows may or may not have updated the driver for that device.

I hope that helps and not confuses people more.
j35u5fr34k is offline Find More Posts by j35u5fr34k
Last edited by j35u5fr34k; Oct 31, 2012 at 11:54 AM. Reason: site working now
Reply With Quote
Old Oct 31, 2012, 11:53 AM
Registered User
United States, FL, Apopka
Joined May 2012
65 Posts
That is the one I am trying to use but will not work. Crashes as soon ad I try to open the program after installing
NotFastEnuf is offline Find More Posts by NotFastEnuf
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Wanted Broken Walkera Devo and Spektrum tx itsmillertime Aircraft - General - Radio Equipment (FS/W) 1 Mar 20, 2012 04:37 AM
For Sale Walkera Devo 7 TX/Devo RX2625H Combo for sale Tom Z Aircraft - General - Radio Equipment (FS/W) 0 Oct 06, 2011 12:33 PM
For Sale Walkera Devo 7 TX/Devo RX2625H Combo for sale Tom Z Aircraft - Electric - Helis (FS/W) 0 Oct 05, 2011 11:38 AM
Discussion New Walkera Devention Devo 12 TX w/ Touch-Screen hobbypartz Radios 2 May 08, 2011 11:38 PM
Discussion New Walkera Devention Devo 12 TX w/ Touch-Screen hobbypartz XHeli 0 May 05, 2011 11:19 PM