SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Mar 05, 2012, 03:10 PM
Registered User
United States, AZ, Tucson
Joined Mar 2008
2,195 Posts
Help!
NAZA Basic and ATTI mode gain question, which one do I use on AUX3 on my DX8

I'm trying to setup my quad and don't know the difference between Basic gain and ATTI gain.

The manual states that Basic Pitch / Roll gain controls back to level hovering but it also states that ATTI Pitch / Roll gain controls the reaction speed back to level when releasing the stick.

Can someone please explain the difference. Also I want to control the gains remotely on AUX3 of my DX8. Do I put the basic or ATTI gains on that.
I've heard some doing basic and some doing ATTI.

I put both the all the Basic and ATTI gains on AUX3 but was told that's not what I should do.

I've had my quad one day so it's a learning curve to understand all of this.

Also, how do I set up the fail safe with the NAZA on the DX8, I thought my manual said something like put the throttle where you want it (mid stick for hover) and bind the receiver. But when I try the radio beeps and warns that the throttle is not at idle.
jasper7821 is offline Find More Posts by jasper7821
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 05, 2012, 05:19 PM
MaineFlyer
jpgilbert's Avatar
Augusta, Me
Joined Feb 2005
929 Posts
Quote:
Originally Posted by jasper7821 View Post

Also, how do I set up the fail safe with the NAZA on the DX8, I thought my manual said something like put the throttle where you want it (mid stick for hover) and bind the receiver. But when I try the radio beeps and warns that the throttle is not at idle.
On the Dx8, the manual indicates you can change the throttle alarm position by going into the SYSTEM mode, WARNINGS, and set the Throttle value just higher for the moment to avoid the alarm. I wouldn't bind to the 50% level. I set mine to approx 15%.

To properly set up the failsafe, you need to bind the receiver in the Preset Failsafe mode (remove the bind plug after the receiver starts blinking and BEFORE turning on the transmitter in bind mode). You must first set the transmitter channel you are using to select Attitude/Manual mode so it selects the Failsafe mode as shown on the PC at least temporarily. Then bind. You can then readjust that channel so the switch you're using will now select either Attitude or Manual. DON'T rebind!

After you have all your binding done and you have properly set the switch to select Attitude or Manual, if you shut off your transmitter, you should should see the mode change on the PC so it is now putting the Naza in the Failsafe mode. That change is caused by the receiver when it detects the transmitter signal is gone.

Believe me, failsafe does work. I have tested mine by hovering at 20+ ft and shutting off the transmitter. Nice landing. I configured a switch on my transmitter to force a failsafe condition in the Naza just to test also.

I hope this helps and doesn't just confuse you!
I get the feeling reading these threads that many aren't setting up failsafe mode. Maybe I'm wrong. Hope so.
Joe
jpgilbert is offline Find More Posts by jpgilbert
Reply With Quote
Old Mar 05, 2012, 05:35 PM
Registered User
United States, AZ, Tucson
Joined Mar 2008
2,195 Posts
YUP,
It confused me
I'll try when I get home and see what happens.
I read somewhere in the manual if it goes into failsafe it will auto land, is that that same thing as setting the failsafe to 15%
If I set it to 15%, is that a decent descent rate to make it come down smoothly or does the NAZA also assist with it's own altitude sensing.
From Idle, I know I move the stick way more than 15% to get it to come off the ground, if the NAZA does not assist in any way I'd think that if the failsafe triggered it would drop at a pretty fast rate.
Sorry, I'm a total noob with this failsafe and NAZA stuff.
jasper7821 is offline Find More Posts by jasper7821
Reply With Quote
Old Mar 05, 2012, 06:09 PM
MaineFlyer
jpgilbert's Avatar
Augusta, Me
Joined Feb 2005
929 Posts
Sorry about that, Jasper!
If the Naza goes into its failsafe mode, it will autoland!! You must configure your transmitter/receiver to force that mode.

If you have a, say 15% throttle setting when binding and you don't force a Naza failsafe when shutting off the transmitter, it will most likely come down. That is not autoland. That is "I just hope it comes down slow enough so no damage" mode!!! If you have set a much higher throttle setting on bind, maybe it will just fly away!! The Naza failsafe autoland is a controlled landing and it works very well, at least on my tests.

I will admit the whole issue is confusing and maybe I have contributed to here. Hope not. But it is a shame not to take advantage of this built-in safety feature even if it does take some study to understand it. And of course, your receiver must have the capability of Pre-Set Failsafe. Many lower end Spektrum receivers do not. I started with an AR600 but switched to an AR7000 so I could configure Pre-Set failsafe.

Good luck!
Joe
jpgilbert is offline Find More Posts by jpgilbert
Reply With Quote
Old Mar 05, 2012, 10:12 PM
Registered User
United States, AZ, Tucson
Joined Mar 2008
2,195 Posts
Thank you very much, I'm going to attempt setting the fail safe in the DX8 and my AR8000.
Cross your fingers
jasper7821 is offline Find More Posts by jasper7821
Reply With Quote
Old Mar 05, 2012, 10:40 PM
Registered User
United States, AZ, Tucson
Joined Mar 2008
2,195 Posts
FAIL SAFE DIDN"T WORK
But it hovers nicely now, I put all the gains on AUX3 set to 160 and ATTI gains to 85. I still have to fine tune it.

I followed all directions except I didn't fully under this sentence.
"You must first set the transmitter channel you are using to select Attitude/Manual mode so it selects the Failsafe mode as shown on the PC at least temporarily."

I started by changing the warning to 15%, turned off the radio and raised the throttle. I then turned on the radio with warning beeps and vibration, I slowly lowered the throttle until the warning stopped. I assume that's at 15%.
Then I followed the fail safe binding instructions and everything went ok.
I opened the NAZA assistant and turned off the TX but the fail safe bar area didn't highlight blue. I assume it's because I didn't understand how to follow your sentence above. I don't see any kind of fail safe menu in the radio to set it.
I tried in the warning menu and set the gear to position 1, then tried position 2 thinking that might be what your talking about setting the TX to ATTI/manual mode then setting it back to INH after everything is finished, but that didn't work, when I turn off the radio the mode control switch bar goes to Manual
Help
jasper7821 is offline Find More Posts by jasper7821
Last edited by jasper7821; Mar 05, 2012 at 11:01 PM.
Reply With Quote
Old Mar 06, 2012, 05:47 AM
MaineFlyer
jpgilbert's Avatar
Augusta, Me
Joined Feb 2005
929 Posts
jasper,
I am assuming you have an AR8000? Or some other receiver that supports Pre-set failsafe. This won't work unless you do.

I assume you have configured a switch to allow you to either select Attitude or Manual mode. When you activate this, you should see the slider go from Attitude to Manual. In the middle of the Attitude - Manual positions is the Failsafe position.

Select Manual position. Temporarily adjust your servo endpoint so that the slider arrow is in the Failsafe position instead of the Manual position. You can do that with subtrim if you wish. Just be sure that however you do it, the Failsafe area is now highlighted with the slider closer to the midpoint if possible.

Now, with the switch in the manual position and the throttle set where you want it, start the bind process for Pre-set Failsafe. Insert bind plug, power on receiver, remove bind plug, and now power on your transmitter in the bind mode with the throttle where you want it and two position switch in the manual position. After you have successfully completed this process, power everything up in the normal mode, reset the servo endpoint you changed earlier to its proper operating position, so the switch selects either Attitude or manual, not Failsafe.

Shut off your transmitter and the Failsafe area on the Naza software should now be highlighted. You're done. DON'T rebind unless you go through this process.

On my JR radio, I configured another switch that invokes a mix that will force the Naza into Failsafe anytime I want. That way. I can test Failsafe without shutting off the xmitter. If you do that, just bind with that switch on and you don't have to mess with the servo as mentioned above. Either way will give the same result.

Good luck!
Joe
jpgilbert is offline Find More Posts by jpgilbert
Reply With Quote
Old Mar 06, 2012, 09:57 AM
Registered User
United States, AZ, Tucson
Joined Mar 2008
2,195 Posts
Thank you, I will try it on a different switch. That seems safer to test it out instead of turning off the radio.
Yes, I'm using my DX8 and AR8000 rx.
So would I unplug the gear switch servo lead from the NAZA and use a free channel in the AR8000 and plug the servo lead into the gear slot on the NAZA and then make that switch active then bind as instructed. Then when finished remove that lead and put the gear lead back in.
Then hopefully in the assistant software the gear will switch from Manual to ATTI when toggled and the other switch will make the fail safe highlight?
It just doesn't seem like that would work.
I'm still confused, sorry.
jasper7821 is offline Find More Posts by jasper7821
Reply With Quote
Old Mar 06, 2012, 10:59 AM
MaineFlyer
jpgilbert's Avatar
Augusta, Me
Joined Feb 2005
929 Posts
Quote:
Originally Posted by jasper7821 View Post
Thank you, I will try it on a different switch. That seems safer to test it out instead of turning off the radio.
Yes, I'm using my DX8 and AR8000 rx.
So would I unplug the gear switch servo lead from the NAZA and use a free channel in the AR8000 and plug the servo lead into the gear slot on the NAZA and then make that switch active then bind as instructed. Then when finished remove that lead and put the gear lead back in.
Then hopefully in the assistant software the gear will switch from Manual to ATTI when toggled and the other switch will make the fail safe highlight?
It just doesn't seem like that would work.
I'm still confused, sorry.
jasper,
No need to unplug anything. Assuming you use the gear switch & channel to control Naza Attitude and Manual modes, just adjust that gear channel so the switch will select now Attitude and Failsafe. So when you throw the Gear switch from Attitude, it will now move the slider to select Failsafe instead of Manual. Then follow previous instructions to bind (with the Gear Sw in the position that will select Failsafe).

After you have successfully got binding done, you can go back and readjust the gear switch endpoints so that it will select Manual again.

Test it while PC connected to the Naza. Move the Gear Sw between Attitude and Manual. You should see Attitude then Manual highlighted. Shut off the transmitter. You should now see Failsafe highlighted.

As long as you did the bind with the throttle set as specified, you are now invoking the Naza Failsafe which will perform a controlled landing.

We are talking about two different Failsafe situations here:
One is the settings you control when you do a bind to the receiver with the transmitter throttle set as specified and the gear channel switch set to the position that moved the slider to Naza Failsafe position. Your Spektrum receiver will now go to the Pre-Set failsafe mode when it detects loss of transmitter signal.

Second is the Naza failsafe and that will be invoked when you shut off the transmitter BECAUSE the GEAR channel will go to its preset position and the throttle signal on the receiver will move to its position you set when you did the bind. That GEAR channel now puts the Naza into Failsafe.

Done!
Joe
jpgilbert is offline Find More Posts by jpgilbert
Reply With Quote
Old Mar 06, 2012, 11:26 AM
Registered User
United States, AZ, Tucson
Joined Mar 2008
2,195 Posts
Thank you very much, I'll try again when I get home. Still a bit confused though.
I don't know why I can't grasp it.
I built the quad and got the NAZA all setup and it wasn't that hard.

One more question if I may,
all the sliders go full travel when testing but sometimes the motors won't arm.
I do the CSC sequence a bunch of times and nothing happens.
I unplug the battery and plug it back in and then they will arm with the sequence.
Any suggestions.
jasper7821 is offline Find More Posts by jasper7821
Reply With Quote
Old Mar 06, 2012, 11:36 AM
Registered User
kauaicuda's Avatar
United States, MD, Frederick
Joined Aug 2010
394 Posts
I just have to point out here, on the assistant software, the failsafe area on the slider doesn't highlight. It stays gray. The arrow just needs to be below that section.
kauaicuda is offline Find More Posts by kauaicuda
Reply With Quote
Old Mar 06, 2012, 11:37 AM
MaineFlyer
jpgilbert's Avatar
Augusta, Me
Joined Feb 2005
929 Posts
Quote:
Originally Posted by jasper7821 View Post
One more question if I may,
all the sliders go full travel when testing but sometimes the motors won't arm.
I do the CSC sequence a bunch of times and nothing happens.
I unplug the battery and plug it back in and then they will arm with the sequence.
Any suggestions.
I've never had trouble but have heard others have this type of issue. Make sure your travels are set to 100% on rudder, elevator, ailerons, and throttle and all trims are centered. No subtrims. How good is your battery? Any flashes on the LED?

Joe
jpgilbert is offline Find More Posts by jpgilbert
Reply With Quote
Old Mar 06, 2012, 11:52 AM
MaineFlyer
jpgilbert's Avatar
Augusta, Me
Joined Feb 2005
929 Posts
Quote:
Originally Posted by kauaicuda View Post
I just have to point out here, on the assistant software, the failsafe area on the slider doesn't highlight. It stays gray. The arrow just needs to be below that section.
Hi kauaicuda,
You had me for a second so I connected my PC back up to the Naza and it certainly does highlight the failsafe area when I either invoke it with a switch or shut off my transmitter.

Joe
jpgilbert is offline Find More Posts by jpgilbert
Reply With Quote
Old Mar 06, 2012, 01:17 PM
Registered User
United States, AZ, Tucson
Joined Mar 2008
2,195 Posts
Everything is at 100% and the subtrims are zero.
The led is working fine, flashing yellow.
Battery for now until the 4S comes in the mail is a 2200 3S.

I don't get it.
jasper7821 is offline Find More Posts by jasper7821
Reply With Quote
Old Mar 06, 2012, 01:23 PM
DJI SUPPORT / TESTING
blade strike's Avatar
United States, CA, Big Bear
Joined Jan 2006
9,857 Posts
Quote:
Originally Posted by jpgilbert View Post
Hi kauaicuda,
You had me for a second so I connected my PC back up to the Naza and it certainly does highlight the failsafe area when I either invoke it with a switch or shut off my transmitter.

Joe
Joel, you are correct.. I even test fail safe by adding a stick input and then shutting off the TX. The software should show the stick center and then highlight the blue and go into fail safe.
blade strike is online now Find More Posts by blade strike
Site Sponsor
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Anyone did the motor redundancy test for Naza Y6 mode? as my result, it failed... Jason_cx Multirotor Talk 33 Jul 25, 2013 07:03 PM
Discussion TH9X basic set up Question dr_serious FPV Talk 2 Mar 03, 2012 12:02 PM
Discussion need help with primary gain and autolevel Mode gain rkenosha Hoverfly Technologies 5 Feb 20, 2012 03:57 PM
Discussion Al Question and Main gain question rkenosha Hoverfly Technologies 1 Feb 18, 2012 04:55 PM
Discussion basic 2.4 question - scan mode vs normal mode? MCarlton Radios 3 Aug 07, 2011 10:48 PM