HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 03, 2012, 02:07 AM
Registered User
Joined Sep 2011
7 Posts
Discussion
my Sirius Pro Former green led won't light up

Hello guys. i need help. i have a problem here. i just brought a new sirius pro former from Radical RC. but the green led won't light up when i try to form my new 8 cell nicad 700 maH batteries. i already follow all of the instructions.
and i have contact Radical RC but it not help too. do anybody have like this problem before?
edwu is offline Find More Posts by edwu
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 03, 2012, 05:57 AM
Registered User
Joined Sep 2011
7 Posts
I don't know is my former working or not but the sirius getting warm after I charge the batteries about 30 minutes and before i connected batteries the output of the sirius was 11.65 volts that I test with test meter.
this is confuse me. please do anybody have input for me?
edwu is offline Find More Posts by edwu
Reply With Quote
Old Mar 03, 2012, 09:42 AM
PGR
Low AltiDude
PGR's Avatar
United States, CA, Costa Mesa
Joined Jun 2004
7,714 Posts
The green light on a ProFormer won't come on until you have a battery pack connected to it. If the light doesn't come on when a pack is correctly connected then the ProFormer might be defective.

To see if the charger is charging you will need to check the resting voltage of the pack without the charger connected. Then connect the charger for at least an hour before you disconnect it and immediately check the pack voltage again. If the voltage is higher than it was before the hour on the charger then the charger is probably working and only the LED isn't.

Better yet, check the pack voltage while it's connected to the charger. That might be hard to do without a breakout connector, though.

Pete
PGR is offline Find More Posts by PGR
Reply With Quote
Old Mar 03, 2012, 11:58 AM
Registered User
Joined Sep 2011
7 Posts
Quote:
Originally Posted by PGR View Post
The green light on a ProFormer won't come on until you have a battery pack connected to it. If the light doesn't come on when a pack is correctly connected then the ProFormer might be defective.

To see if the charger is charging you will need to check the resting voltage of the pack without the charger connected. Then connect the charger for at least an hour before you disconnect it and immediately check the pack voltage again. If the voltage is higher than it was before the hour on the charger then the charger is probably working and only the LED isn't.

Better yet, check the pack voltage while it's connected to the charger. That might be hard to do without a breakout connector, though.

Pete
thanks Pete for your suggestion. I try to connect the voltage tester while the batteries on charging. the voltage was slowly getting up for sure and the voltage stop until 1.45volt each cell after its charging for 6 hours. is that mean the former was working without the led light up?
edwu is offline Find More Posts by edwu
Reply With Quote
Old Mar 03, 2012, 06:00 PM
PGR
Low AltiDude
PGR's Avatar
United States, CA, Costa Mesa
Joined Jun 2004
7,714 Posts
It sounds like the former is working, but the key words here are "sounds like." If this is a new item I'd push for a replacement. If the vendor you bought it from won't help you then you should contact Peak Electronics directly and explain the situation.

Pete
PGR is offline Find More Posts by PGR
Reply With Quote
Old Mar 03, 2012, 07:15 PM
Registered User
Joined Sep 2011
7 Posts
Quote:
Originally Posted by PGR View Post
It sounds like the former is working, but the key words here are "sounds like." If this is a new item I'd push for a replacement. If the vendor you bought it from won't help you then you should contact Peak Electronics directly and explain the situation.

Pete
I know what you mean about "sounds like" i actually don't know is the former working properly to form my batteries or not. I have email the Peak yesterday ask for technical help.
but the problem is i'm not in the US. I am Indonesian and sending or receiving the former for service will be waste the money.
edwu is offline Find More Posts by edwu
Reply With Quote
Old Mar 03, 2012, 09:05 PM
PGR
Low AltiDude
PGR's Avatar
United States, CA, Costa Mesa
Joined Jun 2004
7,714 Posts
Well, sorry I can't be much more help. I will say this, though: I have 2 Pro Formers that I've been using for years and mine seem to be bulletproof.

Consider this option: I opened one of mine up years ago to see what was inside and I don't recall anything particularly mysterious or proprietary in there. In your case you might want to check for a bad LED or something and repair it yourself. If that's not your forte then perhaps you can find a local wizard to do it for you.

Pete
PGR is offline Find More Posts by PGR
Reply With Quote
Old Mar 03, 2012, 09:29 PM
Registered User
Joined Sep 2011
7 Posts
Quote:
Originally Posted by PGR View Post
Well, sorry I can't be much more help. I will say this, though: I have 2 Pro Formers that I've been using for years and mine seem to be bulletproof.

Consider this option: I opened one of mine up years ago to see what was inside and I don't recall anything particularly mysterious or proprietary in there. In your case you might want to check for a bad LED or something and repair it yourself. If that's not your forte then perhaps you can find a local wizard to do it for you.

Pete
Yea. Peak product must be "bullet prof" beside pro former I have another Peak product. I have Sirius pro plus, Sirius limited edition and super test too. :-)
umm. I have opened the former too. its so simple inside just a little parts in there. I have thinks to check one by one of the parts if I not have a solusion. :-)
edwu is offline Find More Posts by edwu
Reply With Quote
Old Mar 03, 2012, 09:36 PM
Registered User
Joined Sep 2011
7 Posts
oh yea Pete. thanks for your kindness for try to help me. maybe I must check the parts one by one to search if one of the parts broken.

eddy
edwu is offline Find More Posts by edwu
Reply With Quote
Old Mar 04, 2012, 09:08 AM
PGR
Low AltiDude
PGR's Avatar
United States, CA, Costa Mesa
Joined Jun 2004
7,714 Posts
The first thing I'd check is whether the LED is installed backwards. It is a diode so it won't work if the polarity is incorrect.

Pete
PGR is offline Find More Posts by PGR
Reply With Quote
Old Mar 04, 2012, 08:49 PM
Registered User
Joined Sep 2011
7 Posts
Quote:
Originally Posted by PGR View Post
The first thing I'd check is whether the LED is installed backwards. It is a diode so it won't work if the polarity is incorrect.

Pete
yesterday i have check it. no problem with the led but i suspicious the diode. i know every charger have four diode with the same number and resistance. but what i found is that one diode have a different number from the others and i test it with test meter and its broken too. i just thinking reputed Peak Electronics can do a mistakes too. have they QC the product before release it to the market. this is must be a human error. :-)
edwu is offline Find More Posts by edwu
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Found wanted sirius pro former edwu Aircraft - Electric - Batteries & Chargers (FS/W) 0 Dec 23, 2011 07:49 PM
Discussion AR6200 Receiver Won't Light Up At All rtbchris Multirotor Talk 7 Dec 22, 2011 05:33 PM
Discussion My flap servo won't go up anymore? surf1punk Electric Plane Talk 3 Dec 13, 2011 11:02 AM
Sold FS or Trade Sirius Charge Pro Plus and Pro-Former (PRICE REDUCED) pmccleave Aircraft - Electric - Batteries & Chargers (FS/W) 5 Nov 22, 2009 08:49 PM
Help! Green light won't come on when my Aero Ace is charging! BD Flyer Micro Ready-to-Fly 12 Jan 03, 2007 03:12 PM