HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 01, 2012, 08:07 PM
AMA# SIMAGES
simages's Avatar
Hudson Valley
Joined Dec 2006
2,330 Posts
Help!
ESCs will not arm using DX7 or my 9C TM8

My original project includes a GWS IPS-S2 (GW/IPS-DX2BB-2XCS), a CC Pixie 7P wired to an AR6400L.

The system binds, works the servos, but will not arm the ESC. It just blinks on and off so, I thought my wiring to the AR6400L was weak.
Made a new plug wiring, rechecked all my radio settings ie throttle NOR vs REV as well as the arming procedure low 1.5 seconds - move to WOT back to low......
Regardless ESC only blinks with NO beeps. Therefore still would not arm nor will it go into setup mode per steps.

So, I thought I had a bad Pixie 7P, swapped with an ElectriFly C-12 connected to the AR6400L.... No go, same problem.

So, I then bench tested the Pixie 7P using an AR500 and it would bind, control servos, but would just blink as well.

I tested both the Pixie 7P and ElectriFly C-12 using a new AR6400L and an AR500 and both ESCs just blink...... happened with both my Transmitters!

I guess it's not the AR6400L

I can not find the problem, it does it with both my DX7 and my Spektrum converted Futaba 9C with the Spektrum TM8 module.....
simages is online now Find More Posts by simages
RCG Plus Member
Sign up now
to remove ads between posts
Old Mar 01, 2012, 09:12 PM
Registered User
Toronto Canada
Joined Dec 2002
5,411 Posts
In what position is your throttle trim and subtrim?
Martyn McKinney is offline Find More Posts by Martyn McKinney
Reply With Quote
Old Mar 01, 2012, 09:21 PM
AMA# SIMAGES
simages's Avatar
Hudson Valley
Joined Dec 2006
2,330 Posts
Trim all the way down and tried subtrim set at 0, tried the sub-trim set at 120 as well
simages is online now Find More Posts by simages
RCG Plus Member
Old Mar 01, 2012, 10:04 PM
Canadian Bacon
flypaper 2's Avatar
Kingston, Canada
Joined Jun 2004
12,742 Posts
It's the lower throttle endpoint that you need. It's at 100% now. Try lowering it towards 150% and you'll hear the bleep as the ESC arms.

Gord.
flypaper 2 is online now Find More Posts by flypaper 2
Reply With Quote
Old Mar 02, 2012, 01:38 AM
Suspended Account
Panorama City, CA
Joined Sep 2004
5,566 Posts
Try minus 120 on subtrim.
John Kim is offline Find More Posts by John Kim
Reply With Quote  (Disabled)
Old Mar 02, 2012, 06:15 AM
AMA# SIMAGES
simages's Avatar
Hudson Valley
Joined Dec 2006
2,330 Posts
Quote:
Originally Posted by flypaper 2 View Post
It's the lower throttle endpoint that you need. It's at 100% now. Try lowering it towards 150% and you'll hear the bleep as the ESC arms.Gord.
Quote:
Originally Posted by John Kim View Post
Try minus 120 on subtrim.
I did try the 150+- on the DX7 and 120 +- on the Futaba 9C Spektrum so, I'm going to create "new" models and start over again.......

It's driving me nuts!!!!
simages is online now Find More Posts by simages
RCG Plus Member
Old Mar 02, 2012, 07:18 AM
who put that tree there
dazza44's Avatar
Joined Jun 2010
808 Posts
check all solder joints on esc..
dazza44 is offline Find More Posts by dazza44
Reply With Quote
Old Mar 02, 2012, 07:26 AM
AMA# SIMAGES
simages's Avatar
Hudson Valley
Joined Dec 2006
2,330 Posts
Quote:
Originally Posted by dazza44 View Post
check all solder joints on esc..
I will check again..... I did redo the wiring with new as well as another new nano plug. The thing is..... I actually tried 2 ESCs with the same results....
simages is online now Find More Posts by simages
RCG Plus Member
Old Mar 02, 2012, 07:39 AM
who put that tree there
dazza44's Avatar
Joined Jun 2010
808 Posts
dont sound good... reversed throttle ??
dazza44 is offline Find More Posts by dazza44
Reply With Quote
Old Mar 02, 2012, 08:11 AM
AMA# SIMAGES
simages's Avatar
Hudson Valley
Joined Dec 2006
2,330 Posts
Quote:
Originally Posted by dazza44 View Post
dont sound good... reversed throttle ??
I know it's nuts..... and I have tried the NOR - REV on both radios..... not suppose to be that many moving parts...
simages is online now Find More Posts by simages
RCG Plus Member
Old Mar 02, 2012, 01:47 PM
We want... Information!
Bruce Abbott's Avatar
Hastings, New Zealand
Joined Jan 2001
5,182 Posts
Quote:
Originally Posted by simages View Post
Regardless ESC only blinks with NO beeps.

I thought I had a bad Pixie 7P, swapped with an ElectriFly C-12 connected to the AR6400L.... No go, same problem.
The beep sounds that you normally hear come from the motor. So, either you have two faulty ESC's, or...

The motor (or its connector/wiring) is faulty.
Bruce Abbott is offline Find More Posts by Bruce Abbott
Reply With Quote
Old Mar 02, 2012, 01:57 PM
AMA# SIMAGES
simages's Avatar
Hudson Valley
Joined Dec 2006
2,330 Posts
Quote:
Originally Posted by Bruce Abbott View Post
The beep sounds that you normally hear come from the motor. So, either you have two faulty ESC's, or...
The motor (or its connector/wiring) is faulty.
Thanks for that.... I will recheck the wiring and capacitors when I get home....
simages is online now Find More Posts by simages
RCG Plus Member
Old Mar 02, 2012, 02:14 PM
Registered User
Neenah, WI
Joined May 2006
386 Posts
...CC Pixie 7P...
This ESC may have a "Safe "Power On" feature". Does your ESC require/use an arming sequence (series of throttle-stick movements to activate the throttle-control)?
gyrocptr is offline Find More Posts by gyrocptr
Reply With Quote
Old Mar 02, 2012, 02:58 PM
AMA# SIMAGES
simages's Avatar
Hudson Valley
Joined Dec 2006
2,330 Posts
Quote:
Originally Posted by gyrocptr View Post
...CC Pixie 7P...
This ESC may have a "Safe "Power On" feature". Does your ESC require/use an arming sequence (series of throttle-stick movements to activate the throttle-control)?
Yes it's low, plug in battery leave in low "off" position at least 1.5 sec, then WOT "up", then back to low..... ElectricFly is the same to arm.
simages is online now Find More Posts by simages
RCG Plus Member
Old Mar 02, 2012, 09:44 PM
Registered User
Joined May 2009
217 Posts
I've had esc's with a DX7 and have had to set my throttle to medium before plugging in esc. Then full power and then all the way down for it to arm.
seair is offline Find More Posts by seair
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Turnigy and Hobbywing ESCs will not arm helipk Power Systems 8 May 25, 2011 12:29 PM
Discussion E-Flite Pro 25 ESC - will not arm with Futaba 9C - Fixed Henna_Ojisan Power Systems 29 May 05, 2011 01:04 AM
Help! Sidewinder ESC will not Calibrate or Arm bluesxman Castle Creations 7 Jun 22, 2008 05:34 PM
Question Should I XPS my 9C or get a DX7? Bill K. Radios 39 Aug 15, 2007 10:30 AM
Discussion Need help.....CC-45hv will not arm or recognize throttle ericnord Electric Heli Talk 11 Jun 20, 2006 05:29 AM