Espritmodel.com Telemetry Radio
Reply
Thread Tools
Old Feb 13, 2012, 01:01 AM
Registered User
Joined Feb 2012
3 Posts
Discussion
HK - quad control bard 4.7fw gyro reversing again.

Hello!!

First let me introduce my self. My name is Martin, and for about a year I'm learning my new hobby - RC (mostly helis - i have now a T-rex 550) but also playing with quds and planes.

About a half year ago I started to build my own design quad. Using some aluminum and laminate I've created a frame. I bought 4 engines, ECS, and propellers from HK put in a lipo and a HK quad control board (v1 with 48p) and went to the sky's with no problems.

And that was the end of my quads being nice.

So after first success I wanted to update my quad a little - lets change firmware - and that where my problems started.

First I was trying to flush my original board, with KKflashtool, but as it uses a 48p not an 48 atmega it didn't want to flush. So I used an extream burner to flash the chip. All (programing) wen't well but.. (KKtool is only able to successful load the 1 sec test, all other fail)

I wanted to flush with xquad and went with the kapteinkuk's 4.7fw. Flashed ok but the board does not react both on throttle input (only constant engine speed, about 1/3 of power), and esc programing and gyro reversing, esc out of sync (a small delay on every esc). I was able to arm the board, but setting any combination of pots did not put the board in any programing state.

Flashed with quad 4.5 - the same reaction but now the quad responds to throttle - but flips with a left to right roll. Not able to revers gyro, or program throttle range.

Exchanged the Atmega 48p to 328p. Programed xquad 4.7fw - the same reaction as re-flashed 4.5 quad (throttle ok, flips, can not reverse gyro's or set esc range)

I've already tried to search for solution bot nothing helps so far

I've read this http://www.rcgroups.com/forums/showthread.php?t=1458663 but I'm on page 13 and there's a lot to read till the end....

I've read this http://www.rcgroups.com/forums/showt...gyro+reversing - the problem looks similar, but that thread did not solve the problem on 4.7fw.

I know the reversing instruction http://www.rcgroups.com/forums/showp...5&postcount=88 but it simply does not work.... And I've tried all pots in all directions (both 0 and 100% on all combination of pots) - always only one flash, and I'm able to arm.

Sort overview and setup

HK quad control board v1 (Atmega 48p) with original 4.5fw ok.
Flashed 4.7 (Atmega 48p) xquad, no throttle, elev, roll response (seams to set the power to 1/3 constant), can arm, quickly rolls to right, not able to reverse or set esc range, out of sync.
Fleshed 4.7 (Atmega 48p) quad, throttle response ok, rolls to right, not able to reverse or set esc range, slight out of sync.
Flashed 4.5 (Atmega 48p) quad, throttle response ok, rolls to right, not able to reverse or set esc range.
Exchanged atmega to 328p
Fleshed 4.7 (Atmega 328p) xquad, throttle, elev, roll response ok, rolls to right, not able to reverse or set esc range (any combination of pots get's only one blink).

On all firmwares after the original one the reaction to gyro check (quad at 1/3 power in hand and try to move it) is very little, 1 engine seams to be push stronger, then the 2 one, then 3 and 4. Applying force does not seam to change much (on first 4.5 the reaction was very noticeable).

Setup

HobbyKing Quadcopter Control Board
4x Turnigy L2215J-900
HK 9x5 Propellers
TURNIGY Plush 30amp Speed Controller
Powered with 3s Lipos (2400 to 5000mAh)

Spectrum DX6i (reverses set on original 4.5 work fine, and direction check works ok)
OrangeRX 6ch receiver.

Tested both 1sec and 1 minute clock test (a little faster on the 328p).

Please help or advise a different FW to test.
qemay is offline Find More Posts by qemay
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 13, 2012, 09:21 AM
AVR Dude
United Kingdom, England, Cnwll
Joined Jul 2011
1,603 Posts
As far as I know, you have to have another version of the code for your processor. The V4.7 ATMega48 code will only work on the ATMega48. The 168 code may work on your setup. But, I may be wrong....... See post #1101 here

http://www.rcgroups.com/forums/showt...8#post20363785
Steveis is online now Find More Posts by Steveis
RCG Plus Member
Old Feb 13, 2012, 09:47 AM
Registered User
VA
Joined Nov 2009
2,634 Posts
There is nothing wrong with the original kk4.7 Xquad firmware. It is available in both 48 and 328 versions. I am pretty sure I have read that with the hk board you have to reverse a gyro so you need to get that functioning. Have you tried booting the board up with pots rotated fully to both ends of travel? Some boards have pot rotation reversed. Since you have upgraded the chip in the end you can always pick up a serial lcd display and put xx1.5hX on it and not have to worry about pots any more. All settings are in lcd menu as well as a few extras plus diagnostics.

If the flash tool allows using the -F software switch it will ignore the signature mismatch and flash the chip anyway

Quote:
Originally Posted by qemay View Post
Hello!!

First let me introduce my self. My name is Martin, and for about a year I'm learning my new hobby - RC (mostly helis - i have now a T-rex 550) but also playing with quds and planes.

About a half year ago I started to build my own design quad. Using some aluminum and laminate I've created a frame. I bought 4 engines, ECS, and propellers from HK put in a lipo and a HK quad control board (v1 with 48p) and went to the sky's with no problems.

And that was the end of my quads being nice.

So after first success I wanted to update my quad a little - lets change firmware - and that where my problems started.

First I was trying to flush my original board, with KKflashtool, but as it uses a 48p not an 48 atmega it didn't want to flush. So I used an extream burner to flash the chip. All (programing) wen't well but.. (KKtool is only able to successful load the 1 sec test, all other fail)

I wanted to flush with xquad and went with the kapteinkuk's 4.7fw. Flashed ok but the board does not react both on throttle input (only constant engine speed, about 1/3 of power), and esc programing and gyro reversing, esc out of sync (a small delay on every esc). I was able to arm the board, but setting any combination of pots did not put the board in any programing state.

Flashed with quad 4.5 - the same reaction but now the quad responds to throttle - but flips with a left to right roll. Not able to revers gyro, or program throttle range.

Exchanged the Atmega 48p to 328p. Programed xquad 4.7fw - the same reaction as re-flashed 4.5 quad (throttle ok, flips, can not reverse gyro's or set esc range)

I've already tried to search for solution bot nothing helps so far

I've read this http://www.rcgroups.com/forums/showthread.php?t=1458663 but I'm on page 13 and there's a lot to read till the end....

I've read this http://www.rcgroups.com/forums/showt...gyro+reversing - the problem looks similar, but that thread did not solve the problem on 4.7fw.

I know the reversing instruction http://www.rcgroups.com/forums/showp...5&postcount=88 but it simply does not work.... And I've tried all pots in all directions (both 0 and 100% on all combination of pots) - always only one flash, and I'm able to arm.

Sort overview and setup

HK quad control board v1 (Atmega 48p) with original 4.5fw ok.
Flashed 4.7 (Atmega 48p) xquad, no throttle, elev, roll response (seams to set the power to 1/3 constant), can arm, quickly rolls to right, not able to reverse or set esc range, out of sync.
Fleshed 4.7 (Atmega 48p) quad, throttle response ok, rolls to right, not able to reverse or set esc range, slight out of sync.
Flashed 4.5 (Atmega 48p) quad, throttle response ok, rolls to right, not able to reverse or set esc range.
Exchanged atmega to 328p
Fleshed 4.7 (Atmega 328p) xquad, throttle, elev, roll response ok, rolls to right, not able to reverse or set esc range (any combination of pots get's only one blink).

On all firmwares after the original one the reaction to gyro check (quad at 1/3 power in hand and try to move it) is very little, 1 engine seams to be push stronger, then the 2 one, then 3 and 4. Applying force does not seam to change much (on first 4.5 the reaction was very noticeable).

Setup

HobbyKing Quadcopter Control Board
4x Turnigy L2215J-900
HK 9x5 Propellers
TURNIGY Plush 30amp Speed Controller
Powered with 3s Lipos (2400 to 5000mAh)

Spectrum DX6i (reverses set on original 4.5 work fine, and direction check works ok)
OrangeRX 6ch receiver.

Tested both 1sec and 1 minute clock test (a little faster on the 328p).

Please help or advise a different FW to test.
pug398 is offline Find More Posts by pug398
Reply With Quote
Old Feb 13, 2012, 11:42 AM
AVR Dude
United Kingdom, England, Cnwll
Joined Jul 2011
1,603 Posts
Perhaps I shouldn't have used the word version. V4.7 for ATMega48 will not work on an ATMega328. You need V4.7 for ATMega328.
Steveis is online now Find More Posts by Steveis
RCG Plus Member
Old Feb 13, 2012, 12:49 PM
Registered User
Joined Feb 2012
3 Posts
No I have not used the wrong version. I used the M48_M88 version for the atmega 48 and the M168_M328 for the atmega 328P. Additionally if it would not work then it would also not arm, and it does in all cases... The package has both versions included, I only need to flash the right one. Also the 48 should work fine on the 328... the difference in those chips is the memory they have available, the fuses are set differently but if those would be wrong then it should not work at all.

The fuse bits are set according to this http://www.kkmulticopter.com/index.php?option=com_content&view=article&id=91r ogramming-the-ic-with-extreme-burner&catid=50rogramming-the-ic&Itemid=65 - and 1 minute test works fine (is a little fast but it should be ok as I read)

I know about the -f switch but I can not pass it through the kkflashtool.

And as I already wrote, I've tried all possible pot configuration.

Y50 P0 R50 - 1blink, 3+1 beaps form esc, arms fine

Y0 P0 R50 - 1blink, 3+1 beaps form esc, arms fine (no esc range set)
Y100 P0 R50 - 1blink, 3+1 beaps form esc, arms fine (no esc range set)
Y0 P50 R50 - 1blink, 3+1 beaps form esc, arms fine (no esc range set)
Y100 P50 R50 - 1blink, 3+1 beaps form esc, arms fine (no esc range set)

Y50 P0 R0 - 1blink, 3+1 beaps form esc, arms fine (no gyro reversing)
Y50 P0 R100 - 1blink, 3+1 beaps form esc, arms fine (no gyro reversing)
Y50 P50 R0 - 1blink, 3+1 beaps form esc, arms fine (no gyro reversing)
Y50 P50 R100 - 1blink, 3+1 beaps form esc, arms fine (no gyro reversing)

I will try to find a serial lcd as my brother should have one. Where can I find a good fw to use it with?

And I know that the lcd I can have is not a serial one, so no luck here
qemay is offline Find More Posts by qemay
Last edited by qemay; Feb 14, 2012 at 01:19 AM.
Reply With Quote
Old Feb 13, 2012, 01:52 PM
Registered User
VA
Joined Nov 2009
2,634 Posts
deleted...double post
pug398 is offline Find More Posts by pug398
Reply With Quote
Old Feb 15, 2012, 06:08 AM
Registered User
Joined Feb 2012
3 Posts
As suggested somewhere else today I removed the pots and checked if the readings are ok.. They are correct within .3kohm.

The fuse bits on the atmega 328P are set like this
low E2
high D9
Ex FE
lock FF (default)
calibration FFFFFF85 (default)

Can someone confirm if those are set as they should?
qemay is offline Find More Posts by qemay
Last edited by qemay; Feb 15, 2012 at 12:02 PM.
Reply With Quote
Old Mar 27, 2012, 11:38 AM
Registered User
Joined Mar 2012
6 Posts
I have also the same problem with 4.7 version, as I give accelleration, first motor1 starts, after increasing speed motor2 starts, and so on. Does anyone know the solution of this?
Dengesiz is offline Find More Posts by Dengesiz
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold E-flite EFLH1024 4-in1 Control Unit Rx/ESC/Mixer/Gyro 2.4 Ghz NEW! tprada1624 Aircraft - General - Radio Equipment (FS/W) 1 Dec 29, 2011 11:11 AM
Sold E-flite EFLH1024 4-in1 Control Unit Rx/ESC/Mixer/Gyro 2.4 Ghz NEW tprada1624 Aircraft - Electric - Power Systems (FS/W) 0 Oct 22, 2011 04:32 PM
e flight 4 in 1 control unit gyro dr rc Non R/C Items (FS/W) 3 Apr 29, 2011 05:46 PM
Discussion Reversing shaft on Scorpion HK 4025 890KV emillard Power Systems 0 Apr 25, 2011 07:56 PM
Help! Tricopter XXcontrol_KR Firmware Gyro Reversing Issue ArrowX Multirotor Talk 13 Apr 17, 2011 02:21 PM