New Products Flash Sale
Thread Tools
Old Oct 07, 2012, 10:36 AM
LanceMc is online now
Find More Posts by LanceMc
Certified Wingnut
LanceMc's Avatar
Delta BC
Joined Jul 2008
381 Posts
omega bearings

Hi guys. I'm running an Omega 130 in my 47" Extra. The motor is making some strange sounds. I think the bearings are going/gone. I searched the forums for a bearing replacement and found Boca bearings. My question is What is the difference between the regular bearings and ceramic? Which do you recommend?
Thanks
Lance
LanceMc is online now Find More Posts by LanceMc
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 07, 2012, 11:07 AM
nebwake is online now
Find More Posts by nebwake
Registered User
nebwake's Avatar
United States, NE, Lincoln
Joined Mar 2011
726 Posts
The ceramic will last longer. I replaced my stock 130's bearings with ceramic bocas and am happy although I haven't noticed a difference in performance.
nebwake is online now Find More Posts by nebwake
Reply With Quote
Old Oct 07, 2012, 11:12 AM
Bigster is online now
Find More Posts by Bigster
Well, now that you know ...
Bigster's Avatar
Grafton, Massachusetts, United States
Joined Sep 2004
6,224 Posts
I replaced the bearings with Boca's ceramics in my Omega 103. It was much quieter until I had a prop strike. I found another company that sells replacements for a couple bucks (non ceramic) and figured I'd try them. I haven't pulled the motor out and borrowed the arbor press to try them yet though.
Bigster is online now Find More Posts by Bigster
Reply With Quote
Old Oct 07, 2012, 11:52 AM
LanceMc is online now
Find More Posts by LanceMc
Certified Wingnut
LanceMc's Avatar
Delta BC
Joined Jul 2008
381 Posts
Quote:
Originally Posted by nebwake View Post
The ceramic will last longer. I replaced my stock 130's bearings with ceramic bocas and am happy although I haven't noticed a difference in performance.
Quote:
Originally Posted by Bigster View Post
I replaced the bearings with Boca's ceramics in my Omega 103. It was much quieter until I had a prop strike. I found another company that sells replacements for a couple bucks (non ceramic) and figured I'd try them. I haven't pulled the motor out and borrowed the arbor press to try them yet though.
Thanks guys. I took a video of the situation. Could you please take a look/listen, and tell me if this is a bearing problem?
Omega 130 (0 min 21 sec)

Thanks again
Lance
LanceMc is online now Find More Posts by LanceMc
Reply With Quote
Old Oct 07, 2012, 12:04 PM
Bigster is online now
Find More Posts by Bigster
Well, now that you know ...
Bigster's Avatar
Grafton, Massachusetts, United States
Joined Sep 2004
6,224 Posts
The 130 in my 47" Edge and 103 in my Slick sound exactly like that. The 130 in my Vyper is perfectly quiet. The advice I was given was "Fly it.".
Bigster is online now Find More Posts by Bigster
Reply With Quote
Old Oct 07, 2012, 12:11 PM
quadracer is online now
Find More Posts by quadracer
No, I won't ship it. Don't ask
quadracer's Avatar
United States, IN, Derby
Joined Feb 2012
4,716 Posts
Quote:
Originally Posted by LanceMc View Post
Thanks guys. I took a video of the situation. Could you please take a look/listen, and tell me if this is a bearing problem?
http://www.youtube.com/watch?v=0uk8Q9EAFv0
Thanks again
Lance
Is your prop balanced? Sounds like it might be a bit heavy on one end.
quadracer is online now Find More Posts by quadracer
Reply With Quote
Old Oct 07, 2012, 12:57 PM
LanceMc is online now
Find More Posts by LanceMc
Certified Wingnut
LanceMc's Avatar
Delta BC
Joined Jul 2008
381 Posts
Quote:
Originally Posted by Bigster View Post
The 130 in my 47" Edge and 103 in my Slick sound exactly like that. The 130 in my Vyper is perfectly quiet. The advice I was given was "Fly it.".
That's good to know The 130 I have in my Osiris is perfectly quiet, and this one started quiet, so I thought something was wrong

Quote:
Originally Posted by quadracer View Post
Is your prop balanced? Sounds like it might be a bit heavy on one end.
Yes the prop is balanced, but The spinner isn't. Perhaps that's the problem? Maybe, I'll try it without the spinner?

Thanks guys
Lance
LanceMc is online now Find More Posts by LanceMc
Reply With Quote
Old Oct 07, 2012, 01:23 PM
going4speed is offline
Find More Posts by going4speed
3DHS 'native'
going4speed's Avatar
USA, TX, Spring
Joined Jan 2008
5,935 Posts
sounds like a possible timing issue
going4speed is offline Find More Posts by going4speed
Reply With Quote
Old Oct 07, 2012, 02:02 PM
keithy4129 is offline
Find More Posts by keithy4129
Registered User
United States, NJ, Clayton
Joined Aug 2010
1,580 Posts
Quote:
Originally Posted by LanceMc View Post
Thanks guys. I took a video of the situation. Could you please take a look/listen, and tell me if this is a bearing problem?
http://www.youtube.com/watch?v=0uk8Q9EAFv0
Thanks again
Lance
you my friend have the "omega knock" I have seen this in several different omegas, just fly it, I have seen them last a long time with that noise and I have had one snap in half and another that burned up with that noise, for now on I buy hacker or Motrolfly
keithy4129 is offline Find More Posts by keithy4129
Reply With Quote
Old Oct 07, 2012, 02:25 PM
H.D. is offline
Find More Posts by H.D.
ride hard and fly low
H.D.'s Avatar
Joined Aug 2011
585 Posts
yep, it's the "omega knock"
H.D. is offline Find More Posts by H.D.
Reply With Quote
Old Oct 07, 2012, 03:00 PM
Luv3d is online now
Find More Posts by Luv3d
Honeybadger don't care...
Luv3d's Avatar
United States, FL, Winter Park
Joined May 2010
2,163 Posts
Might be dirty bearings. You can clean the bearings, repack and replace, or I have a video about how to replace them here:

How to replace Omega130 bearings (5 min 0 sec)


I believe Boca Bearings Ceramics run smoother- I would recommend the ABEC 5 bearings. I put them in my Omega, and no more rattle- it was very smooth last time I flew it.
Luv3d is online now Find More Posts by Luv3d
Reply With Quote
Old Oct 07, 2012, 06:21 PM
3Daddict is offline
Find More Posts by 3Daddict
Addicted to 3DHS and EF
3Daddict's Avatar
United States, OH, Bristolville
Joined Oct 2010
5,031 Posts
my airplane rack.
Name: IMG_3143.jpg
Views: 100
Size: 236.3 KB
Description:
3Daddict is offline Find More Posts by 3Daddict
Reply With Quote
Old Oct 07, 2012, 06:22 PM
quadracer is online now
Find More Posts by quadracer
No, I won't ship it. Don't ask
quadracer's Avatar
United States, IN, Derby
Joined Feb 2012
4,716 Posts
Quote:
Originally Posted by 3Daddict View Post
my airplane rack.
Attachment 5214211
That looks like some of my landings in the past.... LOL
quadracer is online now Find More Posts by quadracer
Reply With Quote
Old Oct 07, 2012, 06:29 PM
3Daddict is offline
Find More Posts by 3Daddict
Addicted to 3DHS and EF
3Daddict's Avatar
United States, OH, Bristolville
Joined Oct 2010
5,031 Posts
You must have some rough landings then
3Daddict is offline Find More Posts by 3Daddict
Reply With Quote
Old Oct 07, 2012, 06:30 PM
quadracer is online now
Find More Posts by quadracer
No, I won't ship it. Don't ask
quadracer's Avatar
United States, IN, Derby
Joined Feb 2012
4,716 Posts
I've hung them in the trees a couple times.... Don't hate.
quadracer is online now Find More Posts by quadracer
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Unofficial NQD Tear Into Jet Boat Mod Thread Energy Racing Boats - Electric 14233 Today 10:51 AM
Discussion Banana Hobby Customer Support Request/Q and A Thread! banana hobby Banana Hobby 1148 Jul 22, 2015 02:37 PM
Discussion The Official AirWare Q&A Thread AndyKunz Radios 95 Feb 14, 2013 08:36 AM
Discussion THE FIRST UNOFFICIAL Parkzone Sukhoi mods thread!!!! bluemeane Micro Ready-to-Fly 27 Aug 17, 2009 11:23 PM
Megatech H2O unofficial thread and first rewiew. grk65 Racing Boats - Electric 7 Mar 05, 2007 12:09 AM