HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 17, 2003, 07:02 PM
Registered User
Walled Lake, MI, USA
Joined Feb 2000
11,182 Posts
Haldor, have you seen Gary's probable explanation for what went wrong?

http://www.rcgroups.com/forums/showt...71#post1400471
Dave Hederich is offline Find More Posts by Dave Hederich
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 17, 2003, 07:27 PM
Registered User
Joined Jan 2002
6,587 Posts
Steve,

You may be literally playing with fire running so many LiPos on such small wire.

While 10 amp wire may be OK for a single 2s pack of 1500 LiPos, your 7s14p pack will deliver 42 amps and over 1100 watts at a 2C discharge rate.

- RD
RD Blakeslee is offline Find More Posts by RD Blakeslee
Reply With Quote
Old Oct 17, 2003, 07:57 PM
Carbon fiber is our friend
Steve C's Avatar
United States, CA, Lodi
Joined Feb 2001
4,204 Posts
My plane is pulling 40 amps WOT on a full charge. As Cue said, these cells knocked a pound out of the plane vs. CP2400's. That's a lot

I didn't keep the wire that small all the way to the plug. I joined them together as the cells connected, then went to 13g wire from there. So the small wires "only" need to carry 10 amps from each cell to the large wire. Still, it seems like a lot for the little wire, but so far it's working ok.

Since I don't keep full throttle on for more than about 10 seconds at the most, maybe that helps. It keeps the motor temps down too.

Just to be sure of what I'm getting, I think I'll buy single cells and assemble packs myself in the future.

Steve C
Steve C is offline Find More Posts by Steve C
Reply With Quote
Old Oct 17, 2003, 08:07 PM
Registered User
Walled Lake, MI, USA
Joined Feb 2000
11,182 Posts
>> I think I'll buy single cells and assemble packs myself in the future.

Just be sure to read the following thread!

http://www.rcgroups.com/forums/showt...hreadid=160551
Dave Hederich is offline Find More Posts by Dave Hederich
Reply With Quote
Old Oct 17, 2003, 11:05 PM
EDF Head
Haldor's Avatar
Stavanger, Norway
Joined Feb 2000
7,999 Posts
Quote:
Originally posted by Dave Hederich
Haldor, have you seen Gary's probable explanation for what went wrong?

http://www.rcgroups.com/forums/showt...71#post1400471
Not until now. As far as I can tell from what I'read here on the Ezone regarding LiPo failures the majority are due to user error of some sort. Electronic devices are never 100% safe no matter what so by taking appropriate measures you can almost eliminate damage outside the pack itself (Firesafe charging station)

What I like about LiPo:

1 - Weight
2 - Capacity

What I dont like:

1 - Very voltage sensitive, volatile nature if exposed to over voltage
2 - Less robust physically, cell itself + tabs that break easily.

Based on that I simply dont trust them anymore and would be afraid by having them in my house. Besides I'm content with what NiHM's have to offer

I'm glad though that Gary seem to have found his source of failure, things like that are to our benefit.
Haldor is offline Find More Posts by Haldor
Reply With Quote
Old Oct 18, 2003, 01:10 AM
aka Anthony
Xoltri's Avatar
Edmonton, Alberta
Joined Jul 2002
1,005 Posts
Quote:
Originally posted by kelvin

4. The only way you are getting my Lipos is prying them out of my cold dead fingers

Kelvin
How about charred, hot, burning fingers from a lipo fire?


I am about to purchase some lipos next week for my hummingbird. Wish me luck
Xoltri is offline Find More Posts by Xoltri
Last edited by Xoltri; Oct 18, 2003 at 01:19 AM.
Reply With Quote
Reply


Thread Tools