HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 30, 2011, 03:38 PM
Electric foamy flyer
fly Frontier's Avatar
Chandler, Arizona
Joined Apr 2010
306 Posts
Help!
Hitec Optic 6 2.4 Sport Problem. HELP

Today my Hitec Optic 6 2.4 Sport radio is acting funny. When i plugged in my 7.2v lipo, I accidently plugged in the polarity backwards, turned it on, quickly turned it off, then fixed the plug, and thats when the problem started.

I Turn Tx on and then Rx on the plane, I get a connection beep from the tx and lights indicate a link. However all the servos shoot in one direction and stop, also the motor makes a few beeps i have never heard. No control surface or motor response. If i go into programing and adjust the Sub Trim of the servos, they respond to the adjustment but still no stick movement response. Also I believe most Program mixes etc... do work.

I have re-Binded the receivers and tried it on different airplanes and my Heli. same problem. Could this be a factor: When i plugged in my 7.2v lipo, I accidently plugged in the polarity backwards, turned it on, quickly turned it off, then fixed it, and thats when the problem started.

What can i do? is my radio fried? can i get a warrenty? Also i did not purchase this radio, i won it in a contest.


Thanks for the help

Daniel
fly Frontier is offline Find More Posts by fly Frontier
Last edited by fly Frontier; Dec 30, 2011 at 05:23 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 30, 2011, 06:47 PM
Registered User
Joined Aug 2002
5,811 Posts
Quote:
Originally Posted by fly Frontier View Post
Today my Hitec Optic 6 2.4 Sport radio is acting funny. When i plugged in my 7.2v lipo, I accidently plugged in the polarity backwards, turned it on, quickly turned it off, then fixed the plug, and thats when the problem started. I Turn Tx on and then Rx on the plane, I get a connection beep from the tx and lights indicate a link. However all the servos shoot in one direction and stop, also the motor makes a few beeps i have never heard. No control surface or motor response. If i go into programing and adjust the Sub Trim of the servos, they respond to the adjustment but still no stick movement response. Also I believe most Program mixes etc... do work. I have re-Binded the receivers and tried it on different airplanes and my Heli. same problem. Could this be a factor: When i plugged in my 7.2v lipo, I accidently plugged in the polarity backwards, turned it on, quickly turned it off, then fixed it, and thats when the problem started What can i do? is my radio fried? can i get a warrenty? Also i did not purchase this radio, i won it in a contest. Thanks for the help Daniel

Crospost answered : Hitec Optic 6 Sport - Reversed polarity on manufacturers forum.


Alan T.
Alan's Hobby, Model & RC FAQ Web Links (quick search = Ctrl+F)
A.T. is offline Find More Posts by A.T.
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold Hitec Optic 6 Sport 2.4 radio $80 JoeR Aircraft - General - Radio Equipment (FS/W) 16 Jan 12, 2012 08:25 PM
Wanted Hitec Optic 6 Sport 2.4 Ghz chriscap Aircraft - General - Radio Equipment (FS/W) 0 Aug 03, 2011 07:12 PM
Cool Vendo radio hitec optic sport 6 ch 2.4 ghz markk25 Mexico 1 May 23, 2011 02:30 PM
Discussion Looking for a micro receiver compatible with Hitec optic 6 sport 2,4 paramarc Electric Plane Talk 3 Apr 09, 2011 02:14 PM
Help! hitec optic 6 2.4 vs optic 6 sport 2.4 shanet1975 Radios 13 Nov 29, 2010 03:06 AM