HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 30, 2011, 02:59 AM
Registered User
United States, NH, Nashua
Joined Dec 2011
133 Posts
Help!
ouch msr x out of control hit my face

ive had an msr x for 10 days and it has flown great, i flew it 3 or 4 times thismorning giving it atleast 10 mins of rest in between , then i took a break and made food and took a shower easily 30 mins or more then i went back and put a fresh battery in my MSR x expecting to enjoy hovering it around my house and it is like its stuck in full reverse it needs to be almost full input forward to save it from hitting me in the face. i turned it of rebound it to my dx6i and it still happens it is unflyable.

does anyone know why this is happening, can it be fixed or should i just call horizon?
thanks
kyle
minkyboodle is offline Find More Posts by minkyboodle
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 30, 2011, 03:35 AM
Registered User
Letchworth, Great Britain (UK)
Joined Jul 2004
12,015 Posts
Is your fresh battery the same weight as the original, and located in the same position? Wrong centre of gravity can cause the model to move forwards or backwards. Otherwise, has one of the links come off a servo?
abenn is online now Find More Posts by abenn
Reply With Quote
Old Dec 30, 2011, 03:51 AM
Registered User
United States, NH, Nashua
Joined Dec 2011
133 Posts
its not a slight drift it is like it wants to go full tilt in reverse, the servo link is still atached and it works like normel sitting on the table useing the right stick to move forward backward lft and right until i turn the throttle on then it want to fly backwards hmmm maybe it is the board. if i can i will upload a video but i need to get a camera
minkyboodle is offline Find More Posts by minkyboodle
Reply With Quote
Old Dec 30, 2011, 08:29 AM
Registered User
Air Vaca's Avatar
Arivaca,Arizona
Joined May 2008
7,715 Posts
Did you try re-initializing the rx?....I mean, pull the batt out and rebind. These 3axis gyros can get confused and sometimes all they need is a "reboot".
Is there a chance you bumped your trim adjustments?
Air Vaca is offline Find More Posts by Air Vaca
Reply With Quote
Old Dec 30, 2011, 08:32 AM
Cranky old fart
Balr14's Avatar
Germantown, WI.
Joined Oct 2007
21,486 Posts
Check that the swashplate has not separated and the servos are centered and moving freely.
Balr14 is offline Find More Posts by Balr14
Reply With Quote
Old Dec 30, 2011, 09:52 AM
Registered User
Mt helena western australia
Joined May 2009
2,013 Posts
^seen a similar problem, the servos are either jammed or the antirotation estention has come out of its slot at the rear.
rangamatchstic is offline Find More Posts by rangamatchstic
Reply With Quote
Old Dec 31, 2011, 05:00 AM
Registered User
United States, NH, Nashua
Joined Dec 2011
133 Posts
its not the servo rod, or the dx6i because i also tryed the stock blade transmitter, reset transmitter, changed battery, checked for propper cyclic movment it is all fine until i put the throttle on. also tryed switching my dx6i from heli to airplane mode and also the swash is set to 90. im not sure what else i could be missing i have a bad feeling that its the board and i may have to ship it back.
minkyboodle is offline Find More Posts by minkyboodle
Reply With Quote
Old Dec 31, 2011, 07:00 AM
Registered User
Mt helena western australia
Joined May 2009
2,013 Posts
no, thats not what i mean. At the back of the swash is a little rod that goes into a prong on the frame which is the antirotation braket, this sometimes pops out and will have similar effect.
rangamatchstic is offline Find More Posts by rangamatchstic
Reply With Quote
Old Dec 31, 2011, 01:28 PM
Registered User
Canada, AB, Edmonton
Joined May 2008
2,574 Posts
take a picture of the head and swash plate and post it here so we can see what's going on.
Druss is offline Find More Posts by Druss
Reply With Quote
Old Dec 31, 2011, 04:44 PM
Registered User
United States, NH, Nashua
Joined Dec 2011
133 Posts
i went through everything with horizon tech support and they are just going to send me a new board ( also its not the antirotation rod) thanks guys i hope that this board solves my problem.
minkyboodle is offline Find More Posts by minkyboodle
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion my V200D01 now spins out of control KostaP Beginner Training Area (Heli-Electric) 1 Sep 15, 2011 05:28 AM
Discussion Optic 6 control sticks - Dig into my thumbs - Ouch Steve_A_Reno Radios 1 Aug 16, 2008 07:12 AM
Discussion Ouch!, not a good time for a radio hit... AnthonyRC Aerial Photography 15 Dec 14, 2006 01:51 PM
Discussion First face plant....ouch otisflies Mini Helis 8 Jun 11, 2006 08:42 PM
My Bandit took a hit! OUCH! ferradas Electric Sailplanes 12 Jun 02, 2002 06:03 PM