New Products Flash Sale
Thread Tools
Old Mar 28, 2012, 01:43 PM
indiggio is offline
Find More Posts by indiggio
Registered User
Joined Jun 2005
155 Posts
Update: It was the front motor that was shot.

After a few more attempts, the top set of blades wouldn't spin at all when giving throttle. They would just get whacked by the lower set.

Ordered 2 motors from xHeli @ $5.00/ea. + $4.95 shipping.

Went through the process of pulling out a ton of screws and replaced the motor.

After getting it all back together, it flies like it used to again.

Also looking for a 4ch heli now, as this one's getting a little boring and I'd like to have roll control instead of just yaw.

Thanks!
indiggio is offline Find More Posts by indiggio
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 22, 2012, 10:28 AM
usacjc is offline
Find More Posts by usacjc
Registered User
Joined Aug 2012
2 Posts
Quote:
Originally Posted by akacy View Post
has anyone had trouble with the trim. mine seems to want to trim to the left no mater where the trim control is. all gears look good, in fact i replaced the small gears do to spinning on the ground with no lift off. i know the book said to shut it down and restart the controller, didn't seem to help.
mine was always going left after crashing and i found that on the top blades the one connector holding the stabilizer on fell off so i made one with a straw with 2 holes to hold it level and everything was good again.
usacjc is offline Find More Posts by usacjc
Reply With Quote
Old Nov 04, 2012, 05:11 PM
Jake8131 is online now
Find More Posts by Jake8131
USAF Retired - 1968-1988
Jake8131's Avatar
United States, IL, Mascoutah
Joined Dec 2010
3,624 Posts
Just got mine...got a good deal on a NIB, for a great price...here is the maiden flight!

LT 711HAWKSPY A (4 min 18 sec)
Jake8131 is online now Find More Posts by Jake8131
Reply With Quote
Old Jan 20, 2013, 04:25 PM
aeroqualityguy is offline
Find More Posts by aeroqualityguy
AeroQualityGuy
United States, NC, Wake Forest
Joined Dec 2012
1 Posts
Not the Gears, but the set screw(s) for the lower rotor gear

I've got no take off thrust. My gears are intact. What I noticed is the set screws as the bottom of the lower rotor main gear is loose and it won't tighten. Disassembled the whole copter Friday, noticed there's two holes and I only had one screw in one hole. I found a second screw and put it in place in the open hole only to find that won't tighter either. Snugged them up as best I could - and after two successful flights, I'm back at square one with loose set screws whereas the shaft can't grasp the screws tight enough and I've not got enough spin on the rotor blades.

Any ideas on how to snug those set screws?
aeroqualityguy is offline Find More Posts by aeroqualityguy
Reply With Quote
Old Feb 25, 2013, 07:06 PM
Jake8131 is online now
Find More Posts by Jake8131
USAF Retired - 1968-1988
Jake8131's Avatar
United States, IL, Mascoutah
Joined Dec 2010
3,624 Posts
Quote:
Originally Posted by aeroqualityguy View Post
I've got no take off thrust. My gears are intact. What I noticed is the set screws as the bottom of the lower rotor main gear is loose and it won't tighten. Disassembled the whole copter Friday, noticed there's two holes and I only had one screw in one hole. I found a second screw and put it in place in the open hole only to find that won't tighter either. Snugged them up as best I could - and after two successful flights, I'm back at square one with loose set screws whereas the shaft can't grasp the screws tight enough and I've not got enough spin on the rotor blades.

Any ideas on how to snug those set screws?
Get some screw loc-tite......coat the threads and then screw them in as tight as you can and wait a few hours before you fly it.
Jake8131 is online now Find More Posts by Jake8131
Reply With Quote
Old Apr 10, 2015, 03:09 PM
Trucker6977 is offline
Find More Posts by Trucker6977
Registered User
Joined Apr 2015
1 Posts
No lift

Quote:
Originally Posted by ShaunKothZR1 View Post
I got it yesterday and tonight it took a kind of hard landing and now wont take flight only sits and spins any idea? I have put it back on the charger for about 30 minutes but it won't fly. what else could it be? did I break it already...
Check the two small drives gears chances are one of them is stripped of teeth i have just ordered cpl of sets common problem $1.75 for both gears hope this helps
Trucker6977 is offline Find More Posts by Trucker6977
Reply With Quote
Old Apr 12, 2015, 09:49 AM
Seer is offline
Find More Posts by Seer
Registered User
Joined Apr 2015
3 Posts
I bought this LT-711 used and started it up at the place and since I am new to this did not try to fly it. So I get home and charge it up and this is what happens.
1. It accelerates but barely leaves the ground and seems to be spinning fast enough
2. In just a few minutes of doing this I took it inside to mess with it and it will accelerate but still not leave the ground and then just shut off but I can move the power up and it will turn the blades again.
Is there a chance a weakened battery could cause this?
I have been looking at all these thoughts here and the lower gear only has 1 set screw in it.
And since no manual came with it I am lost here being new.

Any ideas would be helpful
Seer is offline Find More Posts by Seer
Last edited by Seer; Apr 12, 2015 at 11:43 AM.
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Egofly LT-712 Hawkspy 3CH RC Helicopter Frank_fjs Coaxial Helicopters 327 Nov 17, 2013 07:00 AM
Question Hawkspy Lt-711 Helicopter munoza Coaxial Helicopters 4 Jan 26, 2012 05:59 PM
Help! LT-711 Hawkspy Battery Warbucks Batteries and Chargers 5 Dec 19, 2011 05:57 AM
Alert Hawkspy 711 & 712 at Fry's Electronics joystix2 Multirotor Talk 1 Dec 17, 2011 03:13 PM
New Product LT-711 &LT-712 Hawkspy 3CH RC Helicopter RTF w/ Built-in Gyro, Spy Camera thercguy Coaxial Helicopters 1 Dec 11, 2011 10:48 AM