HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Feb 06, 2013, 12:13 PM
Registered User
Moldova, Chisinau
Joined Oct 2012
88 Posts
Quote:
Originally Posted by helizrnew2me View Post
ok, you might have a vibration problem causing that .enable the 42hz low pass filters and then try again .assuming you calibrated the esc`s right?
aaaaa no, how to do that ?
sorry for noob question

this way ?
http://www.multiwii.com/wiki/index.p...SC_Calibration
MrDeath is offline Find More Posts by MrDeath
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 06, 2013, 12:21 PM
Registered User
helizrnew2me's Avatar
United States, PA, Slatington
Joined Sep 2010
1,866 Posts
.
wait ...before we go farther lets be clear . when you say it auto increases speed by itself do you mean during flight?
or you mean the motors turn on when you arm the copter?
helizrnew2me is online now Find More Posts by helizrnew2me
Reply With Quote
Old Feb 06, 2013, 12:22 PM
Registered User
helizrnew2me's Avatar
United States, PA, Slatington
Joined Sep 2010
1,866 Posts
Quote:
Originally Posted by MrDeath View Post
aaaaa no, how to do that ?
sorry for noob question

this way ?
http://www.multiwii.com/wiki/index.p...SC_Calibration
yes thats the correct way
helizrnew2me is online now Find More Posts by helizrnew2me
Reply With Quote
Old Feb 06, 2013, 12:30 PM
Registered User
Moldova, Chisinau
Joined Oct 2012
88 Posts
my steps:
1.turn of from battery
2. arm
3. move up throttle stick for low rpm,
motors spins let say at 1300 rpm, after some seconds it increase rpms let say 1350, and again, after some seconds it increase to 1400 ... and so on ... but I don't touch stick in that moment.
MrDeath is offline Find More Posts by MrDeath
Reply With Quote
Old Feb 06, 2013, 12:32 PM
Registered User
Joined Sep 2011
49 Posts
here is how its connected http://www.imagehosting.cz/?v=hpim7217.jpg and here i made a video about whats happening :-)
CRIUS PROBLEM.AVI (0 min 42 sec)
Ackroyd is offline Find More Posts by Ackroyd
Reply With Quote
Old Feb 06, 2013, 12:34 PM
Stop me before I build again!
United States, NY, Albany
Joined Sep 2012
1,320 Posts
Quote:
Originally Posted by MrDeath View Post
my steps:
1.turn of from battery
2. arm
3. move up throttle stick for low rpm,
motors spins let say at 1300 rpm, after some seconds it increase rpms let say 1350, and again, after some seconds it increase to 1400 ... and so on ... but I don't touch stick in that moment.
Does it only happen on the ground? Does it cause a flip?
brontide is offline Find More Posts by brontide
Reply With Quote
Old Feb 06, 2013, 12:42 PM
Registered User
helizrnew2me's Avatar
United States, PA, Slatington
Joined Sep 2010
1,866 Posts
Quote:
Originally Posted by brontide View Post
Does it only happen on the ground? Does it cause a flip?
let me add to that

have you gotten it off the ground yet?into a hover?
helizrnew2me is online now Find More Posts by helizrnew2me
Reply With Quote
Old Feb 06, 2013, 12:56 PM
Registered User
Moldova, Chisinau
Joined Oct 2012
88 Posts
no, now i just adjust it, never fly
MrDeath is offline Find More Posts by MrDeath
Reply With Quote
Old Feb 06, 2013, 12:59 PM
Registered User
Moldova, Chisinau
Joined Oct 2012
88 Posts
Quote:
Originally Posted by helizrnew2me View Post
.
wait ...before we go farther lets be clear . when you say it auto increases speed by itself do you mean during flight?
or you mean the motors turn on when you arm the copter?
yes, but not durng fly but without props
MrDeath is offline Find More Posts by MrDeath
Reply With Quote
Old Feb 06, 2013, 01:00 PM
Registered User
helizrnew2me's Avatar
United States, PA, Slatington
Joined Sep 2010
1,866 Posts
well it could still be getting too much vibration .and if thats the case you would need to enable the low pass filters .

hovering it would help me know .a board thats getting vibrations will hover badly ,have the jitters and the motors could speed up n down .

do you know how to load a new sketch??
helizrnew2me is online now Find More Posts by helizrnew2me
Reply With Quote
Old Feb 06, 2013, 01:02 PM
Stop me before I build again!
United States, NY, Albany
Joined Sep 2012
1,320 Posts
Quote:
Originally Posted by MrDeath View Post
no, now i just adjust it, never fly
You may be witnessing "integral windup" where the controller is doing it's job and increasing motor speed in response to a persistent error ( slight tilt on the ground ). Easiest way to see is tilt it even more, is the speedup clearly on the down side and accelerates faster the more tilt you have?

http://en.wikipedia.org/wiki/Integral_windup

If it does it in a random direction, yes, you probably need the LPF and to better balance your props if you have not done so already.
brontide is offline Find More Posts by brontide
Reply With Quote
Old Feb 06, 2013, 01:05 PM
Registered User
Moldova, Chisinau
Joined Oct 2012
88 Posts
Quote:
Originally Posted by helizrnew2me View Post
do you know how to load a new sketch??
do you mean firmware ?
MrDeath is offline Find More Posts by MrDeath
Reply With Quote
Old Feb 06, 2013, 01:18 PM
Registered User
Moldova, Chisinau
Joined Oct 2012
88 Posts
May be this screen will exaplain
http://ialex.info/01.jpg
http://ialex.info/02.jpg
MrDeath is offline Find More Posts by MrDeath
Reply With Quote
Old Feb 06, 2013, 01:51 PM
Registered User
helizrnew2me's Avatar
United States, PA, Slatington
Joined Sep 2010
1,866 Posts
the links dont work ,but yes do you know how to load the firmware to the board?

if so you need to enable the low pass filters .

start with 42hz like in this shot below

/* ITG3200 & ITG3205 Low pass filter setting. In case you cannot eliminate all vibrations to the Gyro, you can try
to decrease the LPF frequency, only one step per try. As soon as twitching gone, stick with that setting.
It will not help on feedback wobbles, so change only when copter is randomly twiching and all dampening and
balancing options ran out. Uncomment only one option!
IMPORTANT! Change low pass filter setting changes PID behaviour, so retune your PID's after changing LPF.*/
//#define ITG3200_LPF_256HZ // This is the default setting, no need to uncomment, just for reference
//#define ITG3200_LPF_188HZ
//#define ITG3200_LPF_98HZ
#define ITG3200_LPF_42HZ
//#define ITG3200_LPF_20HZ
//#define ITG3200_LPF_10HZ // Use this only in extreme cases, rather change motors and/or props

/* MPU6050 Low pass filter setting. In case you cannot eliminate all vibrations to the Gyro, you can try
to decrease the LPF frequency, only one step per try. As soon as twitching gone, stick with that setting.
It will not help on feedback wobbles, so change only when copter is randomly twiching and all dampening and
balancing options ran out. Uncomment only one option!
IMPORTANT! Change low pass filter setting changes PID behaviour, so retune your PID's after changing LPF.*/
//#define MPU6050_LPF_256HZ // This is the default setting, no need to uncomment, just for reference
//#define MPU6050_LPF_188HZ
//#define MPU6050_LPF_98HZ
#define MPU6050_LPF_42HZ
//#define MPU6050_LPF_20HZ
//#define MPU6050_LPF_10HZ // Use this only in extreme cases, rather change motors and/or props



you can see where i removed the hash marks to enable these .

if this doesnt help then you may have other issues .you should really try to hover it and see whats going on with it .do it over tall grass at low height in case you crash.
helizrnew2me is online now Find More Posts by helizrnew2me
Reply With Quote
Old Feb 06, 2013, 02:02 PM
Registered User
Moldova, Chisinau
Joined Oct 2012
88 Posts
Quote:
Originally Posted by helizrnew2me View Post
the links dont work ,but yes do you know how to load the firmware to the board?

if so you need to enable the low pass filters .

start with 42hz like in this shot below

/* ITG3200 & ITG3205 Low pass filter setting. In case you cannot eliminate all vibrations to the Gyro, you can try
to decrease the LPF frequency, only one step per try. As soon as twitching gone, stick with that setting.
It will not help on feedback wobbles, so change only when copter is randomly twiching and all dampening and
balancing options ran out. Uncomment only one option!
IMPORTANT! Change low pass filter setting changes PID behaviour, so retune your PID's after changing LPF.*/
//#define ITG3200_LPF_256HZ // This is the default setting, no need to uncomment, just for reference
//#define ITG3200_LPF_188HZ
//#define ITG3200_LPF_98HZ
#define ITG3200_LPF_42HZ
//#define ITG3200_LPF_20HZ
//#define ITG3200_LPF_10HZ // Use this only in extreme cases, rather change motors and/or props

/* MPU6050 Low pass filter setting. In case you cannot eliminate all vibrations to the Gyro, you can try
to decrease the LPF frequency, only one step per try. As soon as twitching gone, stick with that setting.
It will not help on feedback wobbles, so change only when copter is randomly twiching and all dampening and
balancing options ran out. Uncomment only one option!
IMPORTANT! Change low pass filter setting changes PID behaviour, so retune your PID's after changing LPF.*/
//#define MPU6050_LPF_256HZ // This is the default setting, no need to uncomment, just for reference
//#define MPU6050_LPF_188HZ
//#define MPU6050_LPF_98HZ
#define MPU6050_LPF_42HZ
//#define MPU6050_LPF_20HZ
//#define MPU6050_LPF_10HZ // Use this only in extreme cases, rather change motors and/or props



you can see where i removed the hash marks to enable these .

if this doesnt help then you may have other issues .you should really try to hover it and see whats going on with it .do it over tall grass at low height in case you crash.
Yes I know how to flash it.

But I have a question, - seems my Gyro don;t work, or not enabled in code, when I'm trying to turn my copter, sensors doesn't react, also I'm getting i2c error, ...

may be I;m not flashing in right mode ?

I flash with Arduino nano w/ATmega 328, compile an upload work, but gyro not.

http://s019.radikal.ru/i642/1302/01/9d6c709b19de.jpg
http://s019.radikal.ru/i612/1302/a8/28d01c1d3cff.jpg
MrDeath is offline Find More Posts by MrDeath
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Full Foxtech AIO Glasses Review Guizmo12 FPV Equipment 1319 Aug 20, 2014 04:55 AM
Sold Arduino / MultiWii / Megapirates Boards 3rdeyepro Aircraft - Electric - Multirotor (FS/W) 3 Dec 03, 2011 08:43 PM
Wanted MSR 5in1 boards and MCPX 3in boards beachflyer Aircraft - Electric - Helis (FS/W) 3 Nov 22, 2011 09:14 PM
Discussion Foxtech AIO goggles RX? Teamsherman FPV Talk 2 Oct 02, 2011 10:06 AM
Sold 3 x PCB boards for multiwii copter for $28 madushan2008 Aircraft - Electric - Multirotor (FS/W) 1 Sep 06, 2011 06:53 AM