HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 04, 2011, 09:32 PM
Registered User
Joined Sep 2011
9 Posts
Discussion
copilot 2 errors

hello. i have installed the copilot 2 on my 450 with a dx6i tx. i am pretty sure i have it wired right but going thru the setup i am getting these errors: remote pigtail not connected and remote on/off must move more. i went into the flt mode and found that when the confirm rmt work on tx, there are no numbers on the screen. it shows this: confirm rmt work on tx _____ us. i can't get the on/off to work because there is no numbers? what am i doing wrong? thanks for the help
bullfroggs is offline Find More Posts by bullfroggs
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 05, 2011, 01:29 PM
AR-15 BRD!
Howard Matos's Avatar
Frederick, MD
Joined May 2002
1,042 Posts
Quote:
Originally Posted by bullfroggs View Post
hello. i have installed the copilot 2 on my 450 with a dx6i tx. i am pretty sure i have it wired right but going thru the setup i am getting these errors: remote pigtail not connected and remote on/off must move more. i went into the flt mode and found that when the confirm rmt work on tx, there are no numbers on the screen. it shows this: confirm rmt work on tx _____ us. i can't get the on/off to work because there is no numbers? what am i doing wrong? thanks for the help
Hi,

T,

First thing to try is to connect a standard servo to the same channel you are trying to use for the CPII on/off. Toggle the switch on your transmitter and make sure the servo is moving. Let me know how you make out with this, thanks.
Howard Matos is offline Find More Posts by Howard Matos
Reply With Quote
Old Dec 05, 2011, 02:01 PM
Registered User
Joined Sep 2011
9 Posts
hello howard and thanks for replying. i did what you said and the servo works when the switch is on and doesn't work with the switch off.
bullfroggs is offline Find More Posts by bullfroggs
Reply With Quote
Old Dec 05, 2011, 03:17 PM
AR-15 BRD!
Howard Matos's Avatar
Frederick, MD
Joined May 2002
1,042 Posts
Quote:
Originally Posted by bullfroggs View Post
hello howard and thanks for replying. i did what you said and the servo works when the switch is on and doesn't work with the switch off.
Hi,

Sounds like the problem is with your transmitter, probably the end point adjustments are not right for that channel. That would also explain why you are seeing "needs more movement". On that switch, with normal end points set, the servo should travel from 1 to 2 ms. It should go from full right to full left. Anything less then the end point is limiting it. See what is set and let me know, thanks.
Howard Matos is offline Find More Posts by Howard Matos
Reply With Quote
Old Dec 05, 2011, 04:28 PM
Registered User
Joined Sep 2011
9 Posts
thanks again howard. the switch for the dx6i that i was trying is in the gyro menu. 0 set at 0 and 1 set at 100. should i be using this switch or some other? why, when i go to program in flt mode and the confirm rmt work on tx comes up, i am getting, confirm rmt work on tx------us. i was told it was something in the transmitter but i am confused on what to do. thanks again. bill
bullfroggs is offline Find More Posts by bullfroggs
Reply With Quote
Old Dec 08, 2011, 09:01 AM
Registered User
Joined Sep 2011
9 Posts
hello. any chance of getting some closer on this matter? thanks
bullfroggs is offline Find More Posts by bullfroggs
Reply With Quote
Old Dec 08, 2011, 10:46 AM
President, FMA, Inc.
Tim Marks's Avatar
Joined Mar 2008
1,054 Posts
Quote:
Originally Posted by bullfroggs View Post
hello. any chance of getting some closer on this matter? thanks
Hi:

Howard is out of the office today, but will reply to you tomorrow.

Tim Marks
Tim Marks is offline Find More Posts by Tim Marks
Reply With Quote
Old Dec 08, 2011, 11:09 AM
Registered User
Joined Sep 2011
9 Posts
thanks tim.
bullfroggs is offline Find More Posts by bullfroggs
Reply With Quote
Old Dec 09, 2011, 10:55 AM
AR-15 BRD!
Howard Matos's Avatar
Frederick, MD
Joined May 2002
1,042 Posts
Hi,

Here is how I have our test helicopter set up using the DX6:

Name: CPII 6CH Heli Setup.jpg
Views: 67
Size: 25.0 KB
Description:

You will use channel 5 for the remote on/off. The gyro gain pigtail is connected to SVO4 on the computer module. You will need to set heading hold gain in the preference section of the CPII options. Start by using the same setting for heading hold that you entered in your transmitter, you may have to increase.decrease once you spool up and see how the gyro reacts. Please let me know if you have any questions, thanks.
Howard Matos is offline Find More Posts by Howard Matos
Reply With Quote
Old Dec 09, 2011, 11:13 AM
Registered User
Joined Sep 2011
9 Posts
hello howard. thanks for the reply. i did as you said. first i still get remote pigtail is not connected, next, confirm rmt work on tx shows this: confirm rmt work on tx-----us. and finally remote on/off must move more. thanks again. bill btw, i have a dx6i.
bullfroggs is offline Find More Posts by bullfroggs
Last edited by bullfroggs; Dec 09, 2011 at 11:20 AM.
Reply With Quote
Old Dec 09, 2011, 11:25 AM
AR-15 BRD!
Howard Matos's Avatar
Frederick, MD
Joined May 2002
1,042 Posts
Quote:
Originally Posted by bullfroggs View Post
hello howard. thanks for the reply. i did as you said. first i still get remote pigtail is not connected, next, confirm rmt work on tx shows this: confirm rmt work on tx-----us. and finally remote on/off must move more. thanks again. bill btw, i have a dx6i.
Hi,

OK, I will have Cindy issue you a return authorization.
Howard Matos is offline Find More Posts by Howard Matos
Reply With Quote
Old Dec 09, 2011, 11:45 AM
Registered User
Joined Sep 2011
9 Posts
thank you howard for your time and help.
bullfroggs is offline Find More Posts by bullfroggs
Reply With Quote
Old Dec 20, 2011, 11:13 PM
Registered User
Joined Sep 2011
9 Posts
update on copilot2

had to send unit back and received new unit today. this thing installed with no problems and went as fast as the video demonstrated. thank you for your help and finding the problem. bill
bullfroggs is offline Find More Posts by bullfroggs
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold Copilot 2 LT System Combo 2 playstat88 Aircraft - Electric - Helis (FS/W) 1 Sep 28, 2011 05:07 PM
Sold Copilot 2 and SK720 nuttzzy34 Aircraft - General - Radio Equipment (FS/W) 0 Aug 15, 2011 10:54 AM
For Sale FMA Copilot II - Combo 2 - SOLD mmalik4 Aircraft - Electric - Helis (FS/W) 1 May 10, 2011 10:09 AM
Sold Trex 500 ready to fly. DX7, Copilot 2, six lipo packs. kauaicuda Aircraft - Electric - Helis (FS/W) 0 Apr 29, 2011 10:01 PM
Sold FMA copilot 2 ch saucisse FPV Equipment (FS/W) 1 Apr 26, 2011 02:20 PM