HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 29, 2011, 04:13 AM
Registered User
Pete1232's Avatar
United Kingdom, England, Callington
Joined Jul 2011
74 Posts
Discussion
Help please, servos etc etc etc

HI guys, right a little help required for me, my twister cp gold has got a problem.
Right whilst hovering it the other week it wouldnt hold a steady altitude, (i,m not the best pilot as i,m just starting out but i know when something isnt right)
Anyway i landed and on closer inspection all the servos were going crazy, now i have had a look around and followed other peoples reccomendations, the first being to eliminate any moisture so i had her sit in the airing cupboard for three days including the tx, I took the tx apart (original twister cp gold tx) and sprayed with wd40.
renewed all batteries and recharged the lipo, plugged in and the problem persists all servos are going crazy.
Now i have unplugged each servo from the rx in turn to try and eliminate a broken servo, but even by doing this the glitching still persists.
That is until I unplug the speed controller, when i done this the crazy servos stopped, AAHHHAAA I thought, so off i went to one of my other helis that has the same speed rated speed controller and swapped them over and....................damn me the servos are still going totally mad!!!!!

So after reading this has anyone got any ideas as to what the problem might be and the solution.many thank in advance ive been trying to solve it for three weeks now, and in the mean time have been trying to master a little Walkera #52 cp for indoor use what a hoot and a steep learning curve this little machine is hahaha.
Pete1232 is offline Find More Posts by Pete1232
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 29, 2011, 05:27 AM
Sopwith Camel's Cousin
Between my tx and crashed aircraft
Joined Mar 2006
3,803 Posts
Quote:
Originally Posted by Pete1232 View Post
...
Anyway i landed and on closer inspection all the servos were going crazy, now i have had a look around and followed other peoples reccomendations, the first being to eliminate any moisture so i had her sit in the airing cupboard for three days including the tx, I took the tx apart (original twister cp gold tx) and sprayed with wd40.
renewed all batteries and recharged the lipo, plugged in and the problem persists all servos are going crazy.
Now i have unplugged each servo from the rx in turn to try and eliminate a broken servo, but even by doing this the glitching still persists.
That is until I unplug the speed controller, when i done this the crazy servos stopped, AAHHHAAA I thought, so off i went to one of my other helis that has the same speed rated speed controller and swapped them over and....................damn me the servos are still going totally mad!!!!!

So after reading this has anyone got any ideas as to what the problem might be ...
One piece of electronics that you have yet to test: the receiver (and if the receiver has a crystal, reseating or replacing the crystal).

Or another way to view it: try plugging in the servos (one by one) into a servo tester or another receiver/transmitter combination.

By the way, unplugging the speed controller will remove all power to the receiver and servos, so whether they are defective or not, they will not do anything.
flying-llama is offline Find More Posts by flying-llama
Reply With Quote
Old Nov 30, 2011, 08:34 AM
Registered User
Pete1232's Avatar
United Kingdom, England, Callington
Joined Jul 2011
74 Posts
Ok I have tried new crystals and no joy servos seem to have a seizure they just seem to freeze up, tried to reseat original crystals and servos still go crazy. Will try and borrow nephews buggy and test servos that way . I have heard that the twister tx can go belly up has anyone else heard of this?
Pete1232 is offline Find More Posts by Pete1232
Reply With Quote
Old Feb 19, 2012, 12:38 PM
Registered User
Pete1232's Avatar
United Kingdom, England, Callington
Joined Jul 2011
74 Posts
ok people, as i always hate an open problem. I can now say that I have found and solved the problem, it was the receiver that was at fault, crystals were ok.
Now I have yet another problem, and that is now the tail rotor doesnt have enough ooommff to deal with the tourq from the main rotor
Pete1232 is offline Find More Posts by Pete1232
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Servos For Twin Cargo Plane (help Please) ramcam Foamies (Scratchbuilt) 3 Nov 20, 2011 05:34 PM
Discussion help with exi 450 servos please almaidah 3D Electric Heli Flying 12 Sep 23, 2011 02:28 AM
Help! Need help in setting up a new plane,such as servos, wiring,contro rods,etc. helipup Beginner Training Area (Aircraft-Electric) 8 Mar 27, 2011 12:40 AM
Question Help please - question about which servos to put where on a PA Katana Mini? glydr 3D Flying 5 Mar 05, 2011 07:37 PM
Discussion mounting servos etc help please shaynes Beginner Training Area (Aircraft-Electric) 4 Apr 12, 2007 03:13 AM