HobbyKing.com New Products Flash Sale
Closed Thread
Thread Tools
Old Sep 15, 2012, 06:57 AM
Pittsburgh, PA
Joined Jul 2012
93 Posts
Just replaced the PCB on my 9116 because it wouldn't bind. New PCB and same problem. Any suggestions? One day it worked fine, next day it wouldn't bind!!
weav01 is offline Find More Posts by weav01
Sign up now
to remove ads between posts
Old Sep 15, 2012, 07:26 AM
Eugene
Whizgig's Avatar
Australia, VIC, Delacombe
Joined Oct 2006
918 Posts
Quote:
Originally Posted by weav01 View Post
Just replaced the PCB on my 9116 because it wouldn't bind. New PCB and same problem. Any suggestions? One day it worked fine, next day it wouldn't bind!!
Ok how are you trying to bind it.

Step by step on what you are doing.

Also try this first turn on the heli then the tx make sure the throttle stick is fully off and then press the thottle trim all the way down
Whizgig is offline Find More Posts by Whizgig
Old Sep 15, 2012, 12:12 PM
Wow, the sky is clear
OrangeBird's Avatar
Canada, QC, Chicoutimi
Joined Aug 2012
544 Posts
Bind...

Quote:
Originally Posted by weav01 View Post
Just replaced the PCB on my 9116 because it wouldn't bind. New PCB and same problem. Any suggestions? One day it worked fine, next day it wouldn't bind!!
Try this:

Another tip: To bind your new PCB: Power on heli, hold both sticks on remote to lower right while powering on. Wait for beeps to stop. Power everything down. Power back up and your now bound.
Work great.....

bye Gilles
OrangeBird is offline Find More Posts by OrangeBird
RCG Plus Member
Old Sep 15, 2012, 04:34 PM
Pittsburgh, PA
Joined Jul 2012
93 Posts
Quote:
Originally Posted by OrangeBird View Post
Try this:

Another tip: To bind your new PCB: Power on heli, hold both sticks on remote to lower right while powering on. Wait for beeps to stop. Power everything down. Power back up and your now bound.
Work great.....

bye Gilles
Whizgig/OrangeBird,
Tried both of your techiniques and nothing. Just a little jump from the servos and a continued slow flahing light on the PCB. THe original way I was trying to bind was power on the Tx until beeping stops then turn on the copter. Also tried turning on the copter while the tx was beeping. Nothing
weav01 is offline Find More Posts by weav01
Old Sep 15, 2012, 05:28 PM
Fly Fast, Fly Hard, Fly Fun
rexless's Avatar
Canada, BC
Joined Apr 2012
1,432 Posts
I find it works best to turn on the helicopter first, then turn on the tx with throttle at 0. Wait a second then throttle slowly to 100% then back down to 0. After that check the elevators and ailerons and if you see movement, try throttle and rudder.
rexless is online now Find More Posts by rexless
RCG Plus Member
Old Sep 15, 2012, 06:53 PM
Pittsburgh, PA
Joined Jul 2012
93 Posts
Quote:
Originally Posted by rexless View Post
I find it works best to turn on the helicopter first, then turn on the tx with throttle at 0. Wait a second then throttle slowly to 100% then back down to 0. After that check the elevators and ailerons and if you see movement, try throttle and rudder.
Still nothing. PCB light flashes fast then slow and stays slow with no bind. What the heck. I wanna fly
weav01 is offline Find More Posts by weav01
Old Sep 16, 2012, 02:00 AM
Ain't crashing often anymore
mikefromgermany's Avatar
Germany, Berlin
Joined Jun 2012
3,175 Posts
Quote:
Originally Posted by weav01 View Post
Still nothing. PCB light flashes fast then slow and stays slow with no bind. What the heck. I wanna fly
1) Have a closer look on the soldered connection bridge between main PCB and the Antenna PCB. In the pic it's the black block on lower right



Either there are solder-blobs that shorten some pins (my spare PCB was delivered like this) or these bridge has cold solder points - just tip every one with an iron.

2) resolder the connection pins of the crystal (the silver can on antenna-PCB - it can be mounted under the newer PCBs too, then the resolder job is much easier.


-mike-
mikefromgermany is offline Find More Posts by mikefromgermany
RCG Plus Member
Old Sep 16, 2012, 08:36 AM
Pittsburgh, PA
Joined Jul 2012
93 Posts
Quote:
Originally Posted by mikefromgermany View Post
1) Have a closer look on the soldered connection bridge between main PCB and the Antenna PCB. In the pic it's the black block on lower right



Either there are solder-blobs that shorten some pins (my spare PCB was delivered like this) or these bridge has cold solder points - just tip every one with an iron.

2) resolder the connection pins of the crystal (the silver can on antenna-PCB - it can be mounted under the newer PCBs too, then the resolder job is much easier.


-mike-
Thanks mike. I inspected the board closely and retouched a few blobs. No evidence of shorted blobs but maybe a few cold joints. Still no binding with every technique mentioned in my post. Question: What does the fast and slow blinking light represent? Same symptoms with both boards? Could it be something besides the board? Possibility of two bad boards is there but low. Symptoms don't point to a servo or a motor. I even unplugged each of those systematically and tried to bind with no joy. Ughhhh. This heli is used as my trainer that I was using to learn FF so I don't crash my x400. I'm stuck at hover practice until this little tough guy is fixed. Driving me crazy.
weav01 is offline Find More Posts by weav01
Old Sep 16, 2012, 10:37 AM
Ain't crashing often anymore
mikefromgermany's Avatar
Germany, Berlin
Joined Jun 2012
3,175 Posts
Quote:
Originally Posted by weav01 View Post
Thanks mike. I inspected the board closely and retouched a few blobs. No evidence of shorted blobs but maybe a few cold joints. Still no binding with every technique mentioned in my post. Question: What does the fast and slow blinking light represent? Same symptoms with both boards? Could it be something besides the board? Possibility of two bad boards is there but low. Symptoms don't point to a servo or a motor. I even unplugged each of those systematically and tried to bind with no joy. Ughhhh. This heli is used as my trainer that I was using to learn FF so I don't crash my x400. I'm stuck at hover practice until this little tough guy is fixed. Driving me crazy.
fast blink: initialising gyro and waiting for binding TX
slow blinking: initialising completed and no signal found to bind to

So there's another test you could do: take (borrow) another TX - another stock one or from a 911/928/Xieda 9958/9x and check the binding with one of these.
You already tried to put new batts in the TX ???

Hard to determine the problem from here....
But one is to take for sure: something prevents data exchange - the prob has to be between (including) the TX and the crystal-PCB connections to main PCB

mike
mikefromgermany is offline Find More Posts by mikefromgermany
RCG Plus Member
Old Sep 16, 2012, 11:47 AM
Pittsburgh, PA
Joined Jul 2012
93 Posts
Quote:
Originally Posted by mikefromgermany View Post
fast blink: initialising gyro and waiting for binding TX
slow blinking: initialising completed and no signal found to bind to

So there's another test you could do: take (borrow) another TX - another stock one or from a 911/928/Xieda 9958/9x and check the binding with one of these.
You already tried to put new batts in the TX ???

Hard to determine the problem from here....
But one is to take for sure: something prevents data exchange - the prob has to be between (including) the TX and the crystal-PCB connections to main PCB

mike
Thanks mike
Yes fresh batteries and still no joy. Luckily my neighbor has one I will try his tx
weav01 is offline Find More Posts by weav01
Old Sep 16, 2012, 02:33 PM
Registered User
NeilGerrard's Avatar
United States, UT, Draper
Joined Sep 2012
14 Posts
Epoxy

Could one of you fine gentleman please post pictures of where to epoxy the PCB? I got my heli about two weeks ago from Banana Hobby and it was DOA. It woun't bind and the red led is just constantly on. I ordered the PCB as a spare and am ready install but with my luck I would probably glue something not ment to be glued.

Thank you
Neil
NeilGerrard is offline Find More Posts by NeilGerrard
Old Sep 16, 2012, 07:18 PM
Pittsburgh, PA
Joined Jul 2012
93 Posts
Quote:
Originally Posted by weav01 View Post
Thanks mike
Yes fresh batteries and still no joy. Luckily my neighbor has one I will try his tx
Mike,
it worked. my neighbors tx bound with the helicopter. is there a common problem in the tx that i can fix or am i looking at a new one for $30?
weav01 is offline Find More Posts by weav01
Old Sep 16, 2012, 09:36 PM
Pittsburgh, PA
Joined Jul 2012
93 Posts
Quote:
Originally Posted by weav01 View Post
Mike,
it worked. my neighbors tx bound with the helicopter. is there a common problem in the tx that i can fix or am i looking at a new one for $30?
Opened the tx box and looked around. Then plugged in the batteries and the damn thing bound. CHeap electronics. wow all of this troubleshooting for nothing. Something was obvioulsy loose.
weav01 is offline Find More Posts by weav01
Old Sep 17, 2012, 02:06 AM
Registered User
Joined Sep 2012
5 Posts
main motor replacement

hi. I'm pretty new with the DH 9116, i just burnt the main motor, is there any better suitable replacement main motor which will fit good on the heli? or should i just order the stock 9116 main motor?
tnx
karatekid1800 is offline Find More Posts by karatekid1800
Last edited by karatekid1800; Sep 17, 2012 at 03:19 AM.
Old Sep 17, 2012, 03:24 AM
Ain't crashing often anymore
mikefromgermany's Avatar
Germany, Berlin
Joined Jun 2012
3,175 Posts
Quote:
Originally Posted by karatekid1800 View Post
hi. I'm pretty new with the DH 9116, i just burnt the main motor, is there any better suitable replacement main motor which will fit good on the heli? or should i just order the stock 9116 main motor?
tnx
Stay with stock. Buy 3 and thats enough for the next months and cheap enough.

-mike-
mikefromgermany is offline Find More Posts by mikefromgermany
RCG Plus Member
Closed Thread


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product the first double horse 2.4G and 4CH single blade helicopter 9116 hkmtk Beginner Training Area (Heli-Electric) 32 May 21, 2013 01:27 PM
Help! Heli Spins out when ascending (Z101, looks like the double horse) Shlofter Electric Heli Talk 5 Aug 16, 2012 01:59 AM
Discussion Double Horse 9097 24" Heli Jake8131 Electric Heli Talk 8 Mar 14, 2012 07:05 AM
Sold 9089 Double Horse Shuttle Electric Heli w/Video DVR Senor Jack Aircraft - Electric - Helis (FS/W) 0 Apr 10, 2011 08:15 PM