HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jul 15, 2012, 06:50 PM
Brosol
Brosol's Avatar
Canada
Joined Dec 2010
1,111 Posts
Check out Daryoon’s er9x Settings:

Daryoon's WL Toys v911 settings for er9x
Daryoon: http://www.hacksmods.com/2012/06/wl-...ings-for-er9x/

Daryoon’s Xieda 9958 settings for er9x
Daryoon: http://www.hacksmods.com/2012/05/xie...er9x-settings/
Brosol is offline Find More Posts by Brosol
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 28, 2012, 03:39 PM
Registered User
Joined Oct 2012
6 Posts
Quote:
Originally Posted by dafremen View Post
DAF'S INTRIGUING HALL OF UNSOLVED 9958 MYSTERIES
TAKE THESE ON...IF YOU DARE!

1. What is the part number for the 5888 Coaxial's Transmitter?
2. How about the 9998's Transmitter?
3. Does anyone have or sell Jamara E-Rix 100 that could supply a part number to replace the transmitter?
4. Who wants to start the battery comparison thread? (I already bit off more than my big mouth can chew.) I'll link to it.
5. What are some drop in replacement swashplates? Part numbers? Tweaks to make them work? Things to look out for when installing them?
Helipal has the tx, http://www.helipal.com/gw-9958-028-transmitter.html
notlarc is offline Find More Posts by notlarc
Reply With Quote
Old Nov 29, 2012, 03:25 PM
Registered User
Joined Oct 2012
6 Posts
Question? Did Xieda and Syma merge? Both seem to have the name "Hero RC" now. Same helis from both but under one name. Here's a link, http://www.xheli.com/herorc.html
notlarc is offline Find More Posts by notlarc
Reply With Quote
Old Nov 29, 2012, 03:59 PM
Safety : practice & promote!
RoboHeli's Avatar
Joined Dec 2011
4,901 Posts
No I think these are just "rebrands" The company that makes the HeroRC "brand" bought some 9958s and S107Gs and repainted them.

Hobby King sells a "rebranded" GW 9958, GW 9988, and WLToys V911 as well. Same toy, just different labels and box decoration.
RoboHeli is online now Find More Posts by RoboHeli
RCG Plus Member
Old Dec 05, 2012, 01:50 PM
Registered User
Joined Dec 2012
2 Posts
does XIEDA remote work on blade MSRX by any chance?

Hey guys,

I been reading this thread for quite a while enjoying a lot of useful info on the xieda. Something on the board of mine is broken I think and instead of paying for a new board I am thinking of upgrading to a Blade msrx.

There is quite a few BNF versions online for sale that are quite a bit cheaper than the rtf's and looking at the rc that comes with the rtf packages makes me wonder if they are the same?!? The outside definitely looks like it - except for the stickers.

Has anybody here got both of them or tried to pair the Xieda remote to the msrx? Does it work? Would save me some money to a point of lmost a second msxr ;P

It'd be AWESOME if somebody could check/confirm

thanx a lot
cheers
elron is offline Find More Posts by elron
Reply With Quote
Old Dec 05, 2012, 02:28 PM
Against Helicopter Cruelty
Heli Pad's Avatar
Joined Aug 2011
6,763 Posts
Elron, welcome to RCG. The 9958 Tx would not bind with the mSRx, or vice versa. Read through the 1st post of this thread and pay extra attention to Section 3. You'll get a lot of good info there.
Heli Pad is online now Find More Posts by Heli Pad
Reply With Quote
Old Dec 05, 2012, 03:43 PM
Registered User
Joined Dec 2012
2 Posts
Quote:
Originally Posted by Heli Pad View Post
Elron, welcome to RCG. The 9958 Tx would not bind with the mSRx, or vice versa. Read through the 1st post of this thread and pay extra attention to Section 3. You'll get a lot of good info there.
Thanx a lot for the warm welcome Heli Pad I been reading in here for quite a while but somehow musta missed section 3 - duh!

Thx a lot for the patience and pointing me in the right direction

cheers
elron
elron is offline Find More Posts by elron
Reply With Quote
Old Jan 20, 2013, 08:19 PM
cka
Registered User
Joined Feb 2010
3 Posts
Prob with my heli

Hi all,
Has anyone experienced this problem?
I have 9958 and after a small crash the motors will not run. When trying throttling up a signal is sent to the motors and they jerk then the heli LED flashes fast and motors do not run. After a few seconds the light returns to steady and the process repeats if I move the throttle up again. The servos respond normally whenever the heli LED is steady so I have correct binding. I have tried 3 different transmitters. Obviously a heli prob.
Any thoughts? Anyone else had this prob?
Thanks
cka is offline Find More Posts by cka
Reply With Quote
Old Jan 20, 2013, 08:21 PM
Team WarpSquad
Daryoon's Avatar
San Diego, CA
Joined Dec 2010
6,691 Posts
Usually a cut in the tail wire where it exits the boom will cause the issue you're experiencing.
Daryoon is offline Find More Posts by Daryoon
Reply With Quote
Old Jan 27, 2013, 06:10 PM
Registered User
Joined Jan 2013
57 Posts
Quote:
Originally Posted by cka View Post
Hi all,
Has anyone experienced this problem?
I have 9958 and after a small crash the motors will not run. When trying throttling up a signal is sent to the motors and they jerk then the heli LED flashes fast and motors do not run. After a few seconds the light returns to steady and the process repeats if I move the throttle up again. The servos respond normally whenever the heli LED is steady so I have correct binding. I have tried 3 different transmitters. Obviously a heli prob.
Any thoughts? Anyone else had this prob?
Thanks
I had exactly the same symptom after repairing a broken tail wire. In order to so do, I had to remove the wiring for the tail motor at the board, then resolder it after I had finished the repair. In the process, I had inadvertently flowed some solder across two terminals and shorted out the tail motor. Once I cut off the solder bridge with an xacto knife, things were back to normal. I believe the previous poster is on the right track..something's probably messed up with your tail motor wiring.

Good luck..

Barry
musechaserpilot is offline Find More Posts by musechaserpilot
Reply With Quote
Old Jan 27, 2013, 07:38 PM
Registered User
Tucson, Az
Joined Feb 2007
8,618 Posts
Hard to believe but my two 9958's are almost a year old. Both gave me a little hassel. Amazing both are still flying and flying pretty good. That weak pin on blades is a drawback as breaks very easy. I still fly them a couple times a week but flying Quads cuts back on heli time. Also going bigger to 6ch c/p's. I am much impressed at how newer stuff can hold up. Great days for heli fans and Quads.
dankar04 is offline Find More Posts by dankar04
Reply With Quote
Old Jan 27, 2013, 11:32 PM
GOT WINGS
siriusflier's Avatar
United States, TX, Wilbarger
Joined Apr 2012
2,655 Posts
I still have one working 9958 and 2 in need of repair. I started to replace both motors on one 9958, but with three quads to play with, I haven't taken the time to heat up the soldering iron. I have spent most of the last two weeks with my new V202. Got the 9958 ready to solder, but soldering is not one of my favorite things to do
siriusflier is online now Find More Posts by siriusflier
Reply With Quote
Old Jan 28, 2013, 06:51 PM
MassiveOverkill's Avatar
United States, FL, Melbourne
Joined Feb 2011
5,467 Posts
Quote:
Originally Posted by siriusflier View Post
I still have one working 9958 and 2 in need of repair. I started to replace both motors on one 9958, but with three quads to play with, I haven't taken the time to heat up the soldering iron. I have spent most of the last two weeks with my new V202. Got the 9958 ready to solder, but soldering is not one of my favorite things to do
You're spending your time wisely Sirius..........your V202 deserves your undivided attention
MassiveOverkill is online now Find More Posts by MassiveOverkill
Site Sponsor
Old Feb 01, 2013, 04:31 PM
Registered User
United States, TN, Nashville
Joined Feb 2012
15 Posts
Quote:
Originally Posted by cka View Post
Hi all,
Has anyone experienced this problem?
I have 9958 and after a small crash the motors will not run. When trying throttling up a signal is sent to the motors and they jerk then the heli LED flashes fast and motors do not run. After a few seconds the light returns to steady and the process repeats if I move the throttle up again. The servos respond normally whenever the heli LED is steady so I have correct binding. I have tried 3 different transmitters. Obviously a heli prob.
Any thoughts? Anyone else had this prob?
Thanks
From page two of this thread, might be related, might not..

Quote:
Originally Posted by SoloProFan View Post
Perhaps some flight times might me interesting?

I use the Nano 130 mostly, because it's lighter than the 160, and I have some of these lying around. Flight times are around 4 minutes, You can push them further, the heli will stay in the air for a little longer, up till 5 mniutes, but you risk draining the lipo too far. I've killed 2 lipos this way, they don't go puffy, but either the heli will start blinking as soon as you apply throttle, or you can fly, but tail hold is bad, and the servos will chatter randomly as a result of the voltage sagging too far under load.
stusvend is offline Find More Posts by stusvend
Reply With Quote
Old Feb 17, 2013, 09:49 PM
GOT WINGS
siriusflier's Avatar
United States, TX, Wilbarger
Joined Apr 2012
2,655 Posts
If anyone is interested, I just used a used motor from a V929 with a worn out pinion on my 9958. I had a new pinion from a syma x1 motor, used that pinion on the V929 motor and installed it on the 9958. It flew fairly well in first inside only test.
siriusflier is online now Find More Posts by siriusflier
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product GW Xieda 9958 Frank_fjs Micro Helis 7496 Dec 03, 2014 09:50 AM
Discussion 9998 Xieda Great Wall Toys Super Uncommon! FreakFlow Coaxial Helicopters 39 Dec 05, 2013 06:45 PM
Mini-Review GW Xieda 9958 - Review Frank_fjs Micro Helis 10 Nov 24, 2011 10:38 AM