HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 26, 2011, 01:06 AM
QiW
Registered User
south east asia
Joined Mar 2009
956 Posts
Discussion
can i "brick" my KK board ?

i was flying fine with my quad ... running KR 2.3 X-copter firmware
decided that i wanna try out the KK 4.7X

flashed my KK 5.5d using a USBASP device and LZ's flash tool

no error message ... read and confirmed fine by flashtool

so proceeded to calibrate throttle/ESCs ... that went without any hiccups

now ... the problems comes
tried to arm the FC ... nothing happened
tried moving trims for yaw and throttle ... nothing happened
tried moving throttle ... motors spins up equally without the FC arming

re-flashed the FC ...
same thing happens

re-flashed the FC with a different firmware (tried FW for quads and tricopter)
same thing happens

is my KK 5.5d FC bricked ??
QiW is offline Find More Posts by QiW
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 26, 2011, 01:23 AM
Master of Flash
LazyZero's Avatar
Alsdorf/Eifel, Germany
Joined Jun 2005
1,565 Posts
No I think you have the YAW pot still on zero position.

Chrsitian
LazyZero is offline Find More Posts by LazyZero
Reply With Quote
Old Oct 26, 2011, 01:52 AM
QiW
Registered User
south east asia
Joined Mar 2009
956 Posts
Quote:
Originally Posted by LazyZero View Post
No I think you have the YAW pot still on zero position.

Chrsitian
i turned pot full CW as per KK 4.7 instructions for calibrating ESCs
throttle stick up .. power on
beep beep of ESCs .. then throttle down .. ESCs confirm beep

moved the yaw pot to around 50% after calibrating the ESCs with the FC
the result is the same ... board does not arm ... motor spins up evenly and normally when i throttle ...

or is my yaw pot broken maybe ?
how do i check for this ? there is no physical damage on board and this FC has never crashed before
when yaw pot is at ZERO ... the FC cannot arm ?
QiW is offline Find More Posts by QiW
Reply With Quote
Old Oct 26, 2011, 02:07 AM
Suspended Account
Joined Dec 2010
11,764 Posts
Yea sounds like its in esc calibration mode.
Measure resistance around yaw pot.
timecop is offline Find More Posts by timecop
Reply With Quote  (Disabled)
Old Oct 26, 2011, 02:45 AM
Master of Flash
LazyZero's Avatar
Alsdorf/Eifel, Germany
Joined Jun 2005
1,565 Posts
And take a look at the solder joints of that pot.
LazyZero is offline Find More Posts by LazyZero
Reply With Quote
Old Oct 26, 2011, 04:32 AM
QiW
Registered User
south east asia
Joined Mar 2009
956 Posts
thanks for your replies
will have a look at the board later for those issues ...
QiW is offline Find More Posts by QiW
Reply With Quote
Old Oct 26, 2011, 06:15 AM
QiW
Registered User
south east asia
Joined Mar 2009
956 Posts
ok .. had a looked at the YAW pot
solder had a cold joint .. tapping it a little got the solder loose
re-soldered it back on .. and IT'S ALIVE !!!!!

THANKS GUYS !!!

ps .. still have that issue of motor #4 running at slower speed than the others though
QiW is offline Find More Posts by QiW
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Can a KK Controller Board Ruin My ESCs? rtbchris Multirotor Talk 8 Aug 25, 2011 01:11 AM
Help! Did I just brick my KK board? tomeparker Multirotor Talk 5 Aug 19, 2011 08:23 AM
For Sale KK KR1.7 ,ESC Board and KK Frame terriwang Aircraft - Electric - Multirotor (FS/W) 3 Jul 26, 2011 04:22 PM
Discussion KK firefly next on the virtual board vintage1 Control Line 5 Jun 22, 2010 07:18 AM
Discussion can my minumun brick habdle the 2 SS/MF motors? trust416 Micro Ready-to-Fly 7 May 03, 2008 03:32 PM