HobbyKing.com New Products Flash Sale
View Poll Results: Which programmers are you using
AVRisp mkII 14 23.73%
usbasp 34 57.63%
mySmartUSB light 4 6.78%
USBtiny 8 13.56%
other 2 3.39%
Multiple Choice Poll. Voters: 59. You may not vote on this poll

Reply
Thread Tools
Old Jan 08, 2013, 02:00 AM
Registered User
Australia, NSW, Sydney
Joined Jan 2012
132 Posts
Yes. There were ESC connected at the time. Bummer. Didn't know that.

Anyways, if someone who reads these posts wouldn't mind helping me with a pre flashed (V1.5) kk2.0 board I would be thankful.

As I said, I'll happily pay any extra money for the time and effort.

Jason.
Exaturbo is offline Find More Posts by Exaturbo
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 08, 2013, 11:32 AM
crashology student
Ontario, Canada
Joined May 2008
116 Posts
After 2-1/2 frustrating all-day internet searches and multiple attempts to flash my four HK F-30A ESCs with SimonK's bs-nfet.hex, success was finally achieved (though I am sure that LazyZero was at the other end of my Java connection).

Thanks to all who have unknowingly contributed through your simple but informing posts ... especially LazyZero, SimonK, ... (and my wife who was sure that I could really do it!).

PS: The jumper on the USBasp board is removed for this method as the USB is not powering the USBasp. Keep the jumper as it is needed to flash KK2.0 etc.
rshep is offline Find More Posts by rshep
Last edited by rshep; Jan 22, 2013 at 08:36 PM. Reason: clarity, jumper
Reply With Quote
Old Jan 15, 2013, 11:37 PM
Registered User
Joined Oct 2012
129 Posts
LazyZero

I flashed my board with a tricopter version. Now I am confused as to what motor corresponds to what corner. Which motor should be the rear, m1, m2, m3? channel 4 is yaw control but Im not sure which motor should be in which designation on the board. Hopefully I explained it good enough.

Is this correct for version 2.5, motor 1 is top left, motor 2 is top right, motor 3 is bottom middle, and 4 is servo


thank you
matchpoint is offline Find More Posts by matchpoint
Last edited by matchpoint; Jan 15, 2013 at 11:43 PM.
Reply With Quote
Old Jan 16, 2013, 01:57 AM
Master of Flash
LazyZero's Avatar
Alsdorf/Eifel, Germany
Joined Jun 2005
1,583 Posts
Yes, that is correct. See http://www.kkmulticopter.kr/index.ht...a=xxcontroller for the manual of that firmware.

Best Christian
LazyZero is offline Find More Posts by LazyZero
Reply With Quote
Old Feb 02, 2013, 04:16 PM
Multi rotors=No Paycheck left
SDSURFnGLIDE's Avatar
United States, CA, San Diego
Joined Apr 2011
3,458 Posts
Ok...so i was directed to this thread since i was posting my flash tool issues over in the kk2 thread..

Anyways...here goes...my flash tool was working before and now it doesnt. the only thing i did was load the lasted java build... i have since gone and uninstalled it and made sure i loaded the 64 bit version since i am on a windows 7 machine.

so i have followed all the trouble shooting steps thus far and nothing has worked for me..i try using the serial cmd and regular tool...and nothing works.

here are some screen shots of what happens...

EDIT: Holy crap i figured it out!! my system variables didnt have the .JAR listed...
SDSURFnGLIDE is online now Find More Posts by SDSURFnGLIDE
Last edited by SDSURFnGLIDE; Feb 02, 2013 at 04:27 PM.
Reply With Quote
Old Feb 02, 2013, 06:43 PM
Registered User
Canada, ON, Merrickville-Wolford
Joined Jun 2012
835 Posts
Quote:
Originally Posted by SDSURFnGLIDE View Post
...

EDIT: Holy crap i figured it out!! my system variables didnt have the .JAR listed...
Hot Damn!

Cheers, Andrew

PS. Can you expand on your solution? I went looking into my ENV variables and can't necessarily see where you mean. The one thing I did notice is that in the CLASSPATH variable, it starts with ".", for the current directory, which kinda jives with Christian's comment that you have to start the tool from the directory that it's in. I'd like to make sure I know what caused your misery just in case it happens to me.
Banjo5 is offline Find More Posts by Banjo5
Last edited by Banjo5; Feb 02, 2013 at 07:51 PM. Reason: Add the PS Question
Reply With Quote
Old Feb 02, 2013, 08:49 PM
Multi rotors=No Paycheck left
SDSURFnGLIDE's Avatar
United States, CA, San Diego
Joined Apr 2011
3,458 Posts
Quote:
Originally Posted by Banjo5 View Post
Hot Damn!

Cheers, Andrew

PS. Can you expand on your solution? I went looking into my ENV variables and can't necessarily see where you mean. The one thing I did notice is that in the CLASSPATH variable, it starts with ".", for the current directory, which kinda jives with Christian's comment that you have to start the tool from the directory that it's in. I'd like to make sure I know what caused your misery just in case it happens to me.
Sure thing....so i went into the system variables...my PATH is correct as it is pointing to the current version of java...it was the PATHEXT that i needed to modify...it was missing the .JAR ext that his tool uses to open..

I have included a screen shot...
SDSURFnGLIDE is online now Find More Posts by SDSURFnGLIDE
Reply With Quote
Old Feb 03, 2013, 12:14 AM
Registered User
Canada, ON, Merrickville-Wolford
Joined Jun 2012
835 Posts
Quote:
Originally Posted by SDSURFnGLIDE View Post
Sure thing....so i went into the system variables...my PATH is correct as it is pointing to the current version of java...it was the PATHEXT that i needed to modify...it was missing the .JAR ext that his tool uses to open..

I have included a screen shot...
Thanks. Well I don't know ... I don't have .jar in my PATHEXT and it works fine? Guess we'll leave it as "good to go" for both of us and hope things stay that way. Happy to flash my first ESC's today. Previously had just done various KK boards.

cheers,
Andrew
Banjo5 is offline Find More Posts by Banjo5
Reply With Quote
Old Feb 07, 2013, 04:48 PM
Registered User
--Oz--'s Avatar
United States
Joined Mar 2006
2,184 Posts
HK 30A Blue Series N-FET ESC flash

Hi Lazy and gang,

I just flashed my four HK 30A Blue Series N-FET ESC's using BS-NFET V2012=09-30. Bench testing is all good with servo tester, although I did not hear any beeps from the motor, is this normal?

I did not see a picture of my ESC on the front page so I took pictures of it, maybe update the front page for others to use. Thanks for the flash tool, next is updating my KK2 with v1.5 unless someone suggests something else?

Just waiting for my HK F330 multirotor parts to arrive (my first real quad).
--Oz-- is offline Find More Posts by --Oz--
Last edited by --Oz--; Feb 07, 2013 at 06:02 PM.
Reply With Quote
Old Feb 07, 2013, 05:22 PM
Registered User
JBPiantanida's Avatar
United States, FL, Tampa
Joined Mar 2006
275 Posts
Quote:
Originally Posted by --Oz-- View Post
Hi Lazy and gang,

I just flashed my four HK 30A Blue Series N-FET ESC's using BS-NFET V2012=09-30. Bench testing is all good with servo tester, although I did not hear any beeps from the motor, is this normal?

I did not see a picture of my ESC on the front page so I took pictures of it, maybe update the front page for others to use. Thanks for the flash tool, next is updating my KK2 with v1.5 unless someone suggests something else?

Just waiting for my HK F330 multirotor parts to arrive (my first real quad).
I have the same ESC's and was debating the flashing of them. Now that I know the correct points to tap into I might just do it. I thought I had seen pictures of this ESC before and it was a different layout. This looks a lot easier. VCC is the hardest to make out... but maybe once I cut the shrink wrap off it will be more obvious. It looks like it is probably the + side of that yellow capacitor. That would make sense.

Any chance you have a larger version of the picture? My old eyes would appreciate it.
JBPiantanida is offline Find More Posts by JBPiantanida
Reply With Quote
Old Feb 07, 2013, 05:46 PM
Registered User
--Oz--'s Avatar
United States
Joined Mar 2006
2,184 Posts
Quote:
Originally Posted by JBPiantanida View Post

Any chance you have a larger version of the picture? My old eyes would appreciate it.
Sure, send me your email address.
--Oz-- is offline Find More Posts by --Oz--
Reply With Quote
Old Feb 08, 2013, 02:37 AM
Registered User
srepfler's Avatar
Croatia, Osijek-Baranja County, Valpovo
Joined Jul 2011
391 Posts
Quote:
Originally Posted by --Oz-- View Post
Hi Lazy and gang,

I just flashed my four HK 30A Blue Series N-FET ESC's using BS-NFET V2012=09-30. Bench testing is all good with servo tester, although I did not hear any beeps from the motor, is this normal?

I did not see a picture of my ESC on the front page so I took pictures of it, maybe update the front page for others to use. Thanks for the flash tool, next is updating my KK2 with v1.5 unless someone suggests something else?

Just waiting for my HK F330 multirotor parts to arrive (my first real quad).
They have very silent beeps when flashed, at first I did not hear them, not sure why, but works good.
srepfler is offline Find More Posts by srepfler
Reply With Quote
Old Mar 10, 2013, 06:30 AM
Registered User
Joined Dec 2011
8 Posts
I tried to flash my F-20A esc's with the "bs n-fet" firmware from the repository. It looks like the flashtool couldn't find the firmware. So I tried the "bs n-fet reverse" firmware. flashing the esc worked from the first time. But wen I powered up the esc's I heard some sparking noise and 1 motor burned out in an instant. So now I think I am sitting next to 4 broken esc's and 1 burned motor. Does somebody have any thoughts about what went wrong? I downloaded the firmware manually an reflashed the esc's but I think some of the FET's are defective. I flashed some F-30A esc's some months ago and had no problems.
Roeland54 is offline Find More Posts by Roeland54
Reply With Quote
Old Mar 10, 2013, 07:19 PM
Registered User
Joined Oct 2012
129 Posts
Hey there can someone clarify the Gryo reversal. I need to reverse the yaw gyro and dont want to mess up anything else.

It says
set roll gain pot to zero ( k got that)
Turn on flight controller ( does this mean activate the board, give power to the board, turn on the transmitter, ?)
Move the stick for the gyro you want to reverse ( I want to reverse yaw but I have to increase throttle stick in order to get the rudder active and I dont want that reversed)
LED will blink continually (k)
Turn off flight controller (kill the power to the board or what?)

thank yo
matchpoint is offline Find More Posts by matchpoint
Reply With Quote
Old Mar 11, 2013, 05:32 AM
xcopter
France, RA, Grenoble
Joined Mar 2013
4 Posts
Hy,

If you download the 4.7KK firmware:

Turn on flight controller:
1) Switch on transmitter
2) Plug LiPo to the copter. It will power up your board.

Move the stick for the gyro you want to reverse:
- throttle stick does not change any gyro. You can increase throttle stick then push yaw stick.

Turn off flight controller:
- Unplug LiPo of the copter.

I don't understand why you need to increase throttle stick. But using the previous procedure, it wil be OK.
Alliaume is offline Find More Posts by Alliaume
Reply With Quote
Reply


Thread Tools