HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 02, 2012, 11:24 AM
Registered User
w4Rd3n's Avatar
Switzerland, VS, Oberems
Joined Apr 2010
523 Posts
i also have some kind of jitter if i fly it too fast.
this jitter is becoming a lot more on windy days.
this is just a small clip from today. at 3 secs and at the end you can see the jitter.

http://youtu.be/9eY2X58WIWg
w4Rd3n is online now Find More Posts by w4Rd3n
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 02, 2012, 04:23 PM
Blu-Core is my friend
Gundy's Avatar
La Crosse, WI
Joined Apr 2006
810 Posts
This is just silly.
http://www.columbian.com/news/2012/j...s-stalls-over/

Later,
Gundy
Gundy is offline Find More Posts by Gundy
Reply With Quote
Old Aug 02, 2012, 05:32 PM
Mum is the word!
Joined Jun 2003
6,767 Posts
Yep Riddle use ZII's for all kinds of stuff
klique is offline Find More Posts by klique
Reply With Quote
Old Aug 02, 2012, 05:35 PM
Mum is the word!
Joined Jun 2003
6,767 Posts
Looks like a little turbulance not flutter.
Quote:
Originally Posted by w4Rd3n View Post
i also have some kind of jitter if i fly it too fast.
this jitter is becoming a lot more on windy days.
this is just a small clip from today. at 3 secs and at the end you can see the jitter.

http://youtu.be/9eY2X58WIWg
klique is offline Find More Posts by klique
Reply With Quote
Old Aug 03, 2012, 06:57 AM
Registered User
Australia, TAS, Hobart
Joined Jun 2012
41 Posts
OK. Built my first ever Zephyr II which also happens to be the first ever flying wing for me.

I've started with the pizza box launch from the beginning and it took off on the first try.
It was the nicest plane I've ever tried in a windy day. Right before the launch, I've also tried to fly my skywalker 1900mm. The plane was staying in place upwind with 3/4 throttle. It was too scary, I landed in 5 minutes. Then came the Zephyr and it flew REALLY nice in that wind. Did few rolls and that sort easily which I was never comfortable before. Never reached the full throttle.
Landed smoothly... except the prop was still sticking out instead of aligning with the body like in the videos (I've already turned on the motor brake before launch).
Then on the second launch right after that, It went straight to the ground On the third as well. Still no visible damage but can't figure out the reason.

Could it be the motor mount bent a little bit on the first landing and causing this? I always launched close to or at full throttle.


My setup:
2x 2200mah 5s batteries in the bay - planning to reclaim this area for autopilot and put the batteries in the wing.
3548 700kv HK SK motor I have motor from CK but I didn't have small enough prop or appropriate size 4S battery at the time.
10x7 Master Airscrew prop.
37A at WOT
but seems to be able to cruise nicely at well below 10A.

I have second frame still in the box... I think I'll take its build lot more serious next time :P
mmbbb is offline Find More Posts by mmbbb
Last edited by mmbbb; Aug 03, 2012 at 10:08 PM. Reason: Corrected motor kV number
Reply With Quote
Old Aug 03, 2012, 06:28 PM
never mind the boll⁣⁣⁣ocks
brosius85's Avatar
Australia, NSW
Joined Dec 2010
1,256 Posts
is it still trimmed properly? servos all working throughout their range?

video would be nice, seems very strange to go from flying well to not being flyable instantly
brosius85 is offline Find More Posts by brosius85
Reply With Quote
Old Aug 04, 2012, 01:38 AM
never mind the boll⁣⁣⁣ocks
brosius85's Avatar
Australia, NSW
Joined Dec 2010
1,256 Posts
soooooooon
brosius85 is offline Find More Posts by brosius85
Reply With Quote
Old Aug 04, 2012, 05:28 AM
Registered User
Australia, TAS, Hobart
Joined Jun 2012
41 Posts
Hi Brosius,

Yes it is trimmed right as far as I know. I'll compare the motor mount with the one in the box... I'm also waiting for a better pushrod clevis from HK...

Your Z looks good. Where do you get those stickers?
mmbbb is offline Find More Posts by mmbbb
Reply With Quote
Old Aug 04, 2012, 06:36 AM
never mind the boll⁣⁣⁣ocks
brosius85's Avatar
Australia, NSW
Joined Dec 2010
1,256 Posts
ebay
brosius85 is offline Find More Posts by brosius85
Reply With Quote
Old Aug 04, 2012, 08:20 AM
Money Shot
United States, CA, Lakeside
Joined Apr 2010
903 Posts
my second go is ready, gonna toss it up monday and see what shes got. Sure learned alot about messing with gorilla glue. That's some good stuff





http://rchelicollective.com/zen/kloner/zIIvII/
Kloner is offline Find More Posts by Kloner
Reply With Quote
Old Aug 04, 2012, 08:50 AM
Registered User
Australia, TAS, Hobart
Joined Jun 2012
41 Posts
Brosius,

Where did you get that long yet not thin pushrod? I couldn't find any good on HK...
mmbbb is offline Find More Posts by mmbbb
Reply With Quote
Old Aug 04, 2012, 09:33 AM
Registered User
United States, NV, Las Vegas
Joined Apr 2011
130 Posts
You do some nice work. I checked out your other pictures you posted. Do you have any build threads posted? especially interested in you antenna builds.

John

Quote:
Originally Posted by Kloner View Post
my second go is ready, gonna toss it up monday and see what shes got. Sure learned alot about messing with gorilla glue. That's some good stuff
Chevycruizer is offline Find More Posts by Chevycruizer
Reply With Quote
Old Aug 04, 2012, 11:19 AM
Money Shot
United States, CA, Lakeside
Joined Apr 2010
903 Posts
not really, i just build alot of stuff from the do it yourself CP threads from IBcrazy here. Crosshair, helicals, cloverleafs, spw

Thanks
Kloner is offline Find More Posts by Kloner
Reply With Quote
Old Aug 04, 2012, 11:37 AM
Registered User
Eagle202's Avatar
United States, FL, Clearwater
Joined Aug 2011
1,595 Posts
Quote:
Originally Posted by brosius85 View Post
soooooooon
Wow what a face on your ZII? Is that thing hungry or what?
Eagle202 is offline Find More Posts by Eagle202
Reply With Quote
Old Aug 04, 2012, 11:53 AM
Registered User
Norway
Joined Aug 2011
243 Posts
quick question, when i punch to full throttle the z2 "locks" on,so the steering doesnt work.. its only on full throttle. Why is that? My setup is scorpion s2 3020 1110kv motor with a 65A ritewing esc. Using a 10A CC bec and rvosd5.
Bauf is offline Find More Posts by Bauf
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log Building the ultimate Ritewing Zephyr ThomasWF FPV Talk 34 Feb 20, 2012 05:14 PM
Discussion wing thickness ritewing zephyr Herishi The Builders Workshop 2 Oct 05, 2011 08:36 AM
Discussion Ritewing Zephyr hobbycity motor nexstarselect FPV Talk 2 Mar 07, 2011 04:37 PM