Espritmodel.com Telemetry Radio
Reply
Thread Tools
Old Dec 01, 2012, 04:44 PM
Registered User
Joined Oct 2012
345 Posts
Quote:
Originally Posted by Rick338 View Post
Hooked up a brand new DLv2 system as per manual(that's another story), does not work like it should. It won't even "BIND"! Now that's sad. My guess is that this brand new DLv2 unit is defective. Why? I thought every system is checked before its shipped out? No?

Enrico(Rick)
First of all check if you get solid green when your tx is on:
Then, you must make the calibration:
1.- Install the Tx antenna, and remove the Rx antenna. The Tx must be at least 10ft away from the Rx (If Tx is next to the Rx this can cause an error in the calibration)
2.- Press and hold the bind button on he DL Tx. While holding it, turn on the RC Tx and keep holding the bind button (hold down the button for about 10 seconds or until the LED turns Red.
3.- Release the bind button on the DL Tx and the LED should be alternating between Red and Green.
Start with the DL Rx off and you have to make sure the jumper is connected between signal pins of channels 5-6
4.- Turn on the Rx (make sure there are no servos connected to the Rx.
5.- Let the system run for about 15 minutes.
6. Turn off the Tx and Rx and remove the jumper from the DL Rx.

After Calibration you must change the ID, follow these single steps:
1.- Start with the DL Tx powered off
2.- Press and hold the bind button on the DL Tx.
3.- Turn on the RC Tx and keep holding the bind button for about 20 seconds (the LED will turn totally dark.
4.- Release the bind button and power cycle the Dragonlink Tx.

Finally, you can bind the DL sysem:

1.- Start with the DL Tx and Rx powered off
2.- Press and hold the bind button on the DL Tx.
3.- While holding the bind button, turn the DL Tx on.
4.- Keep holding the bind button for about 7-8 seconds or until the LED turns YELLOW and then release the button.
5.- The DL LED should now be flashing YELLOW.
6.- Power on the DL Rx, the Dragonlink Rx's "status" LED will come on.
7.- Let the system run for about 10-15 seconds.
8.- Power cycle the DL Tx
9.- Power cycle the DL Rx

With these steps you should be ready to go. Hope this help you
Juanp is offline Find More Posts by Juanp
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 01, 2012, 05:19 PM
Registered User
Joined Oct 2012
78 Posts
Quote:
Originally Posted by junioro16v View Post
Are you getting solid green on tx (donīt press the button)?
To bind, the yellow led should be blinking.
Describe exactly whatīs happening!
Yes I'm getting a solid "GREEN" LED on the TX. The brand new DLv2 TX is hooked up to my transmitter(it gets 9.7volts). While the TX is off(no power), I press the "BIND" button and turn on my transmitter(power is added) till I get a solid "YELLOW" LED light and then I release the "BIND" button. Now I get a flashing "YELLOW" LED light, at that time I turn on the brand new DLv2 RX(it gets 6volts and no servos are hooked up to it). All three LEDs light up(red, blue, and green) for a second and then the "BLUE" LED(LINK) flashes and goes out. Now only red(power) and green(status) is lit up and now I cycle the power to my transmitter(DLv2 TX). Now I get a solid "GREEN" LED on the DLv2 TX and looking at the DLv2 RX, the red(power) LED is still on and the green(status) goes out and the "BLUE"(LINK) comes on for 5seconds and then goes out for 1second and then comes back on again and keeps on doing the same even after I cycle the power to the DLv2 RX(turn the power to the RX off and then on). The light on the DLv2 TX is still solid "GREEN". I did the "Calibration" and "ID Change" about 12 to 16 times. I hooked up a couple of servos to test and it works till the "LINK" LED flashes. TX and RX both have their antennas hooked up.

Enrico(Rick)
Rick338 is offline Find More Posts by Rick338
Reply With Quote
Old Dec 01, 2012, 05:28 PM
Registered User
Australia, VIC, Melbourne
Joined Mar 2010
471 Posts
Quote:
Originally Posted by Juanp View Post
First of all check if you get solid green when your tx is on:
Then, you must make the calibration:
1.- Install the Tx antenna, and remove the Rx antenna. The Tx must be at least 10ft away from the Rx (If Tx is next to the Rx this can cause an error in the calibration)
2.- Press and hold the bind button on he DL Tx. While holding it, turn on the RC Tx and keep holding the bind button (hold down the button for about 10 seconds or until the LED turns Red.
3.- Release the bind button on the DL Tx and the LED should be alternating between Red and Green.
Start with the DL Rx off and you have to make sure the jumper is connected between signal pins of channels 5-6
4.- Turn on the Rx (make sure there are no servos connected to the Rx.
5.- Let the system run for about 15 minutes.
6. Turn off the Tx and Rx and remove the jumper from the DL Rx.

After Calibration you must change the ID, follow these single steps:
1.- Start with the DL Tx powered off
2.- Press and hold the bind button on the DL Tx.
3.- Turn on the RC Tx and keep holding the bind button for about 20 seconds (the LED will turn totally dark.
4.- Release the bind button and power cycle the Dragonlink Tx.

Finally, you can bind the DL sysem:

1.- Start with the DL Tx and Rx powered off
2.- Press and hold the bind button on the DL Tx.
3.- While holding the bind button, turn the DL Tx on.
4.- Keep holding the bind button for about 7-8 seconds or until the LED turns YELLOW and then release the button.
5.- The DL LED should now be flashing YELLOW.
6.- Power on the DL Rx, the Dragonlink Rx's "status" LED will come on.
7.- Let the system run for about 10-15 seconds.
8.- Power cycle the DL Tx
9.- Power cycle the DL Rx

With these steps you should be ready to go. Hope this help you
great instructions mate. That will help people who are struggling with the instructions. The only difference I see is for the V1 or upgraded V1 units, but only the added micro mode and bind mode timing. Well done.
Haych is online now Find More Posts by Haych
Reply With Quote
Old Dec 01, 2012, 06:13 PM
Dragon Link/Labs Engineer
chris1seto's Avatar
Chesterfield, MO
Joined Nov 2010
701 Posts
I have more DragonLink EZ breakout board available!!



$9.50 each, these adapters allow you to connect your DragonLink to your TX and battery through commonly found locking connectors. This can be useful if you want to mount your DL on a tripod or otherwise want a nice neat way to hook everything up.

One side hooks directly up to your DragonLink, the other side attaches to a battery through a standard barrel jack and also has a locking connector for your PPM input.

Boards come fully assembled and fully soldered.
chris1seto is offline Find More Posts by chris1seto
Reply With Quote
Old Dec 01, 2012, 07:03 PM
Leesburg FL
Leesburg FL
Joined May 2008
60 Posts
Chris,
How do we order them?
JohnB36 is offline Find More Posts by JohnB36
Reply With Quote
Old Dec 01, 2012, 08:21 PM
Dragon Link/Labs Engineer
chris1seto's Avatar
Chesterfield, MO
Joined Nov 2010
701 Posts
Quote:
Originally Posted by JohnB36 View Post
Chris,
How do we order them?
exactly the way you just did , email or pm me...!

Thanks!
chris1seto is offline Find More Posts by chris1seto
Reply With Quote
Old Dec 01, 2012, 08:27 PM
Dreamer
Australia, TAS, Ulverstone
Joined Aug 2004
2,043 Posts
Quote:
Originally Posted by Rick338 View Post
Yes I'm getting a solid "GREEN" LED on the TX. The brand new DLv2 TX is hooked up to my transmitter(it gets 9.7volts). While the TX is off(no power), I press the "BIND" button and turn on my transmitter(power is added) till I get a solid "YELLOW" LED light and then I release the "BIND" button. Now I get a flashing "YELLOW" LED light, at that time I turn on the brand new DLv2 RX(it gets 6volts and no servos are hooked up to it). All three LEDs light up(red, blue, and green) for a second and then the "BLUE" LED(LINK) flashes and goes out. Now only red(power) and green(status) is lit up and now I cycle the power to my transmitter(DLv2 TX). Now I get a solid "GREEN" LED on the DLv2 TX and looking at the DLv2 RX, the red(power) LED is still on and the green(status) goes out and the "BLUE"(LINK) comes on for 5seconds and then goes out for 1second and then comes back on again and keeps on doing the same even after I cycle the power to the DLv2 RX(turn the power to the RX off and then on). The light on the DLv2 TX is still solid "GREEN". I did the "Calibration" and "ID Change" about 12 to 16 times. I hooked up a couple of servos to test and it works till the "LINK" LED flashes. TX and RX both have their antennas hooked up.

Enrico(Rick)
Gotta be a simple answer. When you power cycle the transmitter after "binding" are you power cycling the Rx at the same time?
kaz1104 is online now Find More Posts by kaz1104
Reply With Quote
Old Dec 01, 2012, 08:58 PM
Leesburg FL
Leesburg FL
Joined May 2008
60 Posts
Quote:
Originally Posted by kaz1104 View Post
Gotta be a simple answer. When you power cycle the transmitter after "binding" are you power cycling the Rx at the same time?
No, just cycle the TX. Once the TX comes on and you have a link, you can power both down. I power them both on at this point and plug in a few servos to make sure the RX is bound ok.
JohnB36 is offline Find More Posts by JohnB36
Reply With Quote
Old Dec 01, 2012, 10:28 PM
Work less, fly more!
Australia, WA, Broome
Joined Aug 2012
435 Posts
Quote:
Originally Posted by Haych View Post
great instructions mate. That will help people who are struggling with the instructions. The only difference I see is for the V1 or upgraded V1 units, but only the added micro mode and bind mode timing. Well done.
Hello all, just a small thing i found with the instructions, my V2 tx in bind mode flashes green not yellow.

angry
angry is offline Find More Posts by angry
Reply With Quote
Old Dec 01, 2012, 11:23 PM
Registered User
Joined Oct 2012
78 Posts
Quote:
Originally Posted by Juanp View Post
First of all check if you get solid green when your tx is on:
Then, you must make the calibration:
1.- Install the Tx antenna, and remove the Rx antenna. The Tx must be at least 10ft away from the Rx (If Tx is next to the Rx this can cause an error in the calibration)
2.- Press and hold the bind button on he DL Tx. While holding it, turn on the RC Tx and keep holding the bind button (hold down the button for about 10 seconds or until the LED turns Red.
3.- Release the bind button on the DL Tx and the LED should be alternating between Red and Green.
Start with the DL Rx off and you have to make sure the jumper is connected between signal pins of channels 5-6
4.- Turn on the Rx (make sure there are no servos connected to the Rx.
5.- Let the system run for about 15 minutes.
6. Turn off the Tx and Rx and remove the jumper from the DL Rx.

After Calibration you must change the ID, follow these single steps:
1.- Start with the DL Tx powered off
2.- Press and hold the bind button on the DL Tx.
3.- Turn on the RC Tx and keep holding the bind button for about 20 seconds (the LED will turn totally dark.
4.- Release the bind button and power cycle the Dragonlink Tx.

Finally, you can bind the DL sysem:

1.- Start with the DL Tx and Rx powered off
2.- Press and hold the bind button on the DL Tx.
3.- While holding the bind button, turn the DL Tx on.
4.- Keep holding the bind button for about 7-8 seconds or until the LED turns YELLOW and then release the button.
5.- The DL LED should now be flashing YELLOW.
6.- Power on the DL Rx, the Dragonlink Rx's "status" LED will come on.
7.- Let the system run for about 10-15 seconds.
8.- Power cycle the DL Tx
9.- Power cycle the DL Rx

With these steps you should be ready to go. Hope this help you
Thank you for the step by step instructions. I have it a try again, and no luck. I "ID Change" 15 times and also "BIND" the same amount. No luck, I think a got myself a bad unit. The only person that can help me here is Mike.

Enrico(Rick)
Rick338 is offline Find More Posts by Rick338
Reply With Quote
Old Dec 02, 2012, 03:53 AM
Dixie Normious
Eastcoast78's Avatar
Can A da....Ehh!!
Joined May 2010
5,290 Posts
Quote:
Originally Posted by angry View Post
Hello all, just a small thing i found with the instructions, my V2 tx in bind mode flashes green not yellow.

angry
watch this...have a look at the 4:00 min mark...is it blinking like this?
DragonLink V2 Micro Power Mode - Range Test (7 min 57 sec)
Eastcoast78 is offline Find More Posts by Eastcoast78
RCG Plus Member
Old Dec 02, 2012, 04:43 AM
Work less, fly more!
Australia, WA, Broome
Joined Aug 2012
435 Posts
Quote:
Originally Posted by Eastcoast78 View Post
watch this...have a look at the 4:00 min mark...is it blinking like this?
http://www.youtube.com/watch?v=nuqZUwjKgno
watched the video, this is my second full system and it bound ok, but when i hold the bind button until the led turns yellow and release it, it flashes green, still binds ok.
angry is offline Find More Posts by angry
Reply With Quote
Old Dec 02, 2012, 07:27 AM
Registered User
Joined Oct 2012
78 Posts
Quote:
Originally Posted by Eastcoast78 View Post
watch this...have a look at the 4:00 min mark...is it blinking like this?
http://www.youtube.com/watch?v=nuqZUwjKgno
Great "How To" video. My brand new DLv2 RX LEDs blinks exactly like yours does in the video(when it's in "MICRO" power) while mines has a solid "GREEN" LED on the brand new DLv2 TX. Both units are 5 feet apart from each other.

Enrico(Rick)
Rick338 is offline Find More Posts by Rick338
Reply With Quote
Old Dec 02, 2012, 09:11 AM
Registered User
Firatp's Avatar
Turkey, Istanbul
Joined Dec 2010
410 Posts
Hi Guys
I building a Raptor FPV and put the antennae as seen on the picture.
Do you thing I am doing right antenna set up or can you advice the a better one. BTW. I am not intending to further than 5-6km.
Thanks
Cheers
Firat
Firatp is offline Find More Posts by Firatp
Reply With Quote
Old Dec 02, 2012, 09:44 AM
Registered User
Firatp's Avatar
Turkey, Istanbul
Joined Dec 2010
410 Posts
With picture
Name: ImageUploadedByTapatalk1354463071.432993.jpg
Views: 96
Size: 59.4 KB
Description:
Firatp is offline Find More Posts by Firatp
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Long Range UHF RC system now avail on STOCK thomasscherrer FPV Equipment 13415 Today 06:47 AM
Wanted Scherrer UHF long Range or Dragon Link patrick21x FPV Equipment (FS/W) 3 May 24, 2014 09:00 PM
New Product ChainLink UHF Long Range System siim227 FPV Talk 2853 Jul 01, 2013 04:23 PM
Yippee! Win a FREE Dragon Link UHF Long range RC system - BEST VIDEO contest for AUGUST !!! JettPilot FPV Talk 58 Sep 10, 2011 09:15 AM
Yippee! Win a FREE Dragon Link UHF RC System - Video Contest JettPilot FPV Talk 63 Aug 02, 2011 10:52 PM