HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 09, 2013, 05:18 PM
Registered User
Jimbo45cn's Avatar
Southwest Florida
Joined Mar 2004
3,252 Posts
Quote:
Originally Posted by War Horse View Post
OK, thanks, going to do it now and reinstall the driver off the HK file.

I got some of the problems worked out on the ZYX, on the other computor, for one thing, I had not removed the swash mix settings, things are working more normal now, but I think I need to start from scratch again with setting up my servos at 50% throttle and level servo horns.

One thing at a time.....
use Johns NZ software as Simon recommends. YOu can download the usb driver from there and it works just fine on my Windows 7 laptop. Jim
Jimbo45cn is offline Find More Posts by Jimbo45cn
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 09, 2013, 05:29 PM
Registered User
War Horse's Avatar
United States, FL, Hernando
Joined Sep 2012
1,460 Posts
Quote:
Originally Posted by Jimbo45cn View Post
use Johns NZ software as Simon recommends. YOu can download the usb driver from there and it works just fine on my Windows 7 laptop. Jim
Arrrg, thats the one that I've got and wont download..........

The set up menu is working fine, but not the dang driver. It just wont recognise the stupid thing. Download failed is what I get over and over.
War Horse is offline Find More Posts by War Horse
Reply With Quote
Old Jan 09, 2013, 05:39 PM
Registered User
Jimbo45cn's Avatar
Southwest Florida
Joined Mar 2004
3,252 Posts
Quote:
Originally Posted by War Horse View Post
Arrrg, thats the one that I've got and wont download..........

The set up menu is working fine, but not the dang driver. It just wont recognise the stupid thing. Download failed is what I get over and over.
I don't know what could be the problem. This is the instruction page for setting up the usb adaptor. One important thing, you cannot have the adaptor plugged in until after its installed. Other than that I am guessing its some setting on your laptop that is preventing the download. Dont' give up, as I said before, I'm old too, but I got mine figuered out. good luck. Jim
http://fbl.net.nz/info/adapter
Jimbo45cn is offline Find More Posts by Jimbo45cn
Last edited by Jimbo45cn; Jan 09, 2013 at 05:40 PM. Reason: added link
Reply With Quote
Old Jan 09, 2013, 05:40 PM
Registered User
ahamay's Avatar
Australia, QLD, Gold Coast
Joined Jun 2012
267 Posts
Quote:
Originally Posted by War Horse View Post
Arrrg, thats the one that I've got and wont download..........

The set up menu is working fine, but not the dang driver. It just wont recognise the stupid thing. Download failed is what I get over and over.
What do you mean by download ? download from the website ? Download to the pc ie install or download from the gyro using the software ? Need more info.

Have you downloaded and saved the driver installer and then run the driver installation ?
ahamay is offline Find More Posts by ahamay
Reply With Quote
Old Jan 09, 2013, 05:45 PM
Registered User
ahamay's Avatar
Australia, QLD, Gold Coast
Joined Jun 2012
267 Posts
I've uploaded the USB driver installation package to my site. It's not zipped etc, just need to download and run it. If your on Windows 7, right click on the EXE and run as administrator.

Tarot ZYX USB Driver Installer EXE
ahamay is offline Find More Posts by ahamay
Reply With Quote
Old Jan 09, 2013, 06:25 PM
Registered User
crashed121's Avatar
Joined Dec 2012
27 Posts
You know. You could probably bypass all the windows 8 frustrations with the Bluetooth dongle, as don't think you need to install the prolific USB driver.
crashed121 is online now Find More Posts by crashed121
Reply With Quote
Old Jan 09, 2013, 06:32 PM
Registered User
ahamay's Avatar
Australia, QLD, Gold Coast
Joined Jun 2012
267 Posts
Quote:
Originally Posted by crashed121 View Post
You know. You could probably bypass all the windows 8 frustrations with the Bluetooth dongle, as don't think you need to install the prolific USB driver.
Yeah, that thought crossed my mind a few times. I'm just using vmware with windows 7 in a virtual machine which works fine.
ahamay is offline Find More Posts by ahamay
Reply With Quote
Old Jan 09, 2013, 09:49 PM
Texas NewB
Black_heart's Avatar
United States, MD, Princess Anne
Joined Dec 2011
917 Posts
Quote:
Originally Posted by War Horse View Post
Arrrg, thats the one that I've got and wont download..........

The set up menu is working fine, but not the dang driver. It just wont recognise the stupid thing. Download failed is what I get over and over.
what browser are you using?
you could also try downloading it to another pc and move it over on a flash drive.
Black_heart is online now Find More Posts by Black_heart
Reply With Quote
Old Jan 09, 2013, 11:44 PM
Registered User
ahamay's Avatar
Australia, QLD, Gold Coast
Joined Jun 2012
267 Posts
Tarot ZYX Software running Windows 8 RTM using Tarot USB to RS232 PL2302 Dongle

I put up a post yesterday about the findings I had with my initial go at getting this working under win8…..most of it was in the right direction but I have spent countless hours testing this and getting it to work so most of what I wrote is now disproved.

Background – Prolific have some info on their website about the PL-2303HX chip which they claim is old and superseded and their latest drivers will not work with windows 8. Seems they have done this on purpose as they obviously had a problem with clone or counterfeit chips circulating in China so there is no win8 support.

Second problem is that Win8 RTM Kernel will not allow you to install unsigned drivers, this is done on purpose and it a security thing. Being a Network Engineer myself I’ve seen countless nasty drivers installed on Win7 machines that are not signed. They can play havoc with power schemes and cause general system issues.

As I knew there were others that have this working in WIN8 I wasn’t going to let it beat me so here is what I had to do on my WIN8 installation to get it working

Firstly you need to deal with allowing win8 to install unsigned drivers. This can be done a couple of ways but I found the command line option was the best. You’ll need to open a command prompt with elevated privs (You can do this by moving to lower left of your screen and right click when the start button pops up) and issue these commands on a separate line with CR after each:

bcdedit -set loadoptions DISABLE_INTEGRITY_CHECKS
bcdedit -set TESTSIGNING ON

You can undo this by reverting to normal using these commands:

bcdedit -set loadoptions ENABLE_INTEGRITY_CHECKS
bcdedit -set TESTSIGNING OFF


Next we need to deal with the local user group policy setting regarding Driver installations.
From your Metro search, type in gpedit.msc and run the Group Policy Editor.
Find the following path:

User Configuration | Administrative Templates | System | Driver Installation | Code signing for device drivers

Set the policy to Disabled and restart your PC or run gpupdate /force at an elevated command prompt.


The latest drivers from the prolific website will not work at all. The drivers that are installed with the Tarot software have been proven to work by some people but I cannot get them to work and I cannot replicate every sequence of installing them so I gave up on them.

I’ve managed to get my hands on the Vista PL-2032 drivers for both 32 and 64bit which work under WIN7 and WIN8. These are not signed either which is why we did step one.

You can download these drivers from my site also using this link:

PL-2303-WIN8.zip

Without the dongle plugged in:

Unzip PL-2303-WIN8 into a folder, then right click on the “ser2pl.inf” file and then say install.
You should get a message saying the install was completed.

Plug in the dongle
At this point you should be up and running with your device manager looking like this:



If you have installed the ZYXUSBDriver.exe that came with the tarot software you'll find that even though you have installed the above driver, it will keep wanting to load the newer one when you plug the dongle in. You need to remove all traces of the ser2pl64.sys (dated 26/7/2012) driver from your system. Do the following:

- Uninstall the driver package from programs in control panel
- delete the ser2pl64.sys driver file from c:\windows\system32\drivers
- delete the ser2pl64.sys driver from c:\windows\lastgood\system32\drivers

There is a utility that comes with the latest drivers from the Prolific website that will identify what chipset you have. You can Download a copy from here and use it on WIN7 or XP to check your chip version:

PL2303 Chip Version.exe

ahamay is offline Find More Posts by ahamay
Last edited by ahamay; Jan 10, 2013 at 06:00 AM. Reason: Updated Procedure
Reply With Quote
Old Jan 10, 2013, 02:38 AM
No Longer Active
pitchp's Avatar
Australia, VIC, Melbourne
Joined Aug 2010
6,627 Posts
Quote:
Originally Posted by ahamay View Post
I also found that you need to have the dongle plugged in when you boot your machine otherwise the drivers donít load.

[/IMG]
How about this, would this work?

1. Windows Key + R
2. Enter shutdown.exe /r /o /f /t 00
3. Click the "OK" button
4. System will restart to a "Choose an option" screen
5. Select "Troubleshoot" from "Choose an option" screen
6. Select "Advanced options" from "Troubleshoot" screen
7. Select "Windows Startup Settings" from "Advanced options" screen
8. Click "Restart" button
9. System will restart to "Advanced Boot Options" screen
10. Select "Disable Driver Signature Enforcement"
11. Once the system starts, install the driver
pitchp is offline Find More Posts by pitchp
Reply With Quote
Old Jan 10, 2013, 03:09 AM
Registered User
ahamay's Avatar
Australia, QLD, Gold Coast
Joined Jun 2012
267 Posts
Quote:
Originally Posted by pitchp View Post
How about this, would this work?

1. Windows Key + R
2. Enter shutdown.exe /r /o /f /t 00
3. Click the "OK" button
4. System will restart to a "Choose an option" screen
5. Select "Troubleshoot" from "Choose an option" screen
6. Select "Advanced options" from "Troubleshoot" screen
7. Select "Windows Startup Settings" from "Advanced options" screen
8. Click "Restart" button
9. System will restart to "Advanced Boot Options" screen
10. Select "Disable Driver Signature Enforcement"
11. Once the system starts, install the driver
Yes that is one way to disable the signing enforcement part.
ahamay is offline Find More Posts by ahamay
Reply With Quote
Old Jan 10, 2013, 04:45 AM
Registered User
War Horse's Avatar
United States, FL, Hernando
Joined Sep 2012
1,460 Posts
I got it !

I guess after doing safe mode restore, it must have opened up something to allow it in , because it didnt take more than a minute to finish up.

Whew ! I.m glad thats over with, last night I was ready to shot gun the putor, now the time will come for me to ask stupid questions on set up, but I will try to find them on my own first
War Horse is offline Find More Posts by War Horse
Reply With Quote
Old Jan 10, 2013, 02:59 PM
Registered User
War Horse's Avatar
United States, FL, Hernando
Joined Sep 2012
1,460 Posts
I knew it, I tried to follow along with Simons videos but his are working in the correct order, thats great for him and whoever else has such luck, tho this isnt the case for me.

I've got all the sliders working in the right direction in the programing by reversing the TX, but nothing seems to work properly on the heli. Using the reverse procedure in the programing for the ZYX, ch 1, 2, 3, does nothing.

Throttle/Pitch= left and right servos up and rear down, elev= all 3 up, forward, ail= left and right work OK, rudder works OK

Do I need to do a reset? if so, where is it. Any other ideas?
War Horse is offline Find More Posts by War Horse
Reply With Quote
Old Jan 10, 2013, 03:05 PM
Registered User
ahamay's Avatar
Australia, QLD, Gold Coast
Joined Jun 2012
267 Posts
Quote:
Originally Posted by War Horse View Post
I knew it, I tried to follow along with Simons videos but his are working in the correct order, thats great for him and whoever else has such luck, tho this isnt the case for me.

I've got all the sliders working in the right direction in the programing by reversing the TX, but nothing seems to work properly on the heli. Using the reverse procedure in the programing for the ZYX, ch 1, 2, 3, does nothing.

Throttle/Pitch= left and right servos up and rear down, elev= all 3 up, forward, ail= left and right work OK, rudder works OK

Do I need to do a reset? if so, where is it. Any other ideas?
I'd say the elevator servo is reversed or the wrong way around in the software.
ahamay is offline Find More Posts by ahamay
Last edited by ahamay; Jan 10, 2013 at 03:12 PM.
Reply With Quote
Old Jan 10, 2013, 03:17 PM
Registered User
War Horse's Avatar
United States, FL, Hernando
Joined Sep 2012
1,460 Posts
Quote:
Originally Posted by ahamay View Post
I'd say the elevator servo is reversed or the wrong way around in the software.
You know I thought that too, and traced them 4 times. I will pull all of them tomorrow and re-do the whole thing. What gets me is that the program doesnt effect the servo direction, tho it did the first time I hooked it up.

OK now , that edit just blew my mind , however I'm going by the sliders in the software program, should I just ignore those , seems that however I set things the mixing isnt right. Yes , everyting in the Tx is turned off.
War Horse is offline Find More Posts by War Horse
Last edited by War Horse; Jan 10, 2013 at 03:23 PM.
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion New ALZRC 3GYS Flybarless System beenflying Mini Helis 644 Dec 07, 2012 04:44 AM
Found Tarot 450 or like, long flybarless feather shafts TubeBarHeli Aircraft - Electric - Helis (FS/W) 2 Jul 25, 2011 01:13 PM
For Sale New Align 3G Flybarless System V2.1 ptt81 Aircraft - Electric - Helis (FS/W) 1 Jun 06, 2011 04:55 PM
For Sale New 2 cell esc &motor FBL 4g6 spektromized DSM2 spektrum Sat URondo Flybarless system blueindian Aircraft - Electric - Helis (FS/W) 0 May 31, 2011 06:09 PM
Discussion Tarot Flybarless avengedkevinfold Electric Heli Talk 1 May 04, 2011 04:46 AM