HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 09, 2012, 09:26 PM
Registered User
USA, FL, Hudson
Joined Dec 2009
196 Posts
Hi guys, I am in need of some trouble shooting advice on two different helis with similar issues. On the first heli, a HK600 converted to FBL with ZYX-s 3.50, on maiden lifts off tail down tail support just touching the ground and my Buddy has no control. Heli sitting perfectly still holding at that angle for several seconds then he has control. We go over everything, repower everything and try again. This time about 5 feet off the ground and same thing, it holds position perfectly level for several seconds then he regains control.

His setup is using the HK MI servos with the 15amp HK Bec off the 6s main pack with frsky radio. My thought since it held position was loss of receiver as the zyx would have controlled the servos to hold position. I told him to rebind during the week and re-ground the tail and we would try it again. Through everything during the week he forgets to rebind. Up goes the heli, it's flying great for several minutes then as he's pulling up he looses control and it continues through a loop and plants itself. My thought maybe still receiver but possibly zyx.

Heli two is mine, an align 450 pro, align esc using internal bec, ds410 and ds450 servos, Hitec optima 6 using 3s to SPC port, zyx-s 3.50. Has flown plenty of basic flights as I am still learning to fly helis, i have converted to a belt tail and have had no issues until this weekend. Saturday I am flying and try to do a flip, I have been having some tail shakes coming out of turns so have been lowering gain and the tail has been blowing out, so the tail gives a 180 turn inverted and I have no control. Does a nice short inverted backward flight as it drops the tail in a backward half loop, tail spins 180 into forward flight about 4ft off the ground when I hit throttle hold. Damn thing smacks the ground on the skids with no damage. If I only was able to fly like that. My friends are cheering me on thinking I just pulled a move like that off.

I had no control other then the throttle hold. Since then I had two more flights today when I had no control for several seconds each time. Both times doing a flip leaving me hovering inverted on one and slowly flying inverted on the other.

With the 12 volts powering the receiver it couldn't have browned out but the esc voltage on the servo buss side could have. I just can't believe it is since it seems like the zyx is holding some sort of control. My buddy has a belt tail but he did ground it before its last flight, mine has never been grounded.

At this point I am not sure what to think. I have two new helicopters I have recently put together, a compass 6hv and the new alzrc devil fast 480 both with zyx-s 3.50 and they have not had any problems at all. Thanks for holding out for such a long post, any advice on this would really be appreciated.

Thanks,
Troy
Troy S is offline Find More Posts by Troy S
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 09, 2012, 10:46 PM
Registered User
Dr.M's Avatar
United States, WA, Issaquah
Joined May 2011
1,524 Posts
Troy S

Control lockout is no joke. I suggest you and your buddy do some bench tests to figure out exactly what's up. The temporary loss of control, while the zyx holds position, sounds more like an Rx problem than a zyx one. Wiggle those servos on the bench and see if you can reproduce the issue. Consider removing main and tail blades and continue the tests with the motor on. Keep a close eye on the zyx LEDs.
Dr.M is offline Find More Posts by Dr.M
Reply With Quote
Old Dec 09, 2012, 10:53 PM
as much as I can
beenflying's Avatar
NZ
Joined Jan 2010
4,967 Posts
Gosh, Troy, really weird. I'm flying 4 of them and have never experienced anything like this, even using belt drive.

I also use the Optima RX and currently have 9 FBL helis using them, all using the flight pack to power the Rx, so I know how bullet proof this is.

If the 450 an HK600 were losing signal, then you would have expected the motor to slow down. Is fail safe set to kill the motor on both helis? If the motor didn't slow down and the failsafe is set to do this, then the gyro must have reset, but IIRC, usually if this happens you don't get proper cyclic control back.

My 250 is belt drive with a ZYX and so is my 450 Sport with a ZYX, and both have had no issues at all.

My only thought can be static, due to your humidity (very dry). Make sure no wires run closer than the frame to any nylon/plastic moving parts. I only fly CF tail blades on my bigger than 450 helicopters (none are belt drive). Also make sure your boom has a metal connection to the CF frames (bypassing the plastic boom holder).

Cross fingers and see if there is any improvement.
beenflying is offline Find More Posts by beenflying
Reply With Quote
Old Dec 09, 2012, 10:58 PM
Beginner Pilot
United States, NY, Coram
Joined Jul 2012
374 Posts
Hey Troy..... I actually shelved my Zyx-s because I was having a similar problem.... trashed two helis because of it. Same thing, flying along and all of a sudden just loss of control..... it will be fine for several flights than all of a sudden SMASH!!!! I went over everything and over everything again...... no idea what it is so if you do figure it out let me know please!!! Like I said, my zyx-s is on the shelf until I can figure out what the hell is going on with it.... I have the Ikon now and I am loving it. Great unit so far.... Let me know how you make out!
gs550t1981 is offline Find More Posts by gs550t1981
Reply With Quote
Old Dec 10, 2012, 12:31 AM
No Longer Active
pitchp's Avatar
Australia, VIC, Melbourne
Joined Aug 2010
6,627 Posts
Quote:
Originally Posted by gs550t1981 View Post
Hey Troy..... I actually shelved my Zyx-s because I was having a similar problem.... trashed two helis because of it. Same thing, flying along and all of a sudden just loss of control..... it will be fine for several flights than all of a sudden SMASH!!!! ! Great unit so far.... Let me know how you make out!
are you serious?
pitchp is offline Find More Posts by pitchp
Reply With Quote
Old Dec 10, 2012, 01:39 AM
Closed Account
Joined Aug 2007
4,497 Posts
Quote:
Originally Posted by gs550t1981 View Post
Hey Troy..... I actually shelved my Zyx-s because I was having a similar problem.... trashed two helis because of it. Same thing, flying along and all of a sudden just loss of control..... it will be fine for several flights than all of a sudden SMASH!!!! I went over everything and over everything again...... no idea what it is so if you do figure it out let me know please!!! Like I said, my zyx-s is on the shelf until I can figure out what the hell is going on with it.... I have the Ikon now and I am loving it. Great unit so far.... Let me know how you make out!
What happened? I have now 5 ZYX and ZYX-S gyros, with a couple that shouldn't work after crashes, but are fine.

What does it do to make you crash?
eagle777 is offline Find More Posts by eagle777
Reply With Quote
Old Dec 10, 2012, 04:55 AM
Beginner Pilot
United States, NY, Coram
Joined Jul 2012
374 Posts
The elev and ail inputs just do not respond. It's scary. Only a 450 but still. I tried new servos, new rx, new ground wire, pretty much everything. I can only think I may have received a faulty unit. Or it might have gotten messed up in a crash. I was about to go back to flybar I was getting very frustrated.
gs550t1981 is offline Find More Posts by gs550t1981
Reply With Quote
Old Dec 10, 2012, 05:02 AM
Looptastic!
sp00fman's Avatar
Enschede, Netherlands
Joined Nov 2009
2,342 Posts
For starters i would disassemble the gyro and go over any suspicious solder points with a small soldering iron. Cut off excessive long leads that went through the PCB. Furthermore check al servo cables for damage/chaffing. Put a piece of foam in there so its more shug in the casing.
An extra capacitor in the powerline is always a good idea. (i borrow the 6,3V 20000mAH ones from old PC motherboards)

I would not fly it until i at least found something that could explain it.
sp00fman is offline Find More Posts by sp00fman
Reply With Quote
Old Dec 10, 2012, 09:00 AM
just gotta mess with it!
2Doggs's Avatar
North West Louisiana
Joined Nov 2009
4,984 Posts
Quote:
Originally Posted by Troy S View Post
Hi guys, I am in need of some trouble shooting advice on two different helis with similar issues. On the first heli, a HK600 converted to FBL with ZYX-s 3.50, on maiden lifts off tail down tail support just touching the ground and my Buddy has no control. Heli sitting perfectly still holding at that angle for several seconds then he has control. We go over everything, repower everything and try again. This time about 5 feet off the ground and same thing, it holds position perfectly level for several seconds then he regains control.

His setup is using the HK MI servos with the 15amp HK Bec off the 6s main pack with frsky radio. My thought since it held position was loss of receiver as the zyx would have controlled the servos to hold position. I told him to rebind during the week and re-ground the tail and we would try it again. Through everything during the week he forgets to rebind. Up goes the heli, it's flying great for several minutes then as he's pulling up he looses control and it continues through a loop and plants itself. My thought maybe still receiver but possibly zyx.

Heli two is mine, an align 450 pro, align esc using internal bec, ds410 and ds450 servos, Hitec optima 6 using 3s to SPC port, zyx-s 3.50. Has flown plenty of basic flights as I am still learning to fly helis, i have converted to a belt tail and have had no issues until this weekend. Saturday I am flying and try to do a flip, I have been having some tail shakes coming out of turns so have been lowering gain and the tail has been blowing out, so the tail gives a 180 turn inverted and I have no control. Does a nice short inverted backward flight as it drops the tail in a backward half loop, tail spins 180 into forward flight about 4ft off the ground when I hit throttle hold. Damn thing smacks the ground on the skids with no damage. If I only was able to fly like that. My friends are cheering me on thinking I just pulled a move like that off.

I had no control other then the throttle hold. Since then I had two more flights today when I had no control for several seconds each time. Both times doing a flip leaving me hovering inverted on one and slowly flying inverted on the other.

With the 12 volts powering the receiver it couldn't have browned out but the esc voltage on the servo buss side could have. I just can't believe it is since it seems like the zyx is holding some sort of control. My buddy has a belt tail but he did ground it before its last flight, mine has never been grounded.

At this point I am not sure what to think. I have two new helicopters I have recently put together, a compass 6hv and the new alzrc devil fast 480 both with zyx-s 3.50 and they have not had any problems at all. Thanks for holding out for such a long post, any advice on this would really be appreciated.

Thanks,
Troy
Has failsafe been set on the FrSky RX? If there's a loss of signal, and failsafe just happens to be set to hold in a hover, you might seem something like you report.

On the loss of tail in a flip - I don't suppose your tail belt is loose? A belt slip could give you a wild tail move, especially in forward flips.
2Doggs is online now Find More Posts by 2Doggs
RCG Plus Member
Latest blog entry: Nano Tech 1800mah 4S 25-50c
Reply With Quote
Old Dec 10, 2012, 03:31 PM
Registered User
USA, FL, Hudson
Joined Dec 2009
196 Posts
Thanks for the replies guys, i'll ask my buddy on the frsky fail safe, as for mine I did not have it set up. I'll have to do that before I mess with it to much more. I wish I could remember if my zyx unit came fresh out of the box or off a 250 I flew for about ten flights. I did have a crash where the blades flew off mid flight and the 250 dropped about 20 feet onto the grass. I did fly it for a few flights after that before pulling the electronics.
Troy S is offline Find More Posts by Troy S
Reply With Quote
Old Dec 10, 2012, 04:14 PM
Registered User
kings lynn, norfolk uk
Joined Sep 2007
597 Posts
Weather looks like it will be better tomorrow so should get chance to do a proper test flight. Should be good hopefully.
peter24 is offline Find More Posts by peter24
Reply With Quote
Old Dec 10, 2012, 07:59 PM
ETFD2 Creator
etheli's Avatar
Worcester, MA
Joined Feb 2007
300 Posts
Here's an article on my HK500 build using the Tarot ZYX-S unit:

http://www.etheli.com/HK500

I have details in there on my ZYX-S settings; using an OrangeRx satellite receiver.

--ET
etheli is offline Find More Posts by etheli
Reply With Quote
Old Dec 10, 2012, 08:32 PM
as much as I can
beenflying's Avatar
NZ
Joined Jan 2010
4,967 Posts
Thanks, etheli. Some good info there and well written.
beenflying is offline Find More Posts by beenflying
Reply With Quote
Old Dec 10, 2012, 08:50 PM
Toy Flyer
glover's Avatar
Flying Field, Work Bench
Joined Mar 2004
612 Posts
ZYX and Futaba s.bus

Connection to a ZYX-S gyro with a Futaba s-bus RX only results in a blinking yellow light and "one jiggle" of the test servo I have connected to the CH1 output of the gyro. Wiggle of sticks gets no servo response. (Servo works when connected to one of the "direct outputs" of the RX.)

Search of this forum only showed one person attempting a similar setup and he gave up without success. And now it seems that I too cannot get past go with my ZYX attempt.

Suggestions will be appreciated.

Fly safe, Glover


PS Tried a conventional RX and setup seems to work fine (spooled up, but not yet flown).

PPS Same S.Bus RX is working with Robird G31, so issue is totally with the ZYX-S.
glover is offline Find More Posts by glover
Last edited by glover; Dec 12, 2012 at 10:26 PM. Reason: S.Bus just does not work in ZYX-S
Reply With Quote
Old Dec 10, 2012, 11:47 PM
Registered User
mligosh's Avatar
New Smyrna Beach, FL
Joined Jun 2005
373 Posts
Troy S and gs550t1981,

Sounds like what I had posted on the CX forum recently:
http://www.rcgroups.com/forums/showp...postcount=1861
http://www.rcgroups.com/forums/showp...postcount=1867
http://www.rcgroups.com/forums/showp...postcount=1895
http://www.rcgroups.com/forums/showp...postcount=1916

I'm still having problems with it. Last flight ended with another lockout and crash

Mike
mligosh is online now Find More Posts by mligosh
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion New ALZRC 3GYS Flybarless System beenflying Mini Helis 644 Dec 07, 2012 05:44 AM
Found Tarot 450 or like, long flybarless feather shafts TubeBarHeli Aircraft - Electric - Helis (FS/W) 2 Jul 25, 2011 02:13 PM
For Sale New Align 3G Flybarless System V2.1 ptt81 Aircraft - Electric - Helis (FS/W) 1 Jun 06, 2011 05:55 PM
For Sale New 2 cell esc &motor FBL 4g6 spektromized DSM2 spektrum Sat URondo Flybarless system blueindian Aircraft - Electric - Helis (FS/W) 0 May 31, 2011 07:09 PM
Discussion Tarot Flybarless avengedkevinfold Electric Heli Talk 1 May 04, 2011 05:46 AM