SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Sep 09, 2011, 08:25 PM
Registered User
United States, NY, New York
Joined Mar 2011
81 Posts
Help!
Blade 400 servo issue

Hey guys I was hoping someone can shed the light on what is going on with this infernal thing. The servo pictured which is plugged in on the receiver into AUX1 port just stopped moving all of sudden. I believe it is aileron servo. I tried another servo and same result, I rebinded the heli and that didn't help either. I have no idea what is going on and am so frustrated I am about to chuck this thing into a wall lol.
PirateBlenny is offline Find More Posts by PirateBlenny
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 09, 2011, 08:57 PM
Registered User
United States, IL, Oquawka
Joined Nov 2003
116 Posts
What radio? If it has a screen for servo monitor, does it show movement on the aux 1 channel?


Matt
HP^Matt is offline Find More Posts by HP^Matt
Reply With Quote
Old Sep 09, 2011, 09:56 PM
Registered User
United States, NY, New York
Joined Mar 2011
81 Posts
DX6I and it does show movement on the channel. That is why I am stumped
PirateBlenny is offline Find More Posts by PirateBlenny
Reply With Quote
Old Sep 09, 2011, 10:14 PM
Registered User
United States, IL, Oquawka
Joined Nov 2003
116 Posts
I suspect that one of the pins on that channel in rx is dead, since it doesnt work with other servos. No extension right? One last thing to try, select another model in the tx, center the sticks as to not bind any thing, then bind to the rx. If it moves the servo then something in the set up has changed...which I doubt.
Is this a working one minute then not, or working one minute, smacked the ground really hard and fixed every thing and it was working then quit? (and beleive me, I'm not asking as a smart A$$. This has happened to me before)

Either way, if you send the rx to Horizon they will most likely take care of you.


Matt
HP^Matt is offline Find More Posts by HP^Matt
Reply With Quote
Old Sep 09, 2011, 10:44 PM
Professional heli wrecker
Luvmyhelis's Avatar
United States, WA, Spokane
Joined Oct 2010
4,219 Posts
Cheap option, log onto the $3.99 6100e knockoff section here at Rc groups F/S section and pick up a few. They work, and work well. So do the orange RX's at HK. Cheap and effective. Rx's have issues, they break, they wear out. Defects happen. I have multiple versions of both and have never had an issue. Ever.
Luvmyhelis is online now Find More Posts by Luvmyhelis
Reply With Quote
Old Sep 09, 2011, 10:50 PM
Registered User
United States, IL, Oquawka
Joined Nov 2003
116 Posts
Quote:
Originally Posted by Luvmyhelis View Post
Cheap option, log onto the $3.99 6100e knockoff section here at Rc groups F/S section and pick up a few. They work, and work well. So do the orange RX's at HK. Cheap and effective. Rx's have issues, they break, they wear out. Defects happen. I have multiple versions of both and have never had an issue. Ever.
= Band-aid

To each his own, but I wouldn't recommend a 3.99 knock off rx to be installed in a 400 size heli to any one...not even my mother in law.

Just sayin
HP^Matt is offline Find More Posts by HP^Matt
Reply With Quote
Old Sep 10, 2011, 02:28 PM
Registered User
United States, NY, New York
Joined Mar 2011
81 Posts
So the general consensus is that its the RX? Ill pick one up then to try it out. I might jsut get a knock off for testing purposes before getting a horizon one.
PirateBlenny is offline Find More Posts by PirateBlenny
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Blade 400 Servo/Gyro pvtparts Electric Heli Talk 1 Sep 05, 2011 09:01 PM
Discussion What's the best way to fit a hitec 5084 tail servo to blade 400 CaptainCarling Mini Helis 2 Jun 16, 2011 12:56 AM
Discussion Blade 400 tail servo houseboat Electric Heli Talk 6 May 17, 2011 07:22 PM
Question Blade 400 Setup Tail Servo Mount Issue Darker4308 Electric Heli Talk 6 Jun 12, 2010 04:22 PM
Question Blade 400: Minor crash damage - new servo issue pipvac Beginner Training Area (Heli-Electric) 2 Jun 01, 2010 06:53 AM