SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old May 11, 2012, 09:43 AM
RC Flying UK's Avatar
United Kingdom, York
Joined Apr 2011
905 Posts
To be honest Geoff at quadcopters.co.uk told me not to over-tighten the props when I bought mine from him last summer, so it's not a new idea. However, also being honest, none of my T580s ever flipped or overheated so perhaps this did help a lot. The reason I didn't like my T580s, after comparing to subsequent machines I bought, was that they were very wobbly in flight, as if the gyro gains were too high or something, so any on board videos I tried to make were all over the place. I always did like the concept of the thing, just it didn't fly very smoothly and there was no way to alter any settings - either through hardware potis like the KK board or through software like, well almost everything else.
RC Flying UK is offline Find More Posts by RC Flying UK
Site Sponsor
Sign up now
to remove ads between posts
Old May 12, 2012, 01:55 AM
Registered User
1Eye's Avatar
Cyprus, Limassol, Pareklisia
Joined Mar 2012
62 Posts
???
1Eye is offline Find More Posts by 1Eye
Last edited by 1Eye; May 12, 2012 at 02:13 AM.
Reply With Quote
Old May 12, 2012, 02:14 AM
Registered User
1Eye's Avatar
Cyprus, Limassol, Pareklisia
Joined Mar 2012
62 Posts
Quote:
Originally Posted by malcr001 View Post
If I was you unless you REALLY loved the frame I'd suggest going for something with a lot more satisfaction from its users. I allways hear about recommendations of the witespy quad. Most of us who do have the T580P+ have totally ripped out the electronics and many parts of the frame and that includes me.

Thanks it's really good to have honest opinions!
I found this: http://www.flying-hobby.com/shop/f45...za-p-9216.html
What do you think?
1Eye is offline Find More Posts by 1Eye
Reply With Quote
Old May 12, 2012, 06:51 AM
Registered User
malcr001's Avatar
United Kingdom, England, Gt Lon
Joined Nov 2007
2,646 Posts
Quote:
Originally Posted by 1Eye View Post
Thanks it's really good to have honest opinions!
I found this: http://www.flying-hobby.com/shop/f45...za-p-9216.html
What do you think?
Not a bad way to go at all plenty go with that and the frame is supposed to be durable.
malcr001 is offline Find More Posts by malcr001
Reply With Quote
Old May 12, 2012, 10:40 AM
Registered User
1Eye's Avatar
Cyprus, Limassol, Pareklisia
Joined Mar 2012
62 Posts
Quote:
Originally Posted by malcr001 View Post
Not a bad way to go at all plenty go with that and the frame is supposed to be durable.
do you have any other suggestions for a first timer with quads?
1Eye is offline Find More Posts by 1Eye
Reply With Quote
Old May 12, 2012, 10:50 AM
Registered User
malcr001's Avatar
United Kingdom, England, Gt Lon
Joined Nov 2007
2,646 Posts
Quote:
Originally Posted by 1Eye View Post
do you have any other suggestions for a first timer with quads?
I dont know what your previous experiance is, are you completely new to rc? or do you also fly other stuff? I fly multirotors specifically for FPV so my experiance is likely to be a bit different to the standard multi-rotor flyer. This is moving a bit off topic now, but feel free to PM for any questions.
malcr001 is offline Find More Posts by malcr001
Reply With Quote
Old May 12, 2012, 12:57 PM
Registered User
Rc Heli Halle's Avatar
Berlin / Germany
Joined Feb 2010
689 Posts
the NEW T580P+ FC and Escs ?

Hi all, saw this Video from Ali.
Flight Testing LotusRC T580P+ New ESC and FC (8 min 2 sec)


http://www.onlyflyingmachines.com/T580PDX.html

Realy so Better ? Where to buy ?

New Production Line , New Producer or Company ?
FC says ANGEL EYE ??

Mike rchhb
Rc Heli Halle is offline Find More Posts by Rc Heli Halle
Reply With Quote
Old May 16, 2012, 10:51 AM
Registered User
Joined May 2012
23 Posts
Alternate electronics for T580P

I have been waiting almost two months for a set of working electronics for my T580P after returning the failed ESC board to the vendor. What other flight control and ESC combinations would allow me to fly using the Lotus motors that came with the quad? Would a NAZA and DJI ESC's work? Any other suggestions including hints about soldering, assembly and calibration would be appreciated.
Thanks.
Windnow is offline Find More Posts by Windnow
Reply With Quote
Old May 16, 2012, 07:14 PM
Registered User
HummingbirdRPV's Avatar
Canada, AB, Edmonton
Joined Mar 2012
295 Posts
New guts for 580P+

Quote:
Originally Posted by Windnow View Post
I have been waiting almost two months for a set of working electronics for my T580P after returning the failed ESC board to the vendor. What other flight control and ESC combinations would allow me to fly using the Lotus motors that came with the quad? Would a NAZA and DJI ESC's work? Any other suggestions including hints about soldering, assembly and calibration would be appreciated.
Thanks.
I am going to try a rabbit FC and four 20A HobbyKing Blue series ESCs. I have the hardware but it's 3rd in line for attention. I have a tricopter I want to finish first, the one from RCExplorer.SE. It will also have a rabbit.
I have run up one of the motors with the 20A ESC and it runs well, nothing gets too hot. There is enough thrust from the 14" props that I can see it bend the arm upward. Mounting holes on the rabbit FC closely match the support posts on the quad.
HummingbirdRPV is offline Find More Posts by HummingbirdRPV
Reply With Quote
Old Jun 02, 2012, 03:00 PM
Registered User
HummingbirdRPV's Avatar
Canada, AB, Edmonton
Joined Mar 2012
295 Posts
Getting the T580P+ back in the air

and I am done,

LotusRC T580P+ Quad Flies Again (2 min 39 sec)
HummingbirdRPV is offline Find More Posts by HummingbirdRPV
Reply With Quote
Old Jul 07, 2012, 02:26 AM
Registered User
bananaman's Avatar
Brisbane Australia
Joined Oct 2000
128 Posts
Hi I have just received a T580P+.
I can't get it to do more than beep 3 times quickly and no motor start.
Futaba 6008 or Orange receivers used (that also work on other models).
All trims, subtrims, endpoints checked. Tried throttle reversed or not.
All ESC leds flash. Wires are correctly oriented and in the right slots.
Powered up with throttle low.
Tried other 3S batteries (charged)
Connections checked.

What else is there apart from a dud board?
Any clues?
I do have a Naza and other gear ordered to replace the electronics, but frustrating I can't get something new to work.
bananaman is offline Find More Posts by bananaman
Reply With Quote
Old Jul 07, 2012, 05:23 AM
Registered User
China
Joined Jul 2010
357 Posts
Quote:
Originally Posted by bananaman View Post
Hi I have just received a T580P+.
I can't get it to do more than beep 3 times quickly and no motor start.
Futaba 6008 or Orange receivers used (that also work on other models).
All trims, subtrims, endpoints checked. Tried throttle reversed or not.
All ESC leds flash. Wires are correctly oriented and in the right slots.
Powered up with throttle low.
Tried other 3S batteries (charged)
Connections checked.

What else is there apart from a dud board?
Any clues?
I do have a Naza and other gear ordered to replace the electronics, but frustrating I can't get something new to work.
sometimes putting the throttle trim down works

if the quad board detects a slight throttle, it will keep beeping continuously and won't arm motors. also if it does not detect any signals from the receivers it will keep beeping.

Connect a servo to a free channel on your receiver and see if you can move the servo so to confirm that receiver is bound and getting signals.
alishanmao is offline Find More Posts by alishanmao
Reply With Quote
Old Jul 07, 2012, 06:38 AM
Registered User
bananaman's Avatar
Brisbane Australia
Joined Oct 2000
128 Posts
Thanks Ali,
All it does is 3 short ascending beeps only, immediately after power up. Red lights at each end of the ESCs flash and a small blue led lights up on the board and nothing else.

Receiver definitely bound properly. (tried three different ones)
I tried and high and low speed mode on the 6008 too
All connectors reseated, pins look OK and soldered wire joints seem good.
Throttle trim, throw, range, reverse, and everything in between has been tried.

It came with a Quality Report with 7 signatures saying it passed tests.
Maybe the flight test was throwing it across the room into a box.
Nearly what happened today

There were no instructions, I found some (version 1.0) on the net and watched Ali's assembly video.
As it was manufactured June2012, could it be a later version that needs stick/s to a particular position to arm like the Skylark I have?
Although, I can't figure out what it might be. Have sent an email to Lotus.

Any other tips?
bananaman is offline Find More Posts by bananaman
Last edited by bananaman; Jul 07, 2012 at 06:48 PM. Reason: More info
Reply With Quote
Old Jul 07, 2012, 10:49 PM
Registered User
China
Joined Jul 2010
357 Posts
Quote:
Originally Posted by bananaman View Post
Thanks Ali,
All it does is 3 short ascending beeps only, immediately after power up. Red lights at each end of the ESCs flash and a small blue led lights up on the board and nothing else.

Receiver definitely bound properly. (tried three different ones)
I tried and high and low speed mode on the 6008 too
All connectors reseated, pins look OK and soldered wire joints seem good.
Throttle trim, throw, range, reverse, and everything in between has been tried.

It came with a Quality Report with 7 signatures saying it passed tests.
Maybe the flight test was throwing it across the room into a box.
Nearly what happened today

There were no instructions, I found some (version 1.0) on the net and watched Ali's assembly video.
As it was manufactured June2012, could it be a later version that needs stick/s to a particular position to arm like the Skylark I have?
Although, I can't figure out what it might be. Have sent an email to Lotus.

Any other tips?
What radio are you using? i had this issue when using walkera radio. no matter what the thing kept beeping. I switched to spektrum all worked. Futaba All worked.

If you are using spektrum and futaba and still the same stuff, possibly something is wrong with those 7 Quality control signatures

can you like do a video showing ESC and board clearly and that sound is clear too. I can send video to LotusRC and ask them what is happening. we have solved one such problem before doing the same.
alishanmao is offline Find More Posts by alishanmao
Reply With Quote
Old Jul 08, 2012, 04:27 AM
Registered User
bananaman's Avatar
Brisbane Australia
Joined Oct 2000
128 Posts
Thanks again for your help Ali, I have tried Futaba/Robbe and Orange receivers and Spektrum receivers. Radios tried Robbe FX30 and JR12X. I can bind with each and drive servos.
Video link here. No arming or start I'm rushing and might seem angry, but the video battery low warning was on and I was trying to finish before it did

I think the props may be on wrong but if I could get something to turn, I could work that out.

If you think my throttle stick is on the wrong side? Mode 1 flyer.
bananaman is offline Find More Posts by bananaman
Last edited by bananaman; Jul 08, 2012 at 04:48 AM.
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product ARF LotusRC T580 quadcopter LotusRC Multirotor Talk 3741 Jan 09, 2012 12:23 PM
Question XAircraft X650 vs. LotusRC T580 ~>Miha<~ Multirotor Talk 8 Sep 08, 2011 03:19 PM
Discussion Our stories-developers and pilots,started with the LotusRC T580 flips yiny0730 Multirotor Talk 3 Jul 02, 2011 07:58 AM