SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Sep 15, 2012, 09:53 PM
Registered User
Philippines, Calabarzon, San Pedro
Joined Jul 2012
4,189 Posts
I'm kinda worried about the wear i've been putting on the wires leading to the battery. I'm thinking of reinforcing it by covering it in hot glue and making the bend less pronounced, but not sure how it'll handle the heat.
Hajile is online now Find More Posts by Hajile
RCG Plus Member
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 16, 2012, 03:56 AM
Registered User
Joined May 2012
41 Posts
Hey,

same problem here - i've covered the cables near the plug in hotglue (if you have a regulated gun, no problem - else, my bosch hotglue gun gets quite hot and i've smeared it on in its hottest state - to no damage) and wrapped the rest in tight heatshrink. This prohibits bending a bit more for most of the cable as well as totally eliminates bending where it does most damage - at the connection to the plug.

Regards
ShellFish31 is offline Find More Posts by ShellFish31
Reply With Quote
Old Sep 16, 2012, 05:16 AM
Registered User
bobfa's Avatar
United States, TX, Cypress
Joined Jan 2012
399 Posts
A small tie wrap works great.
bobfa is offline Find More Posts by bobfa
Reply With Quote
Old Sep 16, 2012, 01:30 PM
Registered User
Joined Oct 2009
485 Posts
Since winter is coming i decided to dust off my genius cp.
I bought two last winter and i fried 1 of them after about 10 batteries by connecting the batterty the wrong way. So now i took out the other one just to find my tx was broken, ruined the lipo that was in it and it wont turn on. So i got my other tx(lucky for me i though my first genius was lost in the mail) and watched finless videos on setting it up again.

Now heres the new problem, if flew fine for one battery. On the second battery it flew fine for about a minute then it started spinning clockwise when i tried to take off and makes a sqreetching sound. If i leave it for 20 minutes and try again it does the same ting, fine for a minute then it starts to spin. I should note that it seems to spin up fine to a certain point when it goes in to a violent clockwise spin. From what i read it should be a counter clockwise spin if the tailmotor was going bad.

Made a thread but it seems like i disapperating so i thought i would post it here to http://www.rcgroups.com/forums/showthread.php?t=1733063
Jetboatftw is offline Find More Posts by Jetboatftw
Reply With Quote
Old Sep 16, 2012, 01:45 PM
<Marty>
United States, KY, Springfield
Joined Jul 2011
1,870 Posts
sounds like a bad bearing or could be the bushings in the motor/motors...if its been sitting a long time and wasent lubed then the bearings are probably dry ...try adding a tiny bit of machine oil or triflow to the bearing and on both ends of the motor shafts...(just a tiny bit)
magic_marty is offline Find More Posts by magic_marty
Reply With Quote
Old Sep 16, 2012, 01:48 PM
Heli collector
livonia bob's Avatar
United States, MI, Livonia
Joined Apr 2009
16,526 Posts
Quote:
Originally Posted by Jetboatftw View Post
Since winter is coming i decided to dust off my genius cp.
I bought two last winter and i fried 1 of them after about 10 batteries by connecting the batterty the wrong way. So now i took out the other one just to find my tx was broken, ruined the lipo that was in it and it wont turn on. So i got my other tx(lucky for me i though my first genius was lost in the mail) and watched finless videos on setting it up again.

Now heres the new problem, if flew fine for one battery. On the second battery it flew fine for about a minute then it started spinning clockwise when i tried to take off and makes a sqreetching sound. If i leave it for 20 minutes and try again it does the same ting, fine for a minute then it starts to spin. I should note that it seems to spin up fine to a certain point when it goes in to a violent clockwise spin. From what i read it should be a counter clockwise spin if the tailmotor was going bad.

Made a thread but it seems like i disapperating so i thought i would post it here to http://www.rcgroups.com/forums/showthread.php?t=1733063
Main motor problem, might just need oiling or pinion is slipping on the motor's shaft. If a brushless motor check that the bell is still tight on the shaft..
livonia bob is offline Find More Posts by livonia bob
Reply With Quote
Old Sep 18, 2012, 08:38 PM
Registered User
Joined Oct 2009
485 Posts
Yes you are right it was the motor, swapped it for the old one since i coulnt see anything else wrong and now it works fine. Will try to revive the broken one with oil but im swapping to brushless soon so i can fly without taking 5 minute cooldowns between each battery. Do you think i have to swap the tail too? Last time i was reading about this a brushless tail was pretty much useless, atleast with the kit.
Jetboatftw is offline Find More Posts by Jetboatftw
Reply With Quote
Old Sep 18, 2012, 08:42 PM
Heli collector
livonia bob's Avatar
United States, MI, Livonia
Joined Apr 2009
16,526 Posts
Quote:
Originally Posted by Jetboatftw View Post
Yes you are right it was the motor, swapped it for the old one since i coulnt see anything else wrong and now it works fine. Will try to revive the broken one with oil but im swapping to brushless soon so i can fly without taking 5 minute cooldowns between each battery. Do you think i have to swap the tail too? Last time i was reading about this a brushless tail was pretty much useless, atleast with the kit.
I think a brushless tail makes the heli to heavy.. Best is having two stock powered ones and just switching between them every flight..
livonia bob is offline Find More Posts by livonia bob
Reply With Quote
Old Sep 18, 2012, 10:51 PM
Registered User
Philippines, Calabarzon, San Pedro
Joined Jul 2012
4,189 Posts
From what i've read. Brushless is more efficient, but takes too long to spool up/down. When it gets a command from the gyro to speed up, by the time it spools up the tail had already drifted further off. The gyro panicks and tells it to add more power even tho the tail is just getting the speed to compensate for the original drift. By the time the tail gets up to the new required speed, it had already overshot the original position and the gyro just goes nuts. The result is a very bad tail wag.
Hajile is online now Find More Posts by Hajile
RCG Plus Member
Reply With Quote
Old Sep 21, 2012, 11:09 PM
Registered User
Malaysia, Federal Territory of Kuala Lumpur, Kuala Lumpur
Joined Jun 2012
285 Posts
hi... what is the best picth curve with best flight time and doesnt hurt the motor for indoor normal flying for GCP? I'm using a devo8s.. I noticed the motor starts to bog down when the pitch is too high after 50% throttle..currently i have mine from 0% to 60% pitch curve..

looks ok now..i set it to higher throttle output and pitch curve which is about 4.5 mins flight before the power gets low with stock bat..

throttle curve - 0, inh, 50, 70, inh, 90, 100 (exp on)
pitch curve - 30, inh, 40, 50, inh, 70, 80 (exp on)
leonggyooi is offline Find More Posts by leonggyooi
Last edited by leonggyooi; Sep 22, 2012 at 11:03 PM.
Reply With Quote
Old Sep 23, 2012, 04:28 AM
Registered User
Joined Dec 2011
87 Posts
Hi,

I have a second Genius CP (the first one is perfectly working)

It's a second hand.

I received it this morning, and powered it on with the same model on my DEVO 8. The only difference is that I put fixed id off on the TX.

First, I saw smoke. Apparently elevator servo. Now it stays blocked in maximum position, whatever the position I give it before powering on the heli.

But I wanted to try the motor. So I moved the motor stick, and it worked. But when I wanted to stop the motor, moving the stick down, the motor kept turning. I had difficulties to power off the heli...

Last try, Throttle cut. I enabled it, disabled it (with the rudder D/R button). Heard a motor song. I enabled it again (so throttle is normally cut), and then motor started turning... And stop when I disabled TC. I could repeat it a lot of time...

It's the double brushless kit from Walkera. I have a hp03s on my first Genius. Does anyone know what is happenning ?

Thank you
Flo38 is offline Find More Posts by Flo38
Reply With Quote
Old Sep 23, 2012, 07:46 AM
Heli Crash Survivor
Crash Survivor's Avatar
United States, AR, North Little Rock
Joined Feb 2011
1,066 Posts
Quote:
Originally Posted by Flo38 View Post
Hi,

I have a second Genius CP (the first one is perfectly working)

It's a second hand.

I received it this morning, and powered it on with the same model on my DEVO 8. The only difference is that I put fixed id off on the TX.

First, I saw smoke. Apparently elevator servo. Now it stays blocked in maximum position, whatever the position I give it before powering on the heli.

But I wanted to try the motor. So I moved the motor stick, and it worked. But when I wanted to stop the motor, moving the stick down, the motor kept turning. I had difficulties to power off the heli...

Last try, Throttle cut. I enabled it, disabled it (with the rudder D/R button). Heard a motor song. I enabled it again (so throttle is normally cut), and then motor started turning... And stop when I disabled TC. I could repeat it a lot of time...

It's the double brushless kit from Walkera. I have a hp03s on my first Genius. Does anyone know what is happenning ?

Thank you
Unplug elevator servo & try it.
Crash Survivor is offline Find More Posts by Crash Survivor
Reply With Quote
Old Sep 23, 2012, 08:31 AM
Registered User
Joined Dec 2011
87 Posts
I changed it for another ( a bit dangerous I guess, but...)

And now it's working. For TC apparently it was because the level was -5%. At 0% it seems to work.

But what happened ?
Flo38 is offline Find More Posts by Flo38
Reply With Quote
Old Sep 23, 2012, 09:59 AM
Certified Heli Addict
RaymondM's Avatar
United States, MI, Cadillac
Joined Apr 2011
970 Posts
Just bought 5 of the Turnigy Nano Techs 300mah 45-90c for my Genius. It is advised to change the connector around so that the polarities will be the same. I plan on adding micro deans connectors to these batteries. My question is this: when I cut off the original connectors the wires from the batteries, red and black, are black negative and red positive right? Don't want to start a fire or burn out the board. Thanks for listening to such a dumb but have to ask question.
RaymondM is online now Find More Posts by RaymondM
Reply With Quote
Old Sep 23, 2012, 10:07 AM
Registered User
Malaysia, Federal Territory of Kuala Lumpur, Kuala Lumpur
Joined Jun 2012
285 Posts
do u think a Rustler or GCP is faster? LOL...now im into offroad too...
leonggyooi is offline Find More Posts by leonggyooi
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion smallest lightest 10-12mp camera? cdi3d Aerial Photography 16 Apr 27, 2011 09:36 PM
Article Think Geek's MX-1 RTF Helicopter Review: Is it the World's smallest R/C helicopter? Michael Heer Coaxial Helicopters 27 Oct 29, 2008 08:43 AM
The lightest 3D belt driven micro electric helicopter in the world--------ELE Firefox ELE kiki Product Announcements 42 Aug 27, 2007 11:49 PM
Discussion ELE firefox-100, flying weight 180g-the lightest 3D helicopter in the world. ELERC Mini Helis 11 Jun 21, 2007 08:17 AM