SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Aug 20, 2011, 08:13 PM
Registered User
Joined Jul 2010
133 Posts
Discussion
Can a KK Controller Board Ruin My ESCs?

I've spent most of the day trying to activate my new KK Control Board, following the connection instructions. Unfortunately, however, nothing turned on, so I started over. None of my ESCs will activate a single motor now using the type of connection I have traditionally used for my rc planes.

I welcome any suggestions.
rtbchris is offline Find More Posts by rtbchris
Last edited by rtbchris; Aug 20, 2011 at 09:44 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 20, 2011, 10:34 PM
Registered User
United States, TN, Brentwood
Joined Oct 2010
563 Posts
Quote:
Originally Posted by rtbchris View Post
I've spent most of the day trying to activate my new KK Control Board, following the connection instructions. Unfortunately, however, nothing turned on, so I started over. None of my ESCs will activate a single motor now using the type of connection I have traditionally used for my rc planes.

I welcome any suggestions.
Have you re-calibrated the throttle range on each ESC - either as directed in the KK instructions or after you put them back on your other flying thing?

You know the drill on the KK, right?

- TAKE OFF THE PROPS!!!!!
- Set Yaw gain pot to zero.
- Put throttle stick to full.
- Power on.
- LED flashes 3 times.(Ready)
- Check a receiver power.
- Wait a few seconds.(In this state, ignore the beeping.)
- LED flashes 3 times.(Start)[Supported in v1.6 or later]
- Wait for motor signal.(Please refer to the manual of ESC.)
- Throttle to zero.
- Wait for motor confirm signal.
- Power off.
- Restore Yaw gain pot.

Of course, if you have not first checked that your radio channels are set correctly (must Throttle be reversed on your radio?) then the above steps will fail.

Be sure to check out the directions on Minsoo Kim's website: www.kkmulticopter.kr
DroneBuilder is offline Find More Posts by DroneBuilder
Reply With Quote
Old Aug 20, 2011, 10:58 PM
Registered User
VA
Joined Nov 2009
2,640 Posts
Quote:
Originally Posted by rtbchris View Post
I've spent most of the day trying to activate my new KK Control Board, following the connection instructions. Unfortunately, however, nothing turned on, so I started over. None of my ESCs will activate a single motor now using the type of connection I have traditionally used for my rc planes.

I welcome any suggestions.
Try hooking the esc/motor to just the throttle channel of the rx with nothing else hooked up except for battery to esc. This will let you check motor function without anything else involved. The usual sequence to calibrate esc is to turn on tx with throttle max. Power esc/motor/rx and wait for beeps then move throttle to low and wait for long beep. Repower and test motor response. If you get each motor to work with just rx then you can move on to board setup.
pug398 is offline Find More Posts by pug398
Reply With Quote
Old Aug 20, 2011, 11:45 PM
Registered User
Joined Jul 2010
133 Posts
Quote:
Originally Posted by pug398 View Post
Try hooking the esc/motor to just the throttle channel of the rx with nothing else hooked up except for battery to esc. This will let you check motor function without anything else involved. The usual sequence to calibrate esc is to turn on tx with throttle max. Power esc/motor/rx and wait for beeps then move throttle to low and wait for long beep. Repower and test motor response. If you get each motor to work with just rx then you can move on to board setup.
I tried that with each of my motors and that is why I am a bit concerned about my ESCs. Usually, they beep, acknowledging that they are calibrated, but they no longer do so since I connected them to the kk board.
rtbchris is offline Find More Posts by rtbchris
Reply With Quote
Old Aug 20, 2011, 11:48 PM
Registered User
Joined Jul 2010
133 Posts
Quote:
Originally Posted by DroneBuilder View Post
Have you re-calibrated the throttle range on each ESC - either as directed in the KK instructions or after you put them back on your other flying thing?

You know the drill on the KK, right?

- TAKE OFF THE PROPS!!!!!
- Set Yaw gain pot to zero.
- Put throttle stick to full.
- Power on.
- LED flashes 3 times.(Ready)
- Check a receiver power.
- Wait a few seconds.(In this state, ignore the beeping.)
- LED flashes 3 times.(Start)[Supported in v1.6 or later]
- Wait for motor signal.(Please refer to the manual of ESC.)
- Throttle to zero.
- Wait for motor confirm signal.
- Power off.
- Restore Yaw gain pot.

Of course, if you have not first checked that your radio channels are set correctly (must Throttle be reversed on your radio?) then the above steps will fail.

Be sure to check out the directions on Minsoo Kim's website: www.kkmulticopter.kr
I have not even put the props on yet, so safety is good for now. The good news is that throttle does not have to be reversed on my radio. Elevator and Ailerons do, though. I went ahead and reversed those, but I do not think that the reversals made a difference so far.

How do I set the Yaw gain pot to zero? The directions on the ycopter.com web site weren't very specific on how to actually go about adjusting those settings.
rtbchris is offline Find More Posts by rtbchris
Reply With Quote
Old Aug 21, 2011, 02:29 PM
Registered User
Joined Jul 2010
133 Posts
Good news: All of my ESCs work properly again now that I do not have them connected to the KK Controller (blue) board. I am so relieved to know that the board did not ruin them.
rtbchris is offline Find More Posts by rtbchris
Reply With Quote
Old Aug 21, 2011, 03:30 PM
Registered User
United States, TN, Brentwood
Joined Oct 2010
563 Posts
Quote:
Originally Posted by rtbchris View Post
Good news: All of my ESCs work properly again now that I do not have them connected to the KK Controller (blue) board. I am so relieved to know that the board did not ruin them.
That is good news!

The bad news is that you clearly did not go look at the directions on Minsoo Kim's website, which I now link to even more specifically: http://www.kkmulticopter.kr/index.html?modea=manual

If you carefully review those directions, you won't need to ask how to set the yaw pot to zero. Instead, you will find very specific high-resolution photo detailing very specifically how to complete all steps in order to get your KK board working.
DroneBuilder is offline Find More Posts by DroneBuilder
Reply With Quote
Old Aug 21, 2011, 03:58 PM
Registered User
Joined Jul 2010
133 Posts
Quote:
Originally Posted by DroneBuilder View Post
That is good news!

The bad news is that you clearly did not go look at the directions on Minsoo Kim's website, which I now link to even more specifically: http://www.kkmulticopter.kr/index.html?modea=manual

If you carefully review those directions, you won't need to ask how to set the yaw pot to zero. Instead, you will find very specific high-resolution photo detailing very specifically how to complete all steps in order to get your KK board working.
DroneBuilder,

Thank you very much for sending me that link. Those directions were quite similar to the ones on the ycopter.com site. All three of my motors spin properly now, because I went back and paired each ESC with my Spektrum DX6i radio. The only ingredient I am missing at this point is how to program my tilt servo. Can you think of any suggestions?

Thanks again,

rtbchris
rtbchris is offline Find More Posts by rtbchris
Reply With Quote
Old Aug 25, 2011, 01:11 AM
F-H
Joined Jun 2010
151 Posts
For the tilt servo, you just need to check it's moving direction is correct or not. There is two directions needed to consider, one is the direction on the radio of RUD channel; and the other one is the Gyro direction of the KK Board. This is like to set the tail of an RC helicopter.
highbird is offline Find More Posts by highbird
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Yet again, more micro's ruined by OMP/Modelflight Ultra_Spitfire Micro Ready-to-Fly 12 Aug 01, 2011 03:56 PM
have i ruined my rffs? RC_AV8R_181 Scratchbuilt Indoor and Micro Models 4 Feb 11, 2003 07:40 PM
Are my LiPolys ruined? Pork Tornado Batteries and Chargers 3 Jan 30, 2003 10:12 AM
Is my esc ruined? rcnutt Electric Plane Talk 5 Sep 27, 2002 10:14 AM
Ruined my BL HILDY Foamies (Kits) 8 Mar 09, 2002 09:41 AM