SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Nov 27, 2011, 06:20 PM
CL-OSD developer
Sverige, Östergötlands Län, Linköping
Joined Apr 2011
279 Posts
erazotropa: See the wiki FAQ here
callelj is offline Find More Posts by callelj
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 28, 2011, 08:55 AM
Registered User
Schweiz, ZH, Hausen am Albis
Joined Oct 2011
7 Posts
Quote:
Originally Posted by chatch15117 View Post
sorry to be a nagging nancy but I've noticed the GPS info is 3-5 seconds behind. The home arrow is always lagging behind and I have to travel in one direction for 5-10 seconds to get an accurate reading.

Would increasing the speed to 4Hz make a difference? I am back on stock 1Hz refresh rate.
I don't think so. I tried it with 2 Hz, but it's a problem of the cheap 1 Hz GPS module.

I will try it with the DIY 10 Hz GPS module attached to my ArduPilot in the next few days.
Consti is offline Find More Posts by Consti
Reply With Quote
Old Nov 28, 2011, 09:46 AM
Registered User
Joined May 2010
237 Posts
Any directions on calibrating bat2 on E-OSD with cl-osd firmware?
http://www.rcgroups.com/forums/showp...&postcount=854
Thanks
aSa2 is offline Find More Posts by aSa2
Reply With Quote
Old Nov 28, 2011, 02:13 PM
CL-OSD developer
Sverige, Östergötlands Län, Linköping
Joined Apr 2011
279 Posts
Quote:
Originally Posted by aSa2 View Post
Any directions on calibrating bat2 on E-OSD with cl-osd firmware?
http://www.rcgroups.com/forums/showp...&postcount=854
Thanks
See FAQ, link in my previous post.
callelj is offline Find More Posts by callelj
Reply With Quote
Old Nov 28, 2011, 03:10 PM
Registered User
Joined May 2010
237 Posts
Quote:
Originally Posted by callelj View Post
See FAQ, link in my previous post.
Oh, thanks for adding that to FAQ, but as i don't know the language i still want to clarify:
if ADC_MULT and ADC_DIV are arrays
#define ADC_MULT 1,1
#define ADC_DIV 1,1

the aquasion:
ADC = (IN[x] * ADC_MULT[x]) / ADC_DIV[x]

so if x=0 then ADC=(IN[0] * 1) / 1 so IN[0] (is that input of voltage reading? i dont get that) is unchanged
what do you mean by: "mult 9 and div 10"?
do i have to add values to arrays or what?

The question is: what is "x" and what an array is "IN"? That would explane me a lot, but not for all

Sorry if that is a dumb question, but that would help me
Thanks
aSa2 is offline Find More Posts by aSa2
Reply With Quote
Old Nov 28, 2011, 04:46 PM
CL-OSD developer
Sverige, Östergötlands Län, Linköping
Joined Apr 2011
279 Posts
Quote:
Originally Posted by aSa2 View Post
Sorry if that is a dumb question, but that would help me
Ok, maybee it was on a bit high level.
Updated the wiki, please see if it answers your questions... :-)
callelj is offline Find More Posts by callelj
Reply With Quote
Old Nov 30, 2011, 03:48 AM
Registered User
Australia, VIC, Kurunjang
Joined Jan 2011
87 Posts
avrdude: initialization failed, rc=-1

I am using a usbtiny programmer and it can't access my g-osd atmega88v chip. It has support for the atmega88 chip.

With this command avrdude -c usbtiny -p m88 I'm getting this error avrdude: initialization failed, rc=-1

Searching the internet this appears to be a wiring problem but I have checked the wiring several times and I'm sure there is no error.

I am using Linux but I have tried on a Windows machine with exactly the same result.

When I plug the g-osd in I get a solid red light on the g-osd and when I run the command the red light goes out briefly.

usbtiny pin 1 --> miso
usbtiny pin 2 --> +5
usbtiny pin 3 --> sck
usbtiny pin 4 --> moso
usbtiny pin 5 --> rst
usbtiny pin 6 --> gnd

RonSpooner is offline Find More Posts by RonSpooner
Reply With Quote
Old Nov 30, 2011, 04:12 AM
Suspended Account
United States, FL, Maitland
Joined Apr 2011
2,109 Posts
you got the pins mixed up somehow or they are shorted. the light should blink rapidly while plugged in but idle and I can't remember what it does when flashing. it might go solid on but not sure. I'll be flashing tonight with a 4Hz firmware so I'll post a video of me flashing it and what it looks like
chatch15117 is offline Find More Posts by chatch15117
Reply With Quote  (Disabled)
Old Nov 30, 2011, 04:16 AM
CL-OSD developer
Sverige, Östergötlands Län, Linköping
Joined Apr 2011
279 Posts
That error is probably one of the worst I know. I gives no help at all on what could be wrong. But it sound like you might have the wiring wrong. The image in the wiki of the pinout on the programmer is from the top, are you sure you haven't mixed it up?

See here: http://www.bot-thoughts.com/2011/07/...-attiny13.html
callelj is offline Find More Posts by callelj
Reply With Quote
Old Nov 30, 2011, 05:39 AM
Registered User
Australia, VIC, Kurunjang
Joined Jan 2011
87 Posts
Quote:
Originally Posted by callelj View Post
That error is probably one of the worst I know. I gives no help at all on what could be wrong. But it sound like you might have the wiring wrong. The image in the wiki of the pinout on the programmer is from the top, are you sure you haven't mixed it up?

See here: http://www.bot-thoughts.com/2011/07/...-attiny13.html
I'm sure I have it right. I can see it's possible to be confused when looking at the cable and the header pins. I checked the voltage on wire 2 and 6 = 4.77v

I thought I may have damaged the g-osd but I just connected it up and it's working fine. I am going to resolder and check the wiring. I will then post a photo and maybe someone can see the problem.
RonSpooner is offline Find More Posts by RonSpooner
Reply With Quote
Old Dec 01, 2011, 01:11 AM
Registered User
Australia, VIC, Kurunjang
Joined Jan 2011
87 Posts
Quote:
Originally Posted by RonSpooner View Post
I'm sure I have it right. I can see it's possible to be confused when looking at the cable and the header pins. I checked the voltage on wire 2 and 6 = 4.77v

I thought I may have damaged the g-osd but I just connected it up and it's working fine. I am going to resolder and check the wiring. I will then post a photo and maybe someone can see the problem.
I tried another programmer, it's a usbasp (10 pins) and I can now access the chip with a new error


sudo avrdude -p m88 -c usbasp -U flash:w:cl-osd.hex -U eeprom:w:cl-osd.eep

avrdude: warning: cannot set sck period. please check for usbasp firmware update.
avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.01s

avrdude: Device signature = 0x1e930a
avrdude: safemode: Verify error - unable to read lfuse properly. Programmer may not be reliable.
avrdude: safemode: To protect your AVR the programming will be aborted

avrdude done. Thank you.

Any help appreciated.
RonSpooner is offline Find More Posts by RonSpooner
Reply With Quote
Old Dec 01, 2011, 04:00 AM
Registered User
Slovenia, Maribor
Joined Oct 2005
5 Posts
I had similar problem. In my case GND pin was troublemaker.

Check
usbtiny pin 6 --> gnd

Open usbprogramer and check if pin6 is realy GND on pcb. I should select diferent GND pin (pin10 i think).
matjazb is offline Find More Posts by matjazb
Reply With Quote
Old Dec 01, 2011, 04:59 AM
Registered User
Australia, VIC, Kurunjang
Joined Jan 2011
87 Posts
Quote:
Originally Posted by matjazb View Post
I had similar problem. In my case GND pin was troublemaker.

Check
usbtiny pin 6 --> gnd

Open usbprogramer and check if pin6 is realy GND on pcb. I should select diferent GND pin (pin10 i think).
Thank you all

Working perfectly now
RonSpooner is offline Find More Posts by RonSpooner
Reply With Quote
Old Dec 01, 2011, 06:13 AM
Registered User
Joined Sep 2010
2,419 Posts
Matjazb I sent you a PM .

A bit off topic question for all you guys who are very fluent in electronic knowledge, does anyone know what is the difference between this two gps's:

FGPMMOPA6C (PA6C) and FGPMMOPA6B...First one is selling for 15eur+vat+shipping (trenz electronic) the other one is selling for 25eur + 3$ shipping (flytron)...

If in a project the B version works would also the C work, where is the difference? (in initialization or where)
msev is online now Find More Posts by msev
Reply With Quote
Old Dec 01, 2011, 02:11 PM
CL-OSD developer
Sverige, Östergötlands Län, Linköping
Joined Apr 2011
279 Posts
Quote:
Originally Posted by msev View Post
Matjazb I sent you a PM .

A bit off topic question for all you guys who are very fluent in electronic knowledge, does anyone know what is the difference between this two gps's:
....
Yes this is a bit of topic. Couldn't you create a separate thread for this?
callelj is offline Find More Posts by callelj
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log Super OSD ($90): Open Source Graphic OSD: Vario, 6xADC, Games, Datalog, Dual Video tom66 FPV Equipment 1928 May 24, 2014 12:07 PM
Discussion Open Source Remote Control System (OSRC) Gizmoman31 Radios 152 Apr 24, 2012 07:01 PM
Discussion Open source OSD for FPV UFO_MAN FPV Talk 75 Sep 07, 2011 03:03 PM
Question Open Source Octo Design Available...Looking for someonw who can cut a copy for me... Schatham421 Multirotor Talk 14 Apr 12, 2011 06:22 PM