SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Aug 12, 2011, 07:58 PM
No you cant fly it.
kicekilla's Avatar
United States, CA, Ridgecrest
Joined Mar 2011
1,257 Posts
Help!
finished my KK quad and got some error

I finished building my quad and when I hooked it up I got some sort of error. if anyone can help me out that would be great.

KK quadcopter error (0 min 26 sec)
kicekilla is offline Find More Posts by kicekilla
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 13, 2011, 12:29 AM
Registered User
OLDTOM's Avatar
United States, TX, Waxahachie
Joined Jun 2011
440 Posts
I cannot hear well enough to determine , but the beeping is usualy one of two things, either your throttle is not low enough, or you battery voltage is not right. Your esc's should have come with a sheet explaining all of the codes for that particular one. Check that your throttle trim is in low positon. Some radios are not exactly 1 ms at low throttle and mid trim.

Good luck..

OLDTOM is offline Find More Posts by OLDTOM
Reply With Quote
Old Aug 13, 2011, 01:57 AM
Registered User
Hawaii
Joined Feb 2003
5,956 Posts
Quote:
Originally Posted by kicekilla View Post
I finished building my quad and when I hooked it up I got some sort of error. if anyone can help me out that would be great.

http://youtu.be/Lk3y4zm5PQs
You speed controllers are not initializing. For the KK board you have to arm the board to initialize the speed controllers. Assuming you have done all the calibration and made sure the gyros are compensating the correct way. Also your radio is controlling the correct way.

Can you tell us a little more on what you have done to prepare the board for flight?

If you don't know you have to arm the board to initialize the speed controller, that is telling me you never had the motors spun up on the board yet. So you may not know if the machine will fly.

Go read this:

http://www.kkmulticopter.kr/index.html?modea=manual

So here is what I suggest.

1) Get your stick neutral point calibrated. Minimum pitch pot.
2) Get your speed controller calibrated. Minimum yaw pot.
3) Arm your machine.
4) Hold machine over your head and increase throttle slowly to right below mid stick.
5) Tilt machine side to side and front and back. Check to see if you have resistance. Yaw machine and see if you have resistance.
6) Move your right control sticks and see if machine tilt properly.
7) Then you can put it down and try fly.

Edit:
Sorry, I believe your speed controllers are going into error code. They are too fast to be the non-initializing beeps.
SeismicCWave is offline Find More Posts by SeismicCWave
Last edited by SeismicCWave; Aug 13, 2011 at 05:35 AM.
Reply With Quote
Old Aug 13, 2011, 04:50 AM
Registered User
United Kingdom
Joined Nov 2008
2,034 Posts
Quote:
Originally Posted by kicekilla View Post
I finished building my quad and when I hooked it up I got some sort of error. if anyone can help me out that would be great.
and what software are you using ?
Mike Barton is offline Find More Posts by Mike Barton
Reply With Quote
Old Aug 14, 2011, 08:29 PM
No you cant fly it.
kicekilla's Avatar
United States, CA, Ridgecrest
Joined Mar 2011
1,257 Posts
Quote:
Originally Posted by SeismicCWave View Post
You speed controllers are not initializing. For the KK board you have to arm the board to initialize the speed controllers. Assuming you have done all the calibration and made sure the gyros are compensating the correct way. Also your radio is controlling the correct way.

Can you tell us a little more on what you have done to prepare the board for flight?

If you don't know you have to arm the board to initialize the speed controller, that is telling me you never had the motors spun up on the board yet. So you may not know if the machine will fly.

Go read this:

http://www.kkmulticopter.kr/index.html?modea=manual

So here is what I suggest.

1) Get your stick neutral point calibrated. Minimum pitch pot.
2) Get your speed controller calibrated. Minimum yaw pot.
3) Arm your machine.
4) Hold machine over your head and increase throttle slowly to right below mid stick.
5) Tilt machine side to side and front and back. Check to see if you have resistance. Yaw machine and see if you have resistance.
6) Move your right control sticks and see if machine tilt properly.
7) Then you can put it down and try fly.

Edit:
Sorry, I believe your speed controllers are going into error code. They are too fast to be the non-initializing beeps.


my board was sold to me brand new with German v4.5 firmware. I bought it all as a kit and built the frame to instruction specs, soldered all of my connectors on, I connected the esc's to 3s lipo this way Name: DSCN2305.jpg
Views: 68
Size: 303.4 KB
Description:

I wired the esc's to the board in the correct 1 2 3 4 order.
I have my ESC's programmed like this using a programming card
brake off
batt: Ni-xx
soft cut-off
middle voltage cut-off
normal start
low timing mode
governor off


I have the RX connected to the right channels and have all my channels reversed correctly for spektrum.

when I plug the battery (tx power on) the blue LED on the KK board flashes once. Esc's go beep-beep-beep , higher tone in accending order, then straight to the constant beeping. (as shown in the previous video) this is all that happens.

I am not getting the 3 LED ready flashes that the link you provided talked about. what do you think I should do or what do you think the problem is? I tried the stick centering via gain pot and Tx, no success on either.
kicekilla is offline Find More Posts by kicekilla
Reply With Quote
Old Aug 14, 2011, 09:29 PM
Registered User
OLDTOM's Avatar
United States, TX, Waxahachie
Joined Jun 2011
440 Posts
Quick test to prove out one more thing, remove props, set throttle full high, turn on system, both transmitter and reciever. If you do not get the extra beeping then your throttle channel is reversed.

OLDTOM is offline Find More Posts by OLDTOM
Reply With Quote
Old Aug 14, 2011, 10:41 PM
Registered User
Hawaii
Joined Feb 2003
5,956 Posts
>>I have my ESC's programmed like this using a programming card
brake off<<

Good.

>>batt: Ni-xx<<

Good.

>>soft cut-off<<

Good.

>>middle voltage cut-off<<

Go to low voltage cut-off when you have a chance.

>>normal start<<

Yes.

>>low timing mode<<

You will want mid timing or high timing.

>>governor off<<

Yes.

>>I have the RX connected to the right channels and have all my channels reversed correctly for spektrum. <<

So if you are flying spektrum you should have throttle = normal, aileron = reversed, elevator = normal, rudder = reversed.

Is your spektrum binding with your transmitter?

Why don't you try pull off the throttle cable. Plug each speed controller cable to the throttle channel on the receiver and try calibrate them one at a time first. Turn on transmitter, advance throttle to high. Plug in battery to machine with only one speed controller plugged into receiver. You should hear one motor goes beep beep to confirm high throttle. Now lower your throttle stick and you should hear a long beep to confirm low throttle.

Do that to all four speed controllers and plug throttle channel back to KK board and plug all speed controllers back to KK board.

Go through the process to calibrate the KK board but turning the pitch pot to low etc.

>>I am not getting the 3 LED ready flashes that the link you provided talked about. what do you think I should do or what do you think the problem is? I tried the stick centering via gain pot and Tx, no success on either.<<

Depend on the firmware you are using. If you are using the new KK firmware V4.7 or something the pot direction is reversed and the motors are not like the link I sent you.

With the new firmware from KK the pot is minimum at clockwise.

You have to get some support from the people that sold you the KK board to find out what firmware they loaded for you. The german V4.5 firmware sounds like maybe it is the new firmware from KK.


SeismicCWave is offline Find More Posts by SeismicCWave
Reply With Quote
Old Aug 15, 2011, 03:26 AM
Registered User
United Kingdom
Joined Nov 2008
2,034 Posts
@ kicekilla

suggest you re-flash the firmware on the board to a version that you/we know how it is supposed to work.

I'm don't see how we can give any advice on fixing your problem when we don't know how the software works....
Mike Barton is offline Find More Posts by Mike Barton
Reply With Quote
Old Aug 15, 2011, 05:56 AM
No you cant fly it.
kicekilla's Avatar
United States, CA, Ridgecrest
Joined Mar 2011
1,257 Posts
Quote:
Originally Posted by Mike Barton View Post
@ kicekilla

suggest you re-flash the firmware on the board to a version that you/we know how it is supposed to work.

I'm don't see how we can give any advice on fixing your problem when we don't know how the software works....
ok sounds good. Im working on getting that done. ill keep you guys posted. Thanks again for all the help!
kicekilla is offline Find More Posts by kicekilla
Reply With Quote
Old Aug 15, 2011, 07:36 AM
No you cant fly it.
kicekilla's Avatar
United States, CA, Ridgecrest
Joined Mar 2011
1,257 Posts
ok well I am trying to update my firmware and having a little trouble. I downloaded the AVR studio 4 and driver but Im not sure if the driver is installing correctly. My kit came with a sony vaio programmer (w/ 10 pin connector) Is this the right programmer? when I open avr studio 4 and click the "connect" button. I select STK500 as said by the how to update page on the kkmulticopter website. after I click connect it reads back, "connect failed - select AVR programmer"


sorry for all the questions and I really apreciate the help. this is all very new to me but I am very interested in quad and want to learn all about them.
kicekilla is offline Find More Posts by kicekilla
Reply With Quote
Old Aug 15, 2011, 02:46 PM
Registered User
Hawaii
Joined Feb 2003
5,956 Posts
Quote:
Originally Posted by kicekilla View Post
ok well I am trying to update my firmware and having a little trouble. I downloaded the AVR studio 4 and driver but Im not sure if the driver is installing correctly. My kit came with a sony vaio programmer (w/ 10 pin connector) Is this the right programmer? when I open avr studio 4 and click the "connect" button. I select STK500 as said by the how to update page on the kkmulticopter website. after I click connect it reads back, "connect failed - select AVR programmer"


sorry for all the questions and I really apreciate the help. this is all very new to me but I am very interested in quad and want to learn all about them.
Contact the person who sold you the hardware.
SeismicCWave is offline Find More Posts by SeismicCWave
Reply With Quote
Old Aug 16, 2011, 03:32 AM
Registered User
French Riviera - Mougins
Joined Nov 2007
43 Posts
Instead of using AVR Studio, try with the flashtool of Lazyzero which is a much more user friendly tool :
http://lazyzero.de/en/modellbau/kkmulticopterflashtool

But you also need to be sure to select the right programmer in the list of programmers. Not sure that yours are in the list.
riva8406 is offline Find More Posts by riva8406
Reply With Quote
Old Aug 16, 2011, 04:23 AM
Fly,crash,glue,repeat!
Jake Bullit's Avatar
Southport,N.W. England
Joined Nov 2007
395 Posts
Bottom RHS motor is twitching,check your connections.
Jake Bullit is offline Find More Posts by Jake Bullit
Reply With Quote
Old Aug 16, 2011, 07:54 AM
Fly,crash,glue,repeat!
Jake Bullit's Avatar
Southport,N.W. England
Joined Nov 2007
395 Posts
Manual is here:

http://www.hobbyking.com/hobbyking/s...71X7478X58.pdf

Dont forget the pots are the opposite way on the HK board.
Jake Bullit is offline Find More Posts by Jake Bullit
Reply With Quote
Old Aug 23, 2011, 04:49 AM
No you cant fly it.
kicekilla's Avatar
United States, CA, Ridgecrest
Joined Mar 2011
1,257 Posts
ok well I have the board working, but in + quad set up and want to use x quad. The problem im having reflashing the board is that I cant the driver for my programmer to install correctly. does anyone use this programmer and know where to find and how to get the driver working? it looks like a sony vaio 4GB USBasp

Name: DSCN2313.jpg
Views: 36
Size: 154.6 KB
Description:

Name: DSCN2308.jpg
Views: 30
Size: 189.8 KB
Description:
kicekilla is offline Find More Posts by kicekilla
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log Some new Quad builds using the KK boards!! tc3wins Multirotor Talk 5 Sep 18, 2011 10:01 PM
Discussion My First Quad - KK Multi and issues, pls help jockstrap Multirotor Talk 8 Jun 08, 2011 09:47 PM
Discussion Just built my 1st KK Quad - problems wrcfan21 Multirotor Talk 2 Mar 21, 2011 04:18 AM
Discussion KK Quad In air from a Gaui Quad guyg Multirotor Talk 1 Jan 21, 2011 06:13 PM