HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jul 31, 2011, 04:43 AM
Registered User
Joined Nov 2005
270 Posts
Help!
Yaw gyro KK board not responding

Hi,

I hope this is not a repost, but the search function didn't solve my problem .

I have received my KK 5.5 Blackboard and installed it on my Tricopter frame. Somehow the yaw gyro seems to be unresponsive.

Pitch and roll work just fine and it tries to stabilise the tricopter like it should.

The tailservo responds normally to yaw inputs that are given by the transmitter. Also when I put the tailservo on motorpins 1, 2 or 3 it instantly tries to compensate for movement.

I am lost here. Can this be a defective yaw gyro on the board. Is there any other way to check this. Or am I missing something simple (I hope )

Firmwares tried:
- Tricopter (V1.6 [m168] kapteinkuk (mirrored by lazyzero.de)
- Tricopter (V2.0 [m168] kkmulticopter.kr)

On V2.0 I also tried the pins on motor 5 (reverse), but it makes no difference

Maybe I should just put on an extra GY401 .

Regards,
Menno
Menno is offline Find More Posts by Menno
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 31, 2011, 04:59 AM
Registered User
United Kingdom
Joined Nov 2008
2,032 Posts
my search function turns up this thread

Hope it helps....
Mike Barton is offline Find More Posts by Mike Barton
Reply With Quote
Old Jul 31, 2011, 05:55 AM
Registered User
Joined Nov 2005
270 Posts
Hi Mike,

Thanks for the response. I actually did see that post, but I missed the fact that he had manual control over the tail servo, just like me.

Hmm, seems like I have a simular problem.

And I hoped i would finally get some airtime this weekend .

I am not sure which points I should measure on the board with my mulitmeter to check??
Menno is offline Find More Posts by Menno
Reply With Quote
Old Jul 31, 2011, 06:09 AM
Registered User
United Kingdom
Joined Nov 2008
2,032 Posts
Quote:
Originally Posted by Menno View Post
I am not sure which points I should measure on the board with my mulitmeter to check??
OK - the Yaw gyro is the vertical board at the back.

The 3 connections at the base are (left to right): Supply (~5V) : Gyro Out (~1.35V) : Ground

So you just need to measure the Gyro Supply and Output voltages relative to the Ground connection.
Mike Barton is offline Find More Posts by Mike Barton
Reply With Quote
Old Jul 31, 2011, 06:20 AM
Registered User
Joined Mar 2011
159 Posts
Yaw gyro

Quote:
Originally Posted by Menno View Post
Hi Mike,

Thanks for the response. I actually did see that post, but I missed the fact that he had manual control over the tail servo, just like me.

Hmm, seems like I have a simular problem.

And I hoped i would finally get some airtime this weekend .

I am not sure which points I should measure on the board with my mulitmeter to check??
I'm not sure either but I will take a look at the soldering on the board. Can sympathise with your frustration as I have had so many conflicting solutions but hey I will crack it at some stage. I'll let you know how I get on when I ref lash my board.

Mike
mikehawkey is offline Find More Posts by mikehawkey
Reply With Quote
Old Jul 31, 2011, 06:52 AM
Registered User
Joined Nov 2005
270 Posts
Quote:
Originally Posted by Mike Barton View Post
OK - the Yaw gyro is the vertical board at the back.

The 3 connections at the base are (left to right): Supply (~5V) : Gyro Out (~1.35V) : Ground

So you just need to measure the Gyro Supply and Output voltages relative to the Ground connection.
I am measuring ~4 volt on the left connection and ~1.4 volt on the middle one
Menno is offline Find More Posts by Menno
Reply With Quote
Old Jul 31, 2011, 08:44 AM
Registered User
Joined Mar 2011
159 Posts
Quote:
Originally Posted by Menno View Post
I am measuring ~4 volt on the left connection and ~1.4 volt on the middle one

Just measured mine and have about 4.6 and 1.7 on the same connectors. Not sure whats that telling me about the problem though other than I am getting roughly the right voltage at those pins.
mikehawkey is offline Find More Posts by mikehawkey
Reply With Quote
Old Jul 31, 2011, 08:48 AM
Suspended Account
Joined Dec 2010
11,764 Posts
The middle one should change as you rotate the board around.
timecop is offline Find More Posts by timecop
Reply With Quote  (Disabled)
Old Jul 31, 2011, 09:22 AM
Registered User
United Kingdom
Joined Nov 2008
2,032 Posts
Quote:
Originally Posted by Menno View Post
I am measuring ~4 volt on the left connection and ~1.4 volt on the middle one
the gyro voltage appears fine.
the 4V seems a bit low (should be at least 4.7v)
What is the voltage across R4 (should be ~90mV) ?

Quote:
Originally Posted by mikehawkey View Post
Just measured mine and have about 4.6 and 1.7 on the same connectors. Not sure whats that telling me about the problem though other than I am getting roughly the right voltage at those pins.
the 1.7V output is way too high (assuming standard murata gyros)
What is the voltage (Aref) on pin 20 of the ATmega (should be ~1.64V) ?
What are the voltages for the other gyros ?

As an example, my KK blackboard gives 4.78V and 1.53V (<=high, so I have changed R10) respectively
Mike Barton is offline Find More Posts by Mike Barton
Reply With Quote
Old Aug 05, 2011, 02:47 PM
Registered User
Joined Nov 2005
270 Posts
Thanks everybody for the responses. I've returned the defective board to the seller and he has send me a new one. The gyros on the new board work like they should.

I guess this thread can be closed.
Menno is offline Find More Posts by Menno
Reply With Quote
Old Nov 26, 2013, 09:58 AM
Registered User
fmata's Avatar
United States, IL, Forest View
Joined Dec 2005
11 Posts
I have a board that broke off wanted to run some wires to the end points..
Would you know where Yaw Gyro Out would go?

Name: Yaw Breakout Board Schematic.jpg
Views: 18
Size: 9.3 KB
Description:

Name: Design Schematics for the v.5.5 SMD PCB.jpg
Views: 19
Size: 74.8 KB
Description:

Name: kk 5 5 board.jpg
Views: 16
Size: 105.2 KB
Description:

Thanks
fmata is offline Find More Posts by fmata
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion KK board as camera-gimbal stabilisation gyro? ed.ge Multirotor Talk 14 Jun 13, 2012 05:56 AM
Mini-HowTo How to fit the new type HK401 gyro sensor to a KK board. kapteinkuk Multirotor Talk 18 Apr 06, 2012 07:12 AM
Question kk blackboard yaw gyro not working!? Help needed. rash Multirotor Talk 13 Oct 28, 2011 06:48 AM
Discussion 2 Gyros on board + 1 Gyro standalone (KK inside)? iacei Multirotor Talk 4 Aug 12, 2011 04:25 AM
Wanted STABLE Quad control board (not kk,gaui or fy90q) RChelisrule FPV Equipment (FS/W) 5 Mar 28, 2011 04:41 PM