HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 12, 2013, 09:40 AM
Registered User
Joined Dec 2009
49 Posts
Thanks, and about amperimeter?
CAYESA is offline Find More Posts by CAYESA
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 12, 2013, 02:36 PM
Registered User
Uruguay, Canelones
Joined Nov 2013
18 Posts
I have a spy hawk, is there any way to record the data on the display of the OSD?
Cuchivasrt is offline Find More Posts by Cuchivasrt
Reply With Quote
Old Nov 13, 2013, 02:33 PM
Registered User
Joined Nov 2013
7 Posts
Video picture runs through

Hello,
I flashed E-OSD-GPS, but the picture on the monitor runs through (like it lost sync?)
Without E-OSD video comes in fine.
Previous E-OSD original SW was also fine.
I also tried inserting a capacitor in the video line after the camera but no luck.
The CL-OSD runs, LED slowly flashing, on the monitor I can see the OSD screen, picture just glitching through.

Setup: 420TVlines Hobbyking camera (PAL)
E-OSD flashed to latest CL-OSD GPS r111 (I tried original hex and my own compilation, removed //#define COLORSYSTEM_NTSC)
Monitor is Renkforce 9" T-900B.

Does somebody know what's the cause?

Regards,
Simon
mrmidi is offline Find More Posts by mrmidi
Reply With Quote
Old Nov 14, 2013, 03:10 AM
Registered User
Joined Dec 2009
49 Posts
I'm sorry, but this project would be good if it have good documentation. I've send emails to flytron to have support but no reply, 39 USD to the rubish
CAYESA is offline Find More Posts by CAYESA
Reply With Quote
Old Nov 18, 2013, 04:51 AM
Registered User
Joined Mar 2012
13 Posts
Quote:
Originally Posted by CAYESA View Post
I'm sorry, but this project would be good if it have good documentation. I've send emails to flytron to have support but no reply, 39 USD to the rubish
I agree - have spent days of my life on this all because the documents reflect the old version.

no info on rssi or black background for new version. I have cooked my unit trying to work it out.

thumbs down for me to
mattyttv is offline Find More Posts by mattyttv
Reply With Quote
Old Nov 18, 2013, 10:39 AM
Registered User
Joined Jul 2011
40 Posts
Quote:
Originally Posted by mrmidi View Post
I flashed E-OSD-GPS, but the picture on the monitor runs through (like it lost sync?)
What firmware did you flash exactly? The e osd is from hobbyking and there exists an open source firmware for the e osd but I have never heard that it is compatible with the diy osd.
schugabe is offline Find More Posts by schugabe
Reply With Quote
Old Nov 21, 2013, 03:23 PM
Registered User
Joined Nov 2013
7 Posts
Quote:
Originally Posted by schugabe View Post
What firmware did you flash exactly? The e osd is from hobbyking and there exists an open source firmware for the e osd but I have never heard that it is compatible with the diy osd.
Hello schugabe,
sorry I googled into the wrong thread - I built the DIY OSD and works fine! Thank you, Dennis!



I used ATmega328 (non "P"), flashed the Arduino-Bootloader and copied the fuse settings from the makefile. All this is included in the Arduino-Download. Programmer-Tool is AVR Dragon @ISP.
Then I connected the FTDI-Dongle (from HK) and used Arduino to compile and flash the DIY OSD "sketch". The rest was simple bread board work.
GPS works, the MT3329 even locks onto Sats indoors!
I still have to connect the current sensor and change the ratios in the config. Also the top lines have to move down a bit.
mrmidi is offline Find More Posts by mrmidi
Last edited by mrmidi; Nov 22, 2013 at 05:28 AM.
Reply With Quote
Old Nov 22, 2013, 03:46 AM
Registered User
Joined Nov 2013
7 Posts
Just a simple question:
What is the number above mAh? On my screen it shows at the time of the photo "945". In the video from Dennis at the beginning of this thread it jumps quite randomly.
Greetings,
Simon
mrmidi is offline Find More Posts by mrmidi
Reply With Quote
Old Nov 22, 2013, 03:51 AM
Registered User
Joined Jul 2011
40 Posts
It can be configured to show the current mah/km or the rssi of the rx.
schugabe is offline Find More Posts by schugabe
Reply With Quote
Old Nov 22, 2013, 05:32 AM
Registered User
Joined Nov 2013
7 Posts
Ok, in config.h is show_rssi 0 and show_mah_km 1, thank you!
mrmidi is offline Find More Posts by mrmidi
Reply With Quote
Old Nov 27, 2013, 09:28 AM
Registered User
Uruguay, Canelones
Joined Nov 2013
18 Posts
Anyone know why my sensor reads 0 mah and 0 volt?.
something needs to change in the code?.
i'm using version 0_18

Thanks,
Cuchivasrt is offline Find More Posts by Cuchivasrt
Reply With Quote
Old Nov 27, 2013, 09:33 AM
Registered User
Joined Jul 2011
40 Posts
Post a wiring diagram+photos of your setup otherwise it is hard to guess what might be wrong
schugabe is offline Find More Posts by schugabe
Reply With Quote
Old Nov 27, 2013, 10:19 AM
Registered User
Uruguay, Canelones
Joined Nov 2013
18 Posts
Quote:
Originally Posted by schugabe View Post
Post a wiring diagram+photos of your setup otherwise it is hard to guess what might be wrong
This is the connection
Cuchivasrt is offline Find More Posts by Cuchivasrt
Reply With Quote
Old Nov 28, 2013, 02:58 AM
Registered User
Joined Jul 2011
40 Posts
you connected the rx to the current sensor? the current sensor should be connected to the esc directly and the rx must be connected to the esc.

you can check the current sensor itself by measuring with a dvm the voltage on the signal pin.
schugabe is offline Find More Posts by schugabe
Reply With Quote
Old Nov 28, 2013, 07:12 AM
Registered User
Uruguay, Canelones
Joined Nov 2013
18 Posts
Thanks schugabe for reply,
I check the voltage between ground and signal, is 0.01 V.
Cuchivasrt is offline Find More Posts by Cuchivasrt
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Diy osd karl k FPV Talk 2 May 03, 2011 12:31 AM
Idea New DIY OSD? atari7202 FPV Talk 1 Mar 25, 2011 12:08 AM
Discussion see my own diy OSD video Passion Aerial Photography 7 May 27, 2010 01:28 AM
Discussion REAL homebrew DIY OSD - Check it out! jafoca FPV Talk 8 Jun 29, 2009 06:52 PM
Discussion picoOSD DIY PIC12F683 based OSD in C kbosak FPV Talk 6 Jan 31, 2008 07:47 AM