HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jul 07, 2011, 03:43 AM
Kyrkbymannen
Uppsala, Sweden
Joined Aug 2006
42 Posts
Discussion
Still having electric problems with my hobbyking Phoenix 2000, Crashvideo

This is the second time the electronics shut down and it results in planting the airplane. Luckily this time it was a hard crash, but almost no damage because of the tough epo wings.
I love the plane and how it flies but this crashing start to annoy me!

Phoenix 2000, light crash, electronics just died! (5 min 10 sec)
kyrkbymannen is offline Find More Posts by kyrkbymannen
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 07, 2011, 04:15 AM
Heli's and gliders, what else?
BarnOwl's Avatar
Nederland, GE, Slijk-Ewijk
Joined Apr 2006
751 Posts
Ouch! On the tarmac......plane sure is tougher then I thougt if it doesn't have anymore damage!

Is your ESC still working? Mostly these cheap ESC's are the culprit.

If you don't want any surprises with this plane I suggest te following:
  1. Change the ESC
  2. Change the motor
  3. Strengthen the firewall (Link)
BarnOwl is offline Find More Posts by BarnOwl
Reply With Quote
Old Jul 07, 2011, 06:42 PM
I'm not lost, they are
pullup!'s Avatar
Co.
Joined Jan 2005
1,414 Posts
Are you running a stand alone BEC?

4 or six servos?
pullup! is offline Find More Posts by pullup!
Reply With Quote
Old Jul 09, 2011, 07:34 PM
Registered User
United States, KY, Madisonville
Joined Mar 2011
544 Posts
Did electronics come back post crash?
Bugbitten is online now Find More Posts by Bugbitten
RCG Plus Member
Latest blog entry: launch elevator
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Still having a blast with the beast.. Enguneer Electric Heli Talk 3 Jun 18, 2011 03:44 AM
Discussion Ohhh noo, 2nd flight on the HobbyKing Phoenix 2000 KillerCut Electric Sailplanes 14 Jun 06, 2011 09:57 AM
Discussion Bill; still having Alt read out problems EugeneFlorida Eagle Tree Systems 1 Mar 28, 2011 11:51 PM
Discussion Still having problems with smartpropo and sppconsole BowerR64 Simulators 1 Feb 10, 2008 05:01 PM
Still having Problems with theEDF motor on my MSW kushal_22 Foamies (Kits) 4 Nov 26, 2002 12:12 AM