HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 31, 2011, 07:56 AM
Master of Flash
LazyZero's Avatar
Alsdorf/Eifel, Germany
Joined Jun 2005
1,551 Posts
No you select the controller corresponding to the target board.
LazyZero is offline Find More Posts by LazyZero
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 31, 2011, 01:40 PM
Registered User
Joined Jul 2007
9 Posts
Quote:
Originally Posted by erazotropa View Post
You select a Atmega48 as uC when creating the project..
Even if it will be flashed into a 168/168P ???
for 168P, select Atmega168
Jonit is offline Find More Posts by Jonit
Reply With Quote
Old Oct 31, 2011, 02:36 PM
MyFlyDream
erazotropa's Avatar
The Netherlands
Joined Jun 2010
414 Posts
ok thanks just to make it clear
erazotropa is offline Find More Posts by erazotropa
Reply With Quote
Old Oct 31, 2011, 02:49 PM
Registered User
HELModels's Avatar
Joined Aug 2003
2,629 Posts
Just wondering, as I wait for parts, if anyone has combined an ardupilot(legacy) with a HK KK board to get GPS and waypoint navigation of the ardupilot? I'm not thinking it would be simple, but hardware would be inexpensive. Figuring out what parts of either firmware to change seems the challenge.
HELModels is online now Find More Posts by HELModels
Reply With Quote
Old Oct 31, 2011, 08:23 PM
Registered User
Sverige, Uppsala Lšn, Uppsala
Joined Mar 2011
76 Posts
Here I go again...

Regarding the "motor 4 issue".
(in + and x-copter with FW4.7)

I just can't get this problem solved!

Problem description:
Motor 4 spins up at about 0-10% throttle. Motor RPM is constant from 10-50% throttle. Motor RPM increases from 50-100% throttle. When throttle is at 50-100%, the motor RPM is a lot less then the other 3 motors.
(Quad is unflyable. Would not lift from ground if I tried.)

Tested so far without success:
* Two different receivers (Orange R610 and Spektrum AR8000).
* Two different ECU's (Plush 12A and Plush 60A)
* Two different motors (HobbyKing 2614 and Turnigy 3548)
* Reprogrammed to + and X-copter with FW4.7, several times.
* Reprogrammed to FW1.1 - EVERYTHING WORKS FINE!, several times.
* Recallibrating ESC's following guides like this one from rcexplorer, several times.
(Yes, I know FW4.7 have different motor and pot setup as in KK's post in this thread.)
* Callibrating both through KK-board and through the RX one ECS at a time, several times.
* Connecting ESC/motor 1-3 to motor 4 on KK. Then they are behaving the same. (This should confirm it is not an ESC/callibration/motor problem)
* Disconnected motor 1-3, only motor 4 connected.
* Fresh batteries
* Reprogrammed ECU's with Low/Middle/High timing (using a programming card)
* Tested two different HK V1 KK-boards.
* Tested all this on two identical X-copter setups, they both have exactly the same problem.

Some people say they just reflash and recallibrate, problem fixed.
This is not my case, believe me! I have spent many many hours on this
Some other people also seem to have this problem, solving it by going back to FW1.1, which is what I'm flying with right now...

I will try with another brand of ECU in a few days, that is all I can come up with.
Does anyone have a working quad with Turnigy Plush ECU's and FW4.7 on a HK V1 board?

PLEASE HELP!

This is how my beauty looks like. Maby this picture can create some sympathies
Windman is offline Find More Posts by Windman
Last edited by Windman; Oct 31, 2011 at 08:41 PM.
Reply With Quote
Old Oct 31, 2011, 11:38 PM
QiW
Registered User
south east asia
Joined Mar 2009
956 Posts
hi windman
i too FACED the same problem as u with the motor #4
the speed of the motor is quite worrying compared to the other 3 motors
so ....
i calibrated the ESCs ... make sure the gyros are working in the correct direction
took my X out to a grass field just in case it flips over it would have minimal damage coz i really wanted to try this 4.7
told myself not to worry about the 4th motor
throttled up ... quad lifted off (i was expecting a flip before it would get into a stable hover)
hovered perfectly !!! just have to trim it out a bit
settled my nerves about the 4th motor ... got into some FF
and now i am in love with the 4.7 ... just could not get enough of it ... LOL
it is seriously flying on rails

i know it all sounds strange and illogical ... but it worked for me
hope it works for u as well
QiW is offline Find More Posts by QiW
Reply With Quote
Old Nov 01, 2011, 01:15 AM
Registered User
Joined Dec 2005
676 Posts
Regarding the motor #4 issue, I've observed this as well. However, the quad (HK V1 with TGY Plush 30A ESC running simonk's firmware) lifts just fine and flies very well. I like it much better than OpenPilot CC in rate mode. It is very stable in wind and I observe very little wooble in rapid descents. I am amazed how much it is possible to acheive with this tiny processor.

Cheers,
Nick
nikivan is offline Find More Posts by nikivan
Reply With Quote
Old Nov 01, 2011, 02:51 AM
MyFlyDream
erazotropa's Avatar
The Netherlands
Joined Jun 2010
414 Posts
Quote:
Originally Posted by nikivan View Post
Regarding the motor #4 issue, I've observed this as well. However, the quad (HK V1 with TGY Plush 30A ESC running simonk's firmware) lifts just fine and flies very well. I like it much better than OpenPilot CC in rate mode. It is very stable in wind and I observe very little wooble in rapid descents. I am amazed how much it is possible to acheive with this tiny processor.

Cheers,
Nick
So, you are selling you opencontrol then?
erazotropa is offline Find More Posts by erazotropa
Reply With Quote
Old Nov 01, 2011, 05:31 AM
Registered User
Sverige, Uppsala Lšn, Uppsala
Joined Mar 2011
76 Posts
Quote:
Originally Posted by nikivan View Post
Regarding the motor #4 issue, I've observed this as well. However, the quad (HK V1 with TGY Plush 30A ESC running simonk's firmware) lifts just fine and flies very well. I like it much better than OpenPilot CC in rate mode. It is very stable in wind and I observe very little wooble in rapid descents. I am amazed how much it is possible to acheive with this tiny processor.

Cheers,
Nick
Hi Nick,

So you had the same issue with KK's v4.7 and are now running simonk's?
Or, you have the same issue with simonk's, and it flies well?
Windman is offline Find More Posts by Windman
Reply With Quote
Old Nov 01, 2011, 05:36 AM
Registered User
Sverige, Uppsala Lšn, Uppsala
Joined Mar 2011
76 Posts
!

Quote:
Originally Posted by nikivan View Post
Regarding the motor #4 issue, I've observed this as well. However, the quad (HK V1 with TGY Plush 30A ESC running simonk's firmware) lifts just fine and flies very well. I like it much better than OpenPilot CC in rate mode. It is very stable in wind and I observe very little wooble in rapid descents. I am amazed how much it is possible to acheive with this tiny processor.

Cheers,
Nick
Hi Nick,

You got me convinced!
I will give lifting a try...
Actually, during my 10-50% throttle when RPM does not change on motor 4... if I tilt the quad the RPM increases (compensates). That's a good sign.
Windman is offline Find More Posts by Windman
Reply With Quote
Old Nov 01, 2011, 06:50 AM
Master of Flash
LazyZero's Avatar
Alsdorf/Eifel, Germany
Joined Jun 2005
1,551 Posts
Quote:
Originally Posted by Jonit View Post
for 168P, select Atmega168
No for 168P select 168P/PA, or the board you use.
LazyZero is offline Find More Posts by LazyZero
Reply With Quote
Old Nov 01, 2011, 10:29 AM
MyFlyDream
erazotropa's Avatar
The Netherlands
Joined Jun 2010
414 Posts
Quote:
Originally Posted by LazyZero View Post
No for 168P select 168P/PA, or the board you use.
That was not for your tool , it was mentioned for compiling the assembly code
erazotropa is offline Find More Posts by erazotropa
Reply With Quote
Old Nov 01, 2011, 10:33 AM
Master of Flash
LazyZero's Avatar
Alsdorf/Eifel, Germany
Joined Jun 2005
1,551 Posts
Ha okay for compiling of cause the 168 for all atmega168/P/PA.

Christian
LazyZero is offline Find More Posts by LazyZero
Reply With Quote
Old Nov 01, 2011, 10:38 AM
Registered User
kalle123's Avatar
Germany - Rhineland
Joined Oct 2008
258 Posts
Quote:
Originally Posted by Windman View Post
Does anyone have a working quad with Turnigy Plush ECU's and FW4.7 on a HK V1 board?
Me.

This one. Rctimer bl, plush 12 a, HK v1 board, 4.7 firmware.

BR KH
kalle123 is offline Find More Posts by kalle123
Reply With Quote
Old Nov 01, 2011, 10:40 AM
Registered User
Joined Sep 2011
324 Posts
I am running 4.7, v1, dt750 and plush/basic 18s. no problems.
Centurion1 is offline Find More Posts by Centurion1
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold KK Multicopter Core Board V5.5 Quadcopter and firmware loader $95 Shipped terriwang Aircraft - Electric - Multirotor (FS/W) 20 Jun 05, 2011 11:34 PM
Cool KK Multicopter Core Board V5.5 Quadcopter and firmware loader $95 Shipped terriwang Hot Online Deals 0 May 26, 2011 12:28 AM
Discussion NEW KK Multicopter Core Board V5.5 Quadcopter and firmware loader terriwang Multirotor Talk 0 May 22, 2011 09:14 PM
Sold Quadcopter KK Multicopter RR or RTF w/Turnigy 9X -- Trades welcome KKUSA Aircraft - Electric - Helis (FS/W) 12 Mar 04, 2011 04:29 PM
For Sale SOLD, THANKS - COMPLETE KK QUAD RTF Kapteinkuk multicopter for sale bob.titus FPV Equipment (FS/W) 0 Nov 12, 2010 07:23 AM