HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 18, 2012, 04:22 PM
Registered User
United States, NE, Lincoln
Joined Jul 2012
67 Posts
Will try thanks Doc.
Here is a couple of pics from my build.
Name: 525 x 001.jpg
Views: 42
Size: 109.9 KB
Description: Name: 525 x 002.jpg
Views: 47
Size: 85.9 KB
Description: Name: 525 x 003.jpg
Views: 42
Size: 103.4 KB
Description:
shawn1979 is offline Find More Posts by shawn1979
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 18, 2012, 04:28 PM
Youtube Johnbrum26
Mckinney,TX
Joined Oct 2010
1,013 Posts
Quote:
Originally Posted by shawn1979 View Post
Will try thanks Doc.
Here is a couple of pics from my build.
Attachment 5091754Attachment 5091755Attachment 5091756
Good ole x525 where it all started.
Killab is offline Find More Posts by Killab
Reply With Quote
Old Aug 18, 2012, 05:33 PM
Registered User
United States, NE, Lincoln
Joined Jul 2012
67 Posts
OK Doc,
I turned down the P on the Roll and Pitch to 3.4 and turned the I on both to .45. There was no noticeable effect. I actually turned the P down on Roll and Pitch all the way to 1.5.

Now instead of a tight circular oscillation after lift off, I get a veering effect on lift off and when I try to compensate to flatten the bird out I get a very wide or loose circular oscillation that is uncontrollable.

The tight circular oscillation is pretty uncontrollable also but i can hover 6 inches off the ground for only seconds and then it wobbles completly out of control.

I calibrated the gyro right before take off every time I adjusted the PID setting. I calibrated the gyro by throttle down yaw left and elevator back and the orange light on the board flashed.

I have expo set on my tx to 40% on my aileron and elevator.
I have my travels set to about 2000 and 1000 ms although when I was running the kk board I had my travels cut back to about 60% on my aileron and elevator.

I'm not sure what to try next.
Name: oscillation still.jpg
Views: 53
Size: 115.6 KB
Description:

Thanks
Shawn
shawn1979 is offline Find More Posts by shawn1979
Reply With Quote
Old Aug 19, 2012, 12:41 PM
Registered User
Joined Apr 2011
54 Posts
Webex at 3PM!!! What are we going to discuss today, any suggestions?
guru_florida is offline Find More Posts by guru_florida
Reply With Quote
Old Aug 19, 2012, 12:54 PM
Some call me the other guy!
DoctorAudio's Avatar
Milwaukie , Oregon
Joined Feb 2003
4,494 Posts
Quote:
Originally Posted by guru_florida View Post
webex at 3pm!!! What are we going to discuss today, any suggestions?
1.
Quote:
Originally Posted by killab View Post
hey doc, couldn't make the web ex last week. Does he record them? Really interested in the gps integration. Would like to see any tips he had.
2.
Quote:
Originally Posted by shawn1979 View Post
ok doc,
i turned down the p on the roll and pitch to 3.4 and turned the i on both to .45. There was no noticeable effect. I actually turned the p down on roll and pitch all the way to 1.5.

Now instead of a tight circular oscillation after lift off, i get a veering effect on lift off and when i try to compensate to flatten the bird out i get a very wide or loose circular oscillation that is uncontrollable.

The tight circular oscillation is pretty uncontrollable also but i can hover 6 inches off the ground for only seconds and then it wobbles completly out of control.

I calibrated the gyro right before take off every time i adjusted the pid setting. I calibrated the gyro by throttle down yaw left and elevator back and the orange light on the board flashed.

I have expo set on my tx to 40% on my aileron and elevator.
I have my travels set to about 2000 and 1000 ms although when i was running the kk board i had my travels cut back to about 60% on my aileron and elevator.

I'm not sure what to try next.
Attachment 5091865

thanks
shawn
DoctorAudio is offline Find More Posts by DoctorAudio
Reply With Quote
Old Aug 19, 2012, 12:57 PM
Some call me the other guy!
DoctorAudio's Avatar
Milwaukie , Oregon
Joined Feb 2003
4,494 Posts
Something just doesn't look right with Shawn's PIDs!
I sense a disruption in the force!
hahaha!
DoctorAudio is offline Find More Posts by DoctorAudio
Reply With Quote
Old Aug 19, 2012, 01:49 PM
Steve
Denton, Tx
Joined Feb 2004
182 Posts
Quote:
Originally Posted by Killab View Post
Hey doc, couldn't make the web ex last week. Does he record them? Really interested in the GPS integration. Would like to see any tips he had.
I would be interested also.
Steve
3D52 is offline Find More Posts by 3D52
Reply With Quote
Old Aug 19, 2012, 01:52 PM
Registered User
Joined Apr 2011
54 Posts
P is *way* too low for any quad. Even my Gaui330 has then set to 2.3. I is way to high. It should be 0.025 or less. The I term can cause oscillations, reduce I to reduce the oscillation. I am not suprised you dampened response and a lot of oscillating with those values.

Shawn, hop on the webex in an hour. We can talk about your quad and what would be suitable PID values. We may also need to enable the gyro filter. It may simply be vibrations causing the problem.

Colin

Quote:
Originally Posted by shawn1979 View Post
OK Doc,
I turned down the P on the Roll and Pitch to 3.4 and turned the I on both to .45. There was no noticeable effect. I actually turned the P down on Roll and Pitch all the way to 1.5.

Now instead of a tight circular oscillation after lift off, I get a veering effect on lift off and when I try to compensate to flatten the bird out I get a very wide or loose circular oscillation that is uncontrollable.

The tight circular oscillation is pretty uncontrollable also but i can hover 6 inches off the ground for only seconds and then it wobbles completly out of control.

I calibrated the gyro right before take off every time I adjusted the PID setting. I calibrated the gyro by throttle down yaw left and elevator back and the orange light on the board flashed.

I have expo set on my tx to 40% on my aileron and elevator.
I have my travels set to about 2000 and 1000 ms although when I was running the kk board I had my travels cut back to about 60% on my aileron and elevator.

I'm not sure what to try next.
Attachment 5091865

Thanks
Shawn
guru_florida is offline Find More Posts by guru_florida
Reply With Quote
Old Aug 19, 2012, 02:05 PM
Some call me the other guy!
DoctorAudio's Avatar
Milwaukie , Oregon
Joined Feb 2003
4,494 Posts
I just was just talking about that with him.
I think need to also look into his Config.H file.
DoctorAudio is offline Find More Posts by DoctorAudio
Last edited by DoctorAudio; Aug 19, 2012 at 10:43 PM.
Reply With Quote
Old Aug 19, 2012, 06:35 PM
Registered User
United States, NE, Lincoln
Joined Jul 2012
67 Posts
Webex was very helpful again.
Thanks
After Webex I played with the PIDs and had my first successful flight. It was a little wobbly but I managed to get it off the ground and drain my small battery without landing or crashing.
Name: First hover PID Settings.jpg
Views: 50
Size: 121.3 KB
Description:
shawn1979 is offline Find More Posts by shawn1979
Reply With Quote
Old Aug 19, 2012, 07:10 PM
Some call me the other guy!
DoctorAudio's Avatar
Milwaukie , Oregon
Joined Feb 2003
4,494 Posts
nice
DoctorAudio is offline Find More Posts by DoctorAudio
Reply With Quote
Old Aug 19, 2012, 07:11 PM
James not bond
jy0933's Avatar
United States, MN, Minneapolis
Joined May 2012
2,074 Posts
looking for webex replay
jy0933 is offline Find More Posts by jy0933
Reply With Quote
Old Aug 19, 2012, 07:14 PM
Some call me the other guy!
DoctorAudio's Avatar
Milwaukie , Oregon
Joined Feb 2003
4,494 Posts
Quote:
Originally Posted by jy0933 View Post
looking for webex replay
We got a sneak view of the venus GPS in action. Had 9-12 sats llinked inside the house.

It is about a month out but hell for that I will wait!
DoctorAudio is offline Find More Posts by DoctorAudio
Reply With Quote
Old Aug 19, 2012, 07:27 PM
Registered User
United States, NE, Lincoln
Joined Jul 2012
67 Posts
Adjusted PID's again almost wobble free. I decided to be brave and threw the acc switch needs some adjusting but seems to work. Its kind of weird, no wobble to a little wobble in acro mode but when I threw the acc switch, it held attitude pretty well considering there was a breeze but instantly wobbled. I adjusted the level PID which I assume is for the acc mode and wobble is almost gone in acc. This is allot of fun when you can get the copter off the ground and tweak settings to make it fly better. Just waiting for another charge.
I'm sure I will have more tuning questions.
Thanks to Colin,DoctorAudio, and everyone else.
shawn1979 is offline Find More Posts by shawn1979
Reply With Quote
Old Aug 19, 2012, 07:57 PM
"Every boy has a dream to fly"
Airplanekid333's Avatar
Fort Collins Colorado
Joined Sep 2009
510 Posts
Hi, I am switching to 2.1
I went into sketch and defined everything I need and verified everything then uploaded it. So i go into config and clicked read and my graph is flat, my values are zero, and there is a flashing red light on my board. Obviously i did something wrong.
Any help would be appreciated!
Shelby
Airplanekid333 is offline Find More Posts by Airplanekid333
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Article Hangar 9's Piper J-3 Cub 40 Plug-N-Play PNP Plug N Play Evo 46NT Powered ARF Review tailskid2 Scale Fuel Planes 8 Dec 24, 2013 05:08 PM
Help! need new flight controller recommendations n3m1s1s Multirotor Talk 115 Jan 09, 2012 10:38 AM
Article Subsonic's Motrolfly Plug and Play Power System: Motor, Controller & Battery Review Michael Heer Power Systems 27 Dec 16, 2010 01:36 PM
Data Plug 'n Play separates: An Esky CP2 with an E-flight 2 in 1... elan Micro Helis 3 Mar 19, 2010 09:51 AM
Discussion Air Hogs Plug n'Play Flight Deck Simulator trust416 Micro Ready-to-Fly 14 Aug 05, 2007 11:44 AM