SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old May 05, 2011, 11:59 PM
Registered User
tamiyafan1975's Avatar
Joined Jun 2008
698 Posts
Discussion
Issue with Champ servo

Hi guys. Just plugged a lipo into my champ tonight and noticed the elevator servo not responding. It was working fine 2 days ago and now its not. When I take it apart and look at the servo, it appears to be fine, but no movement. Also it gets very hot to the touch. Any ideas? Is is finished? If so how can I replace it? Thanks
tamiyafan1975 is offline Find More Posts by tamiyafan1975
RCG Plus Member
Reply With Quote
Sign up now
to remove ads between posts
Old May 06, 2011, 07:19 AM
Power Wheels Guru
UNGN's Avatar
Southlake, TX
Joined Jan 2008
7,327 Posts
Quote:
Originally Posted by tamiyafan1975 View Post
Hi guys. Just plugged a lipo into my champ tonight and noticed the elevator servo not responding. It was working fine 2 days ago and now its not. When I take it apart and look at the servo, it appears to be fine, but no movement. Also it gets very hot to the touch. Any ideas? Is is finished? If so how can I replace it? Thanks
Roll the gears with your finger tip to make sure they spin freely.

if they do, it's probably the motor, wires or the FET.

Chimchim on RCG can fix these problems for $25
UNGN is offline Find More Posts by UNGN
Reply With Quote
Old May 06, 2011, 06:12 PM
Suspended Account
Joined Oct 2006
5,302 Posts
Have you had the plane Long. have you contacted HH I did this the otehr day of march purchase and a free Fuselage and electronics given in mail
fishycomics is offline Find More Posts by fishycomics
Reply With Quote  (Disabled)
Old May 06, 2011, 09:10 PM
Registered User
tamiyafan1975's Avatar
Joined Jun 2008
698 Posts
Actually I called HH today and sure enough they are sending me new electronics in the mail!! They are awesome!!
tamiyafan1975 is offline Find More Posts by tamiyafan1975
RCG Plus Member
Reply With Quote
Old May 07, 2011, 04:50 PM
Looking4Grass in AZ
Afraidtoregister's Avatar
United States, AZ, Mesa
Joined Feb 2011
1,357 Posts
My elevator servo sticks sometimes and I don't know why. A little tug on the line frees it up each time. I dunno. Works.
Afraidtoregister is offline Find More Posts by Afraidtoregister
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Hobbyzone Champ Servo jam Tcragun56 Beginner Training Area (Aircraft-Electric) 3 Apr 21, 2011 07:32 PM
Discussion Servo Reversers, Still bad, or old issue? mikes68charger Radios 5 Mar 04, 2011 10:23 PM
Discussion Champ servo issue iceman88 Micro Ready-to-Fly 23 Oct 12, 2010 07:18 AM
Discussion Programming issue with HFP20 and 5475 servo Phazer Hitec/Multiplex USA 1 Feb 05, 2009 01:53 PM
Discussion JR 7202 with digital servo issue ucsdgemini Mini Helis 6 Dec 08, 2006 02:09 PM