HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 19, 2011, 07:51 PM
Boycot Crappy CC Controllers
snoshoe62's Avatar
United States, MI, Port Huron
Joined Jun 2006
1,955 Posts
Question
DLE-20 and DLE-30 have same Ignition?

I have a new DLE-30, and I have it tuned and running great, but I have a problem I would call a misfire. at High RPM every second or 2 I get a pop which sounds like a definate misfire to me. I have tried the stock plug and 2 new NGK CM6 plugs, still same result. Now, I have a few other DLE-30s but the ignition will be a little more difficult to get off and swap to test on my new one. But I do have a DLE 20 that is easily accessible right now, just wonder if they are the same, does anyone know for sure?
snoshoe62 is offline Find More Posts by snoshoe62
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 19, 2011, 10:12 PM
Village Idiot!
ScooterInVegas's Avatar
United States, NV, Las Vegas
Joined Apr 2011
1,932 Posts
No. The DLE20 has a weird timing thing going on so it will idle super low. I think the timing for the 20 is set around 38 deg. The DLE-30's timing is 28-30 deg at the hall sensor.
ScooterInVegas is offline Find More Posts by ScooterInVegas
Reply With Quote
Old Apr 20, 2011, 02:41 AM
Boycot Crappy CC Controllers
snoshoe62's Avatar
United States, MI, Port Huron
Joined Jun 2006
1,955 Posts
Ok thanks
snoshoe62 is offline Find More Posts by snoshoe62
Reply With Quote
Old Apr 20, 2011, 02:14 PM
Registered User
pilotpete2's Avatar
The Northeast Kingdom, Vermont
Joined Jun 2004
5,172 Posts
Yes, the DLE 20 and 30 use the same ignition module, so just use the one from the DLE 20 to isolate the problem
Yes, the timing is different, but that is determined by the location of the Hall sensor and has nothing to do with the ignition module.
Pete
pilotpete2 is offline Find More Posts by pilotpete2
Reply With Quote
Old Apr 20, 2011, 02:27 PM
Village Idiot!
ScooterInVegas's Avatar
United States, NV, Las Vegas
Joined Apr 2011
1,932 Posts
DLE-20 uses the #4 module and the DLE-30 uses the #1 module. Look at both your modules on the front right side. One will have a #4, the other a #1. Unless your DLE30 is an older side carb.

Both the 30 and 20 have a weird timing curve to help idle. Im 95.3% sure the timing curve is different between the two. The Hall sensor is in a different place on both engines.
ScooterInVegas is offline Find More Posts by ScooterInVegas
Last edited by ScooterInVegas; Apr 20, 2011 at 02:48 PM.
Reply With Quote
Old Apr 20, 2011, 03:34 PM
Registered User
pilotpete2's Avatar
The Northeast Kingdom, Vermont
Joined Jun 2004
5,172 Posts
I see what you mean. But for troubleshooting purposes, I'm sure the difference is subtle. For a definitive answer, the OP should contact Jody at Valley View RC.
Most dealers sell only one version of the RCEXel ignition for engines with the CM-6 plug.
Pete
pilotpete2 is offline Find More Posts by pilotpete2
Reply With Quote
Old Apr 20, 2011, 04:19 PM
Village Idiot!
ScooterInVegas's Avatar
United States, NV, Las Vegas
Joined Apr 2011
1,932 Posts
That's true, Jody knows more about the DLE than anyone.
ScooterInVegas is offline Find More Posts by ScooterInVegas
Reply With Quote
Old Apr 20, 2011, 06:35 PM
Boycot Crappy CC Controllers
snoshoe62's Avatar
United States, MI, Port Huron
Joined Jun 2006
1,955 Posts
I just looked at my dle 20 and it has a #4, and my problem dle 30 rear carb has a #3, i also have a side mount dle 30 that has no number identification on it.
snoshoe62 is offline Find More Posts by snoshoe62
Last edited by snoshoe62; Apr 20, 2011 at 09:11 PM.
Reply With Quote
Old Apr 21, 2011, 06:30 AM
Registered User
United States, MI, South Lyon
Joined Aug 2004
1,178 Posts
http://www.rcuniverse.com/forum/m_98...m.htm#10402619
StrangeGager is offline Find More Posts by StrangeGager
Reply With Quote
Old Apr 21, 2011, 09:47 AM
Registered User
cje0114's Avatar
Carteret, NJ
Joined Feb 2006
1,255 Posts
I'm having similar issues with my rear carb dle30. The timing was way off from the box and originally it ran like crap. I now have the timing advanced to about 30 degrees and it runs much better but it is getting a constant misfire around half throttle. I can't tune it out so I'm guessing it is and ignition or timing problem. I can advance the timing any more though. Anybody have any thoughts on this? I will not call vvrc about this....long story but I am no longer going to be a customer to them..
cje0114 is offline Find More Posts by cje0114
Reply With Quote
Old Apr 21, 2011, 11:16 AM
Village Idiot!
ScooterInVegas's Avatar
United States, NV, Las Vegas
Joined Apr 2011
1,932 Posts
Put a ngk in it? The stock plug can cause back firing sometimes.
ScooterInVegas is offline Find More Posts by ScooterInVegas
Reply With Quote
Old Apr 21, 2011, 11:18 AM
Registered User
cje0114's Avatar
Carteret, NJ
Joined Feb 2006
1,255 Posts
Yes it has a ngk cm6 plug. I tried another one also just to make sure it wasn't a bad plug. The gap is also set correctly...
cje0114 is offline Find More Posts by cje0114
Reply With Quote
Old Apr 21, 2011, 02:47 PM
Boycot Crappy CC Controllers
snoshoe62's Avatar
United States, MI, Port Huron
Joined Jun 2006
1,955 Posts
side mount dle 30

Quote:
Originally Posted by cje0114 View Post
Yes it has a ngk cm6 plug. I tried another one also just to make sure it wasn't a bad plug. The gap is also set correctly...
I have one of those to, it has that cruising rpm burble to it. I havnt checked the timing on it yet. Need to get a timing wheel somewhere, my lhs doesnt have them
snoshoe62 is offline Find More Posts by snoshoe62
Reply With Quote
Old Apr 21, 2011, 02:49 PM
Registered User
cje0114's Avatar
Carteret, NJ
Joined Feb 2006
1,255 Posts
You can print a manual for a rcxcel ignition. There is one on the last page. I laminated mine and glued it to a piece of aluminum.
cje0114 is offline Find More Posts by cje0114
Reply With Quote
Old Apr 22, 2011, 01:15 PM
www.rcdude.com
JEFFRO503's Avatar
Joined May 2006
678 Posts
Quote:
Originally Posted by cje0114 View Post
I'm having similar issues with my rear carb dle30. The timing was way off from the box and originally it ran like crap. I now have the timing advanced to about 30 degrees and it runs much better but it is getting a constant misfire around half throttle. I can't tune it out so I'm guessing it is and ignition or timing problem. I can advance the timing any more though. Anybody have any thoughts on this? I will not call vvrc about this....long story but I am no longer going to be a customer to them..
Well , honestly , by taking Jody from VV out of the equation , you are shooting yourself in the foot. Jody is well know through all the GS pilots on a lot of different forums , and is known as one of THE BEST motor guys in this hobby. And to be honest....there is NO ONE that knows these DLE's better than him.

I don't know what Jody could have possibly done to irritate you , but he is at the top of a very long list as one of the coolest people in this business and has always gone well above and beyond the call of duty to help people!

Also....I would like to add , that there are 1000's of these DLE 20cc-30cc motors out there that are running like a swiss watch. Maybe you have a bad carb or IGN of some type? Has Jody looked at this motor yet since you had your problems with it?
JEFFRO503 is offline Find More Posts by JEFFRO503
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Wanted DLE 30 Ignition mmclaug858 Aircraft - Fuel - Engines and Accessories (FS/W) 1 Apr 22, 2011 05:26 AM
Help! New to gas, ? test DLE 30 ignition? JBAZ4 Engines 12 Apr 21, 2011 06:19 AM
Question Turnigy 26cc verses DLE 30cc - Same Ignition? snoshoe62 Engines 3 Sep 20, 2010 11:48 PM
Found DLE-30 Ignition Module snoshoe62 Aircraft - Fuel - Engines and Accessories (FS/W) 1 Sep 03, 2010 08:30 PM
Sold DLE 30 New in box, with muffler, ignition, everything jongurley Aircraft - Fuel - Engines and Accessories (FS/W) 0 Aug 07, 2010 10:01 PM