HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 19, 2011, 07:22 PM
Registered User
United States, CA, Fresno
Joined Mar 2009
24 Posts
Discussion
OSD Pro Firmware update fail

Just got a new OSD Pro and went to do the firmware update. Downloaded the latest from the website, updated the Eagleeyes and the elogger4. They did good. The OSD Pro not so good...... It says firmware needs updating, update it, and no luck. Multiple attempts, including downloading latest from ETS.
Any help out there?

Mark Taylor
Team JR/Horizon
Mark taylor is offline Find More Posts by Mark taylor
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 19, 2011, 08:10 PM
Registered User
Joined Mar 2011
9 Posts
I had encountered this exact same scenario. It seemed to be a power issue. I found a USB cable with dual connectors on one end, one for power and the other for power + data. This is what eventually worked for me. Below you will find a link to something similar to my cable.

http://www.amazon.com/Cables-Go-2810...583355&sr=8-15
garand is offline Find More Posts by garand
Reply With Quote
Old Mar 20, 2011, 09:49 AM
Registered User
United States, CA, Fresno
Joined Mar 2009
24 Posts
Thanks for the reply! Will powering it with the flight battery do the same thing?
Mark taylor is offline Find More Posts by Mark taylor
Reply With Quote
Old Mar 20, 2011, 10:16 PM
billpa's Avatar
Joined Nov 2003
4,934 Posts
Mark, is it possible that you are not clicking "OK" on the OSD Configuration page that comes up shortly after the firmware update? THis is required to complete the update process.

In a few days, we'll be posting a new software version that delays the "Firmware Update Complete" message until AFTER you've clicked "OK" on the configuration page, which should make this confusion go away.
billpa is offline Find More Posts by billpa
Site Sponsor
Reply With Quote
Old Mar 21, 2011, 08:49 AM
Registered User
United States, CA, Fresno
Joined Mar 2009
24 Posts
Yes, I was doing all the steps by the numbers. I completely started from scratch, erased the program and reloaded it on the laptop. Reconfigured the hardware and did the firmware update, this time successfully!
Don't ask me why, but the elogger and eagleeyes took the update the first time, not the OSD pro. Go fish.........
Thanks for your help!

MT
Mark taylor is offline Find More Posts by Mark taylor
Reply With Quote
Old Mar 21, 2011, 07:36 PM
Registered User
Joined Mar 2011
9 Posts
I don't actually know as I did not have the battery connected to mine while I was configuring the unit.

Quote:
Originally Posted by Mark taylor View Post
Thanks for the reply! Will powering it with the flight battery do the same thing?
garand is offline Find More Posts by garand
Reply With Quote
Old Mar 24, 2011, 12:09 AM
billpa's Avatar
Joined Nov 2003
4,934 Posts
Hi Mark, that is strange. My best hypothesis is that there was an issue with USB. We get reports occasionally of USB incompatibility with some PCs, but they are few and far between, and often intermittent. :S
billpa is offline Find More Posts by billpa
Site Sponsor
Reply With Quote
Old Mar 24, 2011, 06:39 AM
Registered User
Joined Mar 2011
9 Posts
I also use a USB 1.0 cable in a USB 1.0 port. Sometimes external hard drives, etc. will install USB boost software. I would suggest shutting that off as well.
garand is offline Find More Posts by garand
Reply With Quote
Old Mar 24, 2011, 10:33 AM
Registered User
United States, CA, Fresno
Joined Mar 2009
24 Posts
Everything seems to be working as advertised, at least I didn't release the magic smoke!
Mark taylor is offline Find More Posts by Mark taylor
Reply With Quote
Old Oct 16, 2011, 05:50 AM
Registered User
Joined Jan 2009
106 Posts
Hello I just tried to update my recorder after connecting my new guardian.
Result:
eLogger V3 FW is 5,93 but the software prompts me to update to 5,93.
OSD-Pro FW is unknown and Update fails with error. (without any specification)
Guardian also is unknown and also fails.
What can I do now?
Telefisch is offline Find More Posts by Telefisch
Reply With Quote
Old Oct 18, 2011, 06:12 AM
Resistance is Futile
camship's Avatar
United States, FL, Panama City Beach
Joined Oct 2001
2,680 Posts
Quote:
Originally Posted by Telefisch View Post
Hello I just tried to update my recorder after connecting my new guardian.
Result:
eLogger V3 FW is 5,93 but the software prompts me to update to 5,93.
OSD-Pro FW is unknown and Update fails with error. (without any specification)
Guardian also is unknown and also fails.
What can I do now?
Are you providing power to the ET system other than the USB? If not you may need to power up your system and then connect the USB with it powerd on and try to update.

Sometimes it is a current issue with USB ports and just to make matters worse Windows does a really poor job of power management on the USB ports and will turn it off at very inopportune times.

You can manually set the USB ports in the system to NOT ALLOW the computer to turn them off to save power.

Good Luck!

Rob
camship is offline Find More Posts by camship
Reply With Quote
Old Oct 18, 2011, 02:31 PM
Registered User
Joined Jan 2009
106 Posts
Hello, I tried both...
with and without external power.
Somone told me to try the older Softwareversion (10.4).
I'll try asap but I'm on Holyday. So this will last a few days.
So thanks for answer so far...
Telefisch is offline Find More Posts by Telefisch
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question OSD Pro, eLogger V3, GPS V4 problems updating firmware in OSD Pro jbfoamy Eagle Tree Systems 23 Jun 02, 2012 02:59 PM
Alert GoPro Hero HD firmware update released!!! _Sibi_ FPV Talk 106 Feb 15, 2011 08:28 AM
Discussion The GoPro HD firmware update is finally here! jab FPV Talk 2 Oct 02, 2010 06:34 AM
Help! OSD Pro Update Problem S11D336B Eagle Tree Systems 4 Jun 15, 2010 08:08 AM