HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 12, 2011, 10:48 AM
Registered User
Joined Mar 2011
2 Posts
Discussion
servo not working properly

I have an sc 10 and all of sudden my steering servo when started up will go full power to the right. I can not controll it with my controller of nothing. I changed out the servo thinking that my be the problem, but to my dismay that did not solve the problem. This just happen out of the blue as I was playing with it and the next time I started it, it just did it and I have not been able to the correct the problem yet. I was hopeing that maybe you guys with a little more experience could give me some ideas. Thanks in advance.
therepairman is offline Find More Posts by therepairman
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 12, 2011, 02:43 PM
Registered User
Texas
Joined Aug 2006
1,168 Posts
Have you checked the strg trim on your radio and made sure its not turned all the way to one side?
Duster_360 is offline Find More Posts by Duster_360
Reply With Quote
Old Mar 12, 2011, 04:47 PM
Registered User
Joined Mar 2011
2 Posts
Yes I have and that has no effect on it either.
therepairman is offline Find More Posts by therepairman
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question C Creations not working properly Flazo Power Systems 5 Dec 31, 2008 12:06 PM
Help! G3 controller left stick not working properly? Faster_Gun Simulators 0 Mar 02, 2008 01:42 AM
Help! USB Sim Cable & FMS not working properly... dBuster2007 Micro Helis 12 Oct 11, 2007 05:13 AM
Discussion Radio Fell Down!!!! Not Working Properly After That... indian_radio Radios 1 Dec 31, 2006 03:25 AM
TREC ESC question. Not working properly? jasoncy2k Mini Helis 6 Aug 21, 2005 09:46 PM