HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 09, 2011, 06:26 PM
Registered User
Joined May 2005
1,185 Posts
--- edit ---
liteglow is offline Find More Posts by liteglow
Last edited by liteglow; Dec 09, 2011 at 06:39 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 09, 2011, 08:36 PM
Registered User
Gree's Avatar
Sydney, Australia
Joined Jun 2006
2,948 Posts
Quote:
Originally Posted by m_beeson View Post
You're probably right about that.


If I were to try to rectify that issue while using rudder, I would look at the Stabilizer roll gain.

It may be trying to level your flight, and since it can't, then it is working extra hard at it...

If you lower that gain, then it would give it a little wiggle room.

You're treading into new territory, because most people use ailerons with guardian, but I think you can find some good settings through testing and calibration.
Just wanted to say thank you. I turned the guardian stabiliser roll gain to 3 from 5 and now no more oscillations! Works perfectly. Thanks for the good advice.
Gree is online now Find More Posts by Gree
Reply With Quote
Old Dec 09, 2011, 09:24 PM
FPV junkie
m_beeson's Avatar
United States, UT
Joined Jan 2011
3,390 Posts
Glad to hear it, Gree...
m_beeson is offline Find More Posts by m_beeson
Reply With Quote
Old Dec 10, 2011, 01:35 PM
Registered User
Joined Aug 2010
914 Posts
Billpa,
I am not getting the 1A0000 and 1D0000 as much now when I boot my system but it does still occur with firmware 10.12, I have to reboot again until I don't get the errors.

I tested the Guardian in flight yesterday with some recommended settings instead of the default settings. It was a big failure but no crashes. Since I wasn't using default settings, I won't bother with that issue but the plane was messed up as far as RTH was concerned.

The reason for this post is I was able to get a 1D0000 error "at will" by simply going to the Flight Sim mode. As soon as I activated the Flight Sim mode, I'd immediately get a "1D0000 error, Email Support" The error would appear 100% of the time I selected Sim mode. The big issue to add to this is that there was NO ELEVATOR inputs from the OSD in RTH in the Sim mode only, I reviewed my inflight video and there appeared to be some elevator inputs from the OSD while I was flying "live" RTH.

I used to have the FY-20 instead of the Guardian and had many successful flights with RTH working perfectly. I mention that because I know what RTH is suppose to do.
thekubiaks is offline Find More Posts by thekubiaks
Last edited by thekubiaks; Dec 10, 2011 at 05:37 PM.
Reply With Quote
Old Dec 11, 2011, 03:47 PM
Registered User
ashdec87's Avatar
United States, MI, Detroit
Joined Feb 2004
9,090 Posts
here's a video of the problem i"m having. Watch the AHI during and after turns.

SW12811 (1 min 56 sec)
ashdec87 is offline Find More Posts by ashdec87
Reply With Quote
Old Dec 11, 2011, 05:09 PM
Registered User
imagebuff's Avatar
United States, TX, Tomball
Joined Jan 2011
700 Posts
I have two motors which are throttle balanced by TX programming. Each motor is on a seperate channel. Is there any way to use this with the Guardian?
imagebuff is online now Find More Posts by imagebuff
Reply With Quote
Old Dec 11, 2011, 05:32 PM
Registered User
Shakopee, MN
Joined Aug 2004
153 Posts
Hi,

I am looking for suggestions on a odd behavior with RTH.

I have everything setup with the guardian, RTH and stabilzation works great at low wind <10mph. A couple of recent instances though have me a little confused. If I am attempting a RTH thru a cross wind >10 mph, the RTH turns into the wind and then gets blown by the wind forcing the plane to circle. It tries to head home again but the wind blows the plane into another circle. The end result is the plane keeps going farther away from me at a 45% angle from where RTH was initiated as the wind blows it farther and farther downwind.

Any ideas?
Dan777 is online now Find More Posts by Dan777
Reply With Quote
Old Dec 11, 2011, 09:24 PM
But often down to earth
Floater73's Avatar
Oklahoma, USA
Joined Sep 2010
736 Posts
Quote:
Originally Posted by ashdec87 View Post
here's a video of the problem i"m having. Watch the AHI during and after turns.

http://www.youtube.com/watch?v=hbG0Jo319Mk
What's the problem you're seeing? It looks pretty good to me.

Steve
Floater73 is offline Find More Posts by Floater73
Reply With Quote
Old Dec 11, 2011, 09:50 PM
But often down to earth
Floater73's Avatar
Oklahoma, USA
Joined Sep 2010
736 Posts
Quote:
Originally Posted by Dan777 View Post
Hi,

I am looking for suggestions on a odd behavior with RTH.

I have everything setup with the guardian, RTH and stabilzation works great at low wind <10mph. A couple of recent instances though have me a little confused. If I am attempting a RTH thru a cross wind >10 mph, the RTH turns into the wind and then gets blown by the wind forcing the plane to circle. It tries to head home again but the wind blows the plane into another circle. The end result is the plane keeps going farther away from me at a 45% angle from where RTH was initiated as the wind blows it farther and farther downwind.

Any ideas?
I've had the same problem in high wind. I fly a Radian with a cruise speed about 17 and a climb speed of about 12. If downwind the wind can easily exceed the cruise or climb speed causing the plane to actually be moving backwards in reference to the ground. In this case RTH can't get the plane home. The GPS tells the autopilot the plane is going away from home and RTH turns the plane to try and get home. The Eagletree system doesn't have a compass so it doesn't know the direction the plane is pointing. It only knows the direction the plane is traveling.

When the wind is high I stay upwind when out very far in case I need RTH.

Steve
Floater73 is offline Find More Posts by Floater73
Reply With Quote
Old Dec 11, 2011, 11:30 PM
Flying Monkey
Mr_B's Avatar
Australia, NSW, Sydney
Joined Nov 2009
737 Posts
I've been really happy with my Guardian. Here's why...


An Auto Pilot Landing (3 min 43 sec)


When the magpie came at me I accidently pulled the power from the Vid Goggles... Just luck with the wind gusts round the trees I guess.

8)
//
Mr_B is offline Find More Posts by Mr_B
Reply With Quote
Old Dec 12, 2011, 12:07 AM
Registered User
Alcyon13's Avatar
France
Joined May 2010
537 Posts
Quote:
Originally Posted by Dan777 View Post
Hi,

I am looking for suggestions on a odd behavior with RTH.

I have everything setup with the guardian, RTH and stabilzation works great at low wind <10mph. A couple of recent instances though have me a little confused. If I am attempting a RTH thru a cross wind >10 mph, the RTH turns into the wind and then gets blown by the wind forcing the plane to circle. It tries to head home again but the wind blows the plane into another circle. The end result is the plane keeps going farther away from me at a 45% angle from where RTH was initiated as the wind blows it farther and farther downwind.

Any ideas?
I've solved this issue by increasing the minimum cruise speed setting.
The downside is large turn because the speed is higher. But it works, it help a lot the plane to keep a reasonable route when the wind is high.
Alcyon13 is offline Find More Posts by Alcyon13
Reply With Quote
Old Dec 12, 2011, 12:16 AM
FPV junkie
m_beeson's Avatar
United States, UT
Joined Jan 2011
3,390 Posts
Quote:
Originally Posted by Alcyon13 View Post
I've solved this issue by increasing the minimum cruise speed setting.
The downside is large turn because the speed is higher. But it works, it help a lot the plane to keep a reasonable route when the wind is high.
That's good to know,

Thanks for posting.
m_beeson is offline Find More Posts by m_beeson
Reply With Quote
Old Dec 12, 2011, 08:03 AM
Registered User
Shakopee, MN
Joined Aug 2004
153 Posts
Quote:
Originally Posted by Alcyon13 View Post
I've solved this issue by increasing the minimum cruise speed setting.
The downside is large turn because the speed is higher. But it works, it help a lot the plane to keep a reasonable route when the wind is high.
Thanks for the tip! I will give that a shot
Dan777 is online now Find More Posts by Dan777
Reply With Quote
Old Dec 12, 2011, 08:11 AM
2R Fly Team
smoln1's Avatar
Slovenija, Radovljica, Radovljica
Joined Jul 2009
212 Posts
Quote:
Originally Posted by Alcyon13 View Post
I've solved this issue by increasing the minimum cruise speed setting.
The downside is large turn because the speed is higher. But it works, it help a lot the plane to keep a reasonable route when the wind is high.
Thanks, good to know!!

Cheers
smoln1 is offline Find More Posts by smoln1
Reply With Quote
Old Dec 12, 2011, 08:33 AM
Registered User
GregSilver's Avatar
United States, FL, Plantation
Joined Nov 2005
655 Posts
Quote:
Originally Posted by ashdec87 View Post
here's a video of the problem i"m having. Watch the AHI during and after turns.

http://www.youtube.com/watch?v=hbG0Jo319Mk
Quote:
Originally Posted by Floater73 View Post
What's the problem you're seeing? It looks pretty good to me.

Steve
Ash, that does look like a problem.

When banking, the AI starts to creep up, as if your attitude was pointing down. You can see by the altitude deviations that the plane is in fact not but a few degrees nose up/down throughout the entire turn, while the Guardian drifts.

Assuming that your Guardian is mounted SECURE and can not move, this is a problem that would effect flight. If flying at low speed/altitude, this could cause a catastrophic stall coming out of a bank, or even worse during RTH flight.
GregSilver is offline Find More Posts by GregSilver
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Eagle Tree OSD PRO Return to Home Config (Post your setup here). felipesalomao FPV Equipment 157 Sep 18, 2014 10:06 PM
Mini-HowTo Please post your OSD Pro wiring diagrams here! billpa Eagle Tree Systems 297 May 26, 2014 01:56 PM
Question OSD Pro, eLogger V3, GPS V4 problems updating firmware in OSD Pro jbfoamy Eagle Tree Systems 23 Jun 02, 2012 02:59 PM
Discussion 9CH 2,4 Ghz transsmiter and receiver $54.99 tom112233 Hot Online Deals 7 Oct 01, 2010 05:52 PM
Discussion FMP04 GPS module W/ Eagletree OSD Pro vertcnc FPV Talk 2 Aug 08, 2010 07:26 AM