HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 28, 2011, 07:51 PM
F18
Registered User
United States, MA, Onset
Joined Apr 2008
233 Posts
Quote:
Originally Posted by ChuckTseeker View Post
was doing a bit more reading and searching and found out that right here in good ol Australia we built over 200 of the Mosquito's and i found this old Aussie news reel vid on the tube, it shows it being built and it has some good flying at the end too

cheers chuck

http://www.youtube.com/watch?v=c7cVvYdLeek
Chuck! Outstanding news reel clip! The mosquito flying right over my head looks just like some of the clips of the real thing flying overhead! I do like this plane!
F18 is offline Find More Posts by F18
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 28, 2011, 07:58 PM
Registered User
Joined Sep 2010
4,036 Posts
Quote:
Originally Posted by mitsudriver274 View Post
Thats interesting mine def won't loop from level flight, it also came with both the aileron servos plugged into there own ports
You should be contacting Horizon. What hole do your have the elevator pushrod in? Except don't know why that should be a problem, mine would loop with it in the furthest out hole like it came out of the box.
bobly is offline Find More Posts by bobly
Reply With Quote
Old Mar 28, 2011, 08:04 PM
Registered User
Joined Sep 2010
4,036 Posts
Quote:
Originally Posted by BigD1961 View Post
I am sure someone has posted it, but I am too short on time to look throgh all the threads to find it. So what does everyone recommend on expo? I programmed it into my DX6I and put in 80% on everything, but it's too windy to fly today so I can't try it out yet.
Any suggestions?
I already have the leading edges taped up and I applied a few details with a sharpie to "sharpen" it up a bit. I may paint it up a matt black to make it into a night fighter like someone else did.
SEFF awaits and I need to maiden her before then, so lets hear it guys and gals.
I'm far far from an expert, being pretty new to all this, but 80% sounds like a ton of expo. When I was first learning I sometimes put in 35%, but more recently, I don't use that much. It is a highly personal choice though. No matter how much expo you put in, if you have rates on 100% you still have all the travel. I just find that the travel sneaks up on me if I have expo set high.
bobly is offline Find More Posts by bobly
Reply With Quote
Old Mar 28, 2011, 08:09 PM
Team OFG (Old Fat Guys)
BigD1961's Avatar
United States, KY, Leitchfield
Joined Jul 2008
445 Posts
Expo

Quote:
Originally Posted by bobly View Post
I'm far far from an expert, being pretty new to all this, but 80% sounds like a ton of expo. When I was first learning I sometimes put in 35%, but more recently, I don't use that much. It is a highly personal choice though. No matter how much expo you put in, if you have rates on 100% you still have all the travel. I just find that the travel sneaks up on me if I have expo set high.
I am really new to setting up the planes on the radio, but when I went to the control list the stock setting for expo was 100% and I assumed I was dialing it down to 80%. I am guessing I did it wrong and I will check out my manual to make sure I did it right.
Thanks for bringing it up and making me look twice, I appreciate it.
BigD1961 is offline Find More Posts by BigD1961
RCG Plus Member
Latest blog entry: More SEFF pics.
Reply With Quote
Old Mar 28, 2011, 08:26 PM
Way to many airplanes!
Canada, QC
Joined Oct 2009
5,489 Posts
Without checking the manual myself, I simply think you're mixing "Dual Rates" and "Expo"

Dual rates will be 100% for full control, but can be tamed down to 70% (plus or minus 20%). It's how much travel the control surface will have. Pro want full travel, so 100%

Expo is usually the other way around. You start with 0% and you go up from there. This is a personal choice. Some people don't want any expo (0%) and other will want as much as 40% (plus or minus 20%) to tame a plane down, or to make it softer when the sticks are in the middle.
RealGambler is online now Find More Posts by RealGambler
Reply With Quote
Old Mar 28, 2011, 08:33 PM
-=BS=-
BlazingStar's Avatar
Thousand Oaks, CA
Joined Jul 2009
1,210 Posts
Well, I've had a dozen good flights on my pretty mossie.
I just said "uh-oh flight #13 coming up" (not really being supersticious)
and the starboard prop wouldn't turn on take-off

Now that motor always "looked" slower than the other one. But now it won't go at all unless I give it a start with my finger. "contact".... and there she goes. Throttle back to off and up angain and it won't go anymore. So no flight #13 for me. That averages to $10 a flight for this plane - not a good return on the dollar!

I thought maybe it's a gear mesh issue. opened it up and had a good look. all gears mesh. Nothing is rubbing. A little oil for lubrication did not help. spininng it slowly with my finger I can feel and hear a grinding from the motor.

Ah, crap!
Will call Horizon tomorrow and see what happens. Even if I get a replacement motor, my pretty plane will need open heart surgery to fix
BlazingStar is offline Find More Posts by BlazingStar
Reply With Quote
Old Mar 28, 2011, 08:42 PM
Registered User
Bakersfield, California
Joined Jan 2007
253 Posts
Quote:
Originally Posted by mitsudriver274 View Post
Thats interesting mine def won't loop from level flight, it also came with both the aileron servos plugged into there own ports
A bit strange it wont loop from level...are you flying it low or high rates? The ailerons are just as you said, each has it's own port. There is no 'Y' connector

Here is the manual see page 4 for Ch description:
http://www.parkzone.com/ProdInfo/Fil...-Manual_EN.pdf
maxwellmark is offline Find More Posts by maxwellmark
Reply With Quote
Old Mar 28, 2011, 09:33 PM
Heli and E-Plane
United States, FL, Ocala
Joined Nov 2010
939 Posts
Quote:
Originally Posted by BigD1961 View Post
I am sure someone has posted it, but I am too short on time to look throgh all the threads to find it. So what does everyone recommend on expo? I programmed it into my DX6I and put in 80% on everything, but it's too windy to fly today so I can't try it out yet.
Any suggestions?
I already have the leading edges taped up and I applied a few details with a sharpie to "sharpen" it up a bit. I may paint it up a matt black to make it into a night fighter like someone else did.
SEFF awaits and I need to maiden her before then, so lets hear it guys and gals.
Whenever I get a new plane I usually set the D/R to 90% and expo to 25% until I get a feel for her flight characteristics and take it from there...YMMV
jer291113 is offline Find More Posts by jer291113
Reply With Quote
Old Mar 28, 2011, 09:49 PM
Registered User
Joined Sep 2010
4,036 Posts
Quote:
Originally Posted by BlazingStar View Post
Well, I've had a dozen good flights on my pretty mossie.
I just said "uh-oh flight #13 coming up" (not really being supersticious)
and the starboard prop wouldn't turn on take-off

Now that motor always "looked" slower than the other one. But now it won't go at all unless I give it a start with my finger. "contact".... and there she goes. Throttle back to off and up angain and it won't go anymore. So no flight #13 for me. That averages to $10 a flight for this plane - not a good return on the dollar!

Definitely not $10 a flight. Even if you have to pay for a motor, they are like $11 or so. They should go more than that, but the next one should go 500 flights or more. I've got a whole bunch of ultra micros with these motors and have only had one quit working. The plane certainly isn't ready for the trash bin.
bobly is offline Find More Posts by bobly
Reply With Quote
Old Mar 28, 2011, 11:03 PM
Crazy Canuck
NEWBEFLYER's Avatar
United States, VA, Woodbridge
Joined Apr 2007
2,244 Posts
I've flown mine both indoors and out and find the mosquito a nice plane BUT today I was outside flying and doing some nice rolls and loops then out of no where the plane wasn't responding to elevator control. It ended up smacking into the side of a building at almost full throttle. Damaged wing tip, starboard body motor damaged and tail broken off at the base. I slowly walked home almost in tears wondering what happened and sat for a bit and then glued all the broken parts back she looks alittle worn but still nice. Then I tested out the controls and found out no elevator movement. I opened it up and noticed the servo wasn't moving and seemed to be stuck. I tried working it out didn't help so I'm taking it back to the hobby store I deal with and find out what is wrong. This could be why my plane ended up in the side of the building. Anyone else have any issues with the elevators???
NEWBEFLYER is offline Find More Posts by NEWBEFLYER
Reply With Quote
Old Mar 28, 2011, 11:21 PM
Registered User
Bakersfield, California
Joined Jan 2007
253 Posts
Quote:
Originally Posted by NEWBEFLYER View Post
<edit> Anyone else have any issues with the elevators???
It's not just the elevators. Any control surface can experience issues. These little servos (in all UM's) are not as reliable as one would hope. They are good, but....not great. HH has been great in standing behind the servo (for me it was an aileron) but the damage is.....well on me.

That's the price we pay for RD
maxwellmark is offline Find More Posts by maxwellmark
Reply With Quote
Old Mar 28, 2011, 11:50 PM
Crazy Canuck
NEWBEFLYER's Avatar
United States, VA, Woodbridge
Joined Apr 2007
2,244 Posts
Well I just find it odd that the brick servos have any problems. I have the Sukhoi,T-28,Mustang,4-Site and have no elevator servo problems at all. I know the brick in the Mostquito is the same servos as the other are and all they id was add on two ESC on it so there should be any problems. Maybe just a bad servo got through or something. The PZ bricks have been well made as far as I'm concerned but this Mosquito seems to be having little problems all around. I sent back my first one because of the aileron just like you did (mine was the Starboard when it went about 3/4 down it would flutter spasticly) the shop just gave me another plane. I had another person having one motor runnig slower than the other and they too replaced it with a new plane. (good hobby shop we have here).But now this with the elevatorafter only three good flights and no aciedents. MMMMMM
NEWBEFLYER is offline Find More Posts by NEWBEFLYER
Reply With Quote
Old Mar 29, 2011, 01:15 AM
Flying addicted and lovin it!
Fish99's Avatar
Canada, AB, Edmonton
Joined Jun 2010
2,736 Posts
Quote:
Originally Posted by NEWBEFLYER View Post
Well I just find it odd that the brick servos have any problems. I have the Sukhoi,T-28,Mustang,4-Site and have no elevator servo problems at all. I know the brick in the Mostquito is the same servos as the other are and all they id was add on two ESC on it so there should be any problems. Maybe just a bad servo got through or something. The PZ bricks have been well made as far as I'm concerned but this Mosquito seems to be having little problems all around. I sent back my first one because of the aileron just like you did (mine was the Starboard when it went about 3/4 down it would flutter spasticly) the shop just gave me another plane. I had another person having one motor runnig slower than the other and they too replaced it with a new plane. (good hobby shop we have here).But now this with the elevatorafter only three good flights and no aciedents. MMMMMM
Just bought this plane AND the Blade mCP X heli in the past couple weeks (bonus for me, wife was feeling VERY generous! ) and while I have had NO issues with the mossie, I actually had 2 of the 3 long throw servos go on my mCPX within 4 flights out of the box! One had a fine gear issue, the other just decided to suddenly go FULL UP and stick there when ever you put power into the heli! Lucky for me it did it on a power up, not in the middle of a flight, so no damage from any crashes. Called HH and they were great, sent me 2 new servos no questions asked, no charge, shipped to Canada. Makes you think though that there must be a certain percentage of these servos with the motor and gear on a chip that are faulty.

GL with the new one. Seems like if they make it though 5 or 6 flights they are good to go for a while, from what I have been reading on the various threads, but that is just a guess.

Marlin
Fish99 is offline Find More Posts by Fish99
Reply With Quote
Old Mar 29, 2011, 03:19 PM
-=BS=-
BlazingStar's Avatar
Thousand Oaks, CA
Joined Jul 2009
1,210 Posts
Quote:
Originally Posted by bobly View Post
Definitely not $10 a flight. ..The plane certainly isn't ready for the trash bin.
I agree, the math was referring to cost of original BNF to number of flights so far... $10 a flight.

Called HH today and have a replacement motor on it's way. Just too bad I have to cut the plane open already....
BlazingStar is offline Find More Posts by BlazingStar
Reply With Quote
Old Mar 29, 2011, 04:53 PM
Super Man's cousin! No cape!
Ultra_Spitfire's Avatar
Australia, New South Wales, Wangi Wangi
Joined Sep 2010
479 Posts
So, I decided I would make a new nose. Who wants to see the finished product?
Ultra_Spitfire is offline Find More Posts by Ultra_Spitfire
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product New Hobby-Lobby micro P-51 and Spirfire! - direct competitor to Parkzone Ultra Micro? Smokescreen38 Micro Ready-to-Fly 316 Aug 23, 2012 12:51 AM
Discussion Parkzone New Ultra Micro Mosquito Mk VI ChuckTseeker Scratchbuilt Indoor and Micro Models 4 Feb 03, 2011 02:22 AM
For Sale parkzone ultra micro J-3 cub BNF trade for micro trojan ED3 Aircraft - Electric - Micro & Indoor Airplanes (FS/W) 3 Nov 06, 2010 03:19 AM
Sold Moved to micro section -Parkzone Sukhoi SU-26m Ultra Micro BNF - w/ Lots of new parts major.monogram Aircraft - Electric - Airplanes (FS/W) 2 Jun 08, 2010 01:00 AM
Found Parkzone Ultra Micro P-51D BNF (New or like new condition) CGReload Aircraft - Electric - Micro & Indoor Airplanes (FS/W) 1 Oct 09, 2009 02:28 PM