HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 03, 2012, 08:53 PM
Registered User
Fuego's Avatar
USA, TN, Union City
Joined Mar 2006
364 Posts
Congratulations Black_heart, you should be able to get more flight time too without the flybar.
Fuego is offline Find More Posts by Fuego
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 03, 2012, 11:27 PM
Registered User
Joined Feb 2012
115 Posts
awesome and um wheres the vid?
nitrosportman is offline Find More Posts by nitrosportman
Reply With Quote
Old Mar 04, 2012, 12:42 PM
Registered User
Fuego's Avatar
USA, TN, Union City
Joined Mar 2006
364 Posts
I don't know where to start with the thread lock. Some of the screws are phillips head and are so tight they won't budge. I wish all of them could have been allen head screws. At any rate, I'm just going to have to keep a close eye on it for a while.
Fuego is offline Find More Posts by Fuego
Reply With Quote
Old Mar 04, 2012, 03:33 PM
Registered User
Fuego's Avatar
USA, TN, Union City
Joined Mar 2006
364 Posts
I haven't made any changes to the radio settings except for the trim on the right stick. I have it all the way to the left and there the swash plate looks almost level but I still have to give just a bit of left pressure on the right stick to keep it from drifting to the right in a hover.

Do I need to lengthen the right (longer) servo to swash link and shorten the left (shorter) link a couple of turns so that I can center the aileron trim?
Fuego is offline Find More Posts by Fuego
Reply With Quote
Old Mar 04, 2012, 03:47 PM
Texas NewB
Black_heart's Avatar
United States, MD, Princess Anne
Joined Dec 2011
915 Posts
First off did you not level the swash plate when you where setting up?
you want the swash to be as level as you can get it before you add any trim.
Is the wind going to right?
Black_heart is online now Find More Posts by Black_heart
Reply With Quote
Old Mar 04, 2012, 03:49 PM
Registered User
Fuego's Avatar
USA, TN, Union City
Joined Mar 2006
364 Posts
I didn't level it. There's no wind were I'm at. I thought since it had already been pretested that all that was done but I guess not.
Fuego is offline Find More Posts by Fuego
Last edited by Fuego; Mar 04, 2012 at 03:57 PM.
Reply With Quote
Old Mar 04, 2012, 03:59 PM
Texas NewB
Black_heart's Avatar
United States, MD, Princess Anne
Joined Dec 2011
915 Posts
Try leveling it before your next flight this well help in trimming it out.
Sounds like its almost there.
Black_heart is online now Find More Posts by Black_heart
Reply With Quote
Old Mar 04, 2012, 04:03 PM
Registered User
Fuego's Avatar
USA, TN, Union City
Joined Mar 2006
364 Posts
I hate to sound like a rookie, is my suggestion above correct?
Fuego is offline Find More Posts by Fuego
Reply With Quote
Old Mar 04, 2012, 04:10 PM
Texas NewB
Black_heart's Avatar
United States, MD, Princess Anne
Joined Dec 2011
915 Posts
Yes It is kinda you want to see which of the 2 front rods is level with the back and bring the other one up/down to match.
Black_heart is online now Find More Posts by Black_heart
Reply With Quote
Old Mar 04, 2012, 04:17 PM
Registered User
Fuego's Avatar
USA, TN, Union City
Joined Mar 2006
364 Posts
Ok, thanks. I didn't thing about it being level with the back. I was just focusing on the front.
Fuego is offline Find More Posts by Fuego
Reply With Quote
Old Mar 04, 2012, 04:23 PM
Registered User
Fuego's Avatar
USA, TN, Union City
Joined Mar 2006
364 Posts
It looks like that will make both side level with the back. I think I'll give that a try.
Fuego is offline Find More Posts by Fuego
Reply With Quote
Old Mar 05, 2012, 09:40 PM
Registered User
Fuego's Avatar
USA, TN, Union City
Joined Mar 2006
364 Posts
Well, I hovered the heli just off the ground a few times yesterday in normal mode to check for problems after each flight and everything went great so today I hovered a couple of times in normal mode before switching to idle up for about a minute, set it down, and again, checked for mechanical problems.

After recharging the battery, I took it out this afternoon, spun it up to mid stick and switched to idle up again. Wasn't doing anything fancy, just a few feet up in a solid hover when after about a minute it just dropped so rapidly that I was unable to flip the throttle hold switch before it hit the ground. This happened in about a half a second. The damage appears minimal. The canopy is slightly cracked, the tail boom has a couple of dents, bent flybar and of course damaged blades.

Still, there are no apparent mechanical problems, no missing or loose screws, tail rotor and gyro seem fine, cyclic and pitch appear to be functioning properly (sitting on the kitchen table) but now it won't spin up and I don't know if I have a problem with the motor or esc or both.

Originally, I had reserves about using the stock radio and at first, I thought that the blades had suddenly changed to negative pitch for no reason at all due to the chopping sound they made the moment this happened but now I'm wondering if it lost power because of an electrical problem. Would that have caused the heli to drop so fast? Is this a radio or motor/esc problem? Either way, I would have been happier if I had made an error causing the crash because now I don't trust this helicopter.
Fuego is offline Find More Posts by Fuego
Reply With Quote
Old Mar 05, 2012, 10:26 PM
Texas NewB
Black_heart's Avatar
United States, MD, Princess Anne
Joined Dec 2011
915 Posts
do You stell have full function other then motor? (all servos move)
Not heard about one going full down like that at all and I am stell using the stock motor and ESC (mine is the 3500 version) and I've had way more then My share of earth contacts :S
I sold my stock radio and receiver after about 20 flights because because I had gotten a good deal on my DX6i. Only problem I had with it was to hard to move only one channel with out the other one being effected. (move the aileron and elevator moved Just a little)
Black_heart is online now Find More Posts by Black_heart
Reply With Quote
Old Mar 05, 2012, 10:35 PM
Registered User
Fuego's Avatar
USA, TN, Union City
Joined Mar 2006
364 Posts
Yeah, the servos all seem to be working correctly. I don't understand it. I wasn't expecting something to go wrong so suddenly. It failed after only a few flights.
Fuego is offline Find More Posts by Fuego
Last edited by Fuego; Mar 05, 2012 at 10:41 PM.
Reply With Quote
Old Mar 06, 2012, 07:35 AM
Registered User
Fuego's Avatar
USA, TN, Union City
Joined Mar 2006
364 Posts
I've been going back over this and now I believe the problem was mechanical. I think one of the rotor blades may have failed and the fiberglass ply began to separate. I kept thinking how it sounded like there was a sudden change in pitch because of that sudden chopping or perhaps I should say fluttering sound. That was probably due to the blades ply opening up. After unplugging it, one of the first things I did was to pull grass out from between the ply on one blade but I thought little of it at the time because in my mind I figured the crash caused it. Even after all this, these blades don't even look as though they're broken because they just flexed back in place. If any of you are using the fiberglass blades you should probably inspect them closely and make sure the plies aren't separating or you could end up with more problems. Like me.
Fuego is offline Find More Posts by Fuego
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-Review Cermark Hausler 450 SE V2 koppterX 3D Electric Heli Flying 395 Sep 06, 2014 02:27 PM
Sold hausler 450 rtf heli new in box dennishobbies Aircraft - Electric - Helis (FS/W) 22 Jun 02, 2012 03:12 PM
New Product hausler 450 rtf heli dennishobbies Hot Online Deals 8 Jan 30, 2011 07:48 PM
Sold FS: RTF Align Trex 450 V2, DX7 OCFly Aircraft - Electric - Helis (FS/W) 2 Jan 10, 2011 11:24 AM
Off Site Align T-Rex 450 SE V2 Complete RTF RC Helicopter Tom Z Aircraft - Electric - Helis (FS/W) 1 Sep 25, 2010 08:07 PM