HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 05, 2011, 08:18 AM
Registered User
Joined Apr 2008
11 Posts
Here is what the new version Thunderbird 9 is acting like!

VID 00000-20101227-1700.3GP (0 min 34 sec)
steinywi is offline Find More Posts by steinywi
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 05, 2011, 08:34 AM
Fly lower!
aerolite's Avatar
West Texas
Joined Jan 2005
2,391 Posts
Quote:
Originally Posted by TopDave View Post
aerolite, running a gws 8x4.3 prop. What are you thinking the prop size would effect? I'm just a noob to all of this stuff, so I'm just curious to learn what you guys have experienced. Thanks guys, Dave
TopDave, like RayPB mentions in the post above, if a motor is "over propped", i.e. using too large a prop, then the motor has a difficult time starting. If you had said you were using a 10 x 4.7, or 11 x 4.7, then we would have suggested using a smaller prop. Your prop selection great for this motor.

Cogging could possibly be caused by a bad solder joint, or possibly something going on with the ESC, and timing. Usually I would assume it's not a timing issue.

aerolite
aerolite is offline Find More Posts by aerolite
Reply With Quote
Old Jan 05, 2011, 08:37 AM
Fly lower!
aerolite's Avatar
West Texas
Joined Jan 2005
2,391 Posts
Quote:
Originally Posted by steinywi View Post
Yes I have an older T-9 with version 1.02 software and it works great, but the new T-9 with version 3.0 does not let the motor start. I have sent my new controller back to have them look at it! I have also tried another motor and had the same problem!
That's something I forgot about, the software version. I use the CC phoenix 10's on everything, and when I try to use the newer software, I had startup problems. I have since loaded everything with the oldest software, (I can check which one if anyone is interested), and all startup problems were fixed.

just a thought

aerolite
aerolite is offline Find More Posts by aerolite
Reply With Quote
Old Jan 05, 2011, 09:08 AM
MY '75 CZ "FALTA REPLICA" 2010
TopDave's Avatar
Waterford, Michigan
Joined May 2006
1,253 Posts
Quote:
Originally Posted by steinywi View Post
Here is what the new version Thunderbird 9 is acting like!

http://www.youtube.com/watch?v=DxgqKEOrviE
Stieny, YES, exactly like mine!!! I talked to Castle rep yesterday, and he said the T9 speedo was having trouble starting some of the more agressivly timed 3d motors out there,so they are aware of the problem. He said to check all the solder joints (good) and try a different esc with that motor and if the motor runs with a different esc, then call him back and they will "do something" to solve the problem. (probably a pheonix 10, lol)
TopDave is offline Find More Posts by TopDave
Reply With Quote
Old Jan 05, 2011, 06:19 PM
200 mph club
r/cmark's Avatar
United States, AZ, Fort Mohave
Joined Mar 2005
869 Posts
Quote:
Originally Posted by TopDave View Post
Anyone care to post pic of their radio/battery placement? i would really appreciate it! thanks, Dave
The battery still needs to go back a little.
r/cmark is online now Find More Posts by r/cmark
RCG Plus Member
Latest blog entry: FrSky Taranis misc stuff
Reply With Quote
Old Jan 06, 2011, 08:01 AM
Registered User
Joined Apr 2008
11 Posts
Well I had a chance to fly it for the first time last night and what a treat! Others were very impressed with the fact that I could build a plane that flies so well. That just tells you how well this kit is designed! Very happy with the combo kit from Fancy Foam, it will see a lot of flying this indoor season!
Thanks Andrew!
steinywi is offline Find More Posts by steinywi
Reply With Quote
Old Jan 07, 2011, 10:51 AM
MY '75 CZ "FALTA REPLICA" 2010
TopDave's Avatar
Waterford, Michigan
Joined May 2006
1,253 Posts
Quote:
Originally Posted by Andrew Jesky View Post
Mark,

Glad to see you got your Osiris V2 going. I had a lot of fun designing the V2. I basically wanted at change a few things from the V1 and these were the only things that I could think of. The new plane should come out a bit lighter than the original and should fly the same except, should fly with the tail higher, and stall turn much better.

Andrew
Hi Andrew,
What a nice flying plane! Some of the other guys have sent us pictures of their V2 set ups and battery placements (C of G) and I was wondering if you could show us your set up for competition. That would be much appreciated by us guys just getting started in FP3 and 3D with this plane.
Thanks so much, Dave
TopDave is offline Find More Posts by TopDave
Last edited by TopDave; Jan 07, 2011 at 11:07 AM.
Reply With Quote
Old Jan 07, 2011, 09:14 PM
200 mph club
r/cmark's Avatar
United States, AZ, Fort Mohave
Joined Mar 2005
869 Posts
Started on Osiris V2 kit number 2. I framed it up and weighted it, no pushrods, servos, etc. just wanted to see the 'empty' weight.



Right at about 2oz.
r/cmark is online now Find More Posts by r/cmark
RCG Plus Member
Latest blog entry: FrSky Taranis misc stuff
Reply With Quote
Old Jan 08, 2011, 07:46 PM
Registered User
Joined Apr 2004
8 Posts
At least 3 of us have this problem.

Quote:
Originally Posted by TopDave View Post
Stieny, YES, exactly like mine!!! I talked to Castle rep yesterday, and he said the T9 speedo was having trouble starting some of the more agressivly timed 3d motors out there,so they are aware of the problem. He said to check all the solder joints (good) and try a different esc with that motor and if the motor runs with a different esc, then call him back and they will "do something" to solve the problem. (probably a pheonix 10, lol)
Thanks for sharing this problem with the group. I'm having exactly the problem! Did you guys buy the O2 kit with Hacker motor and TB9 speed controller?
Thanks,
Don
dvetter is offline Find More Posts by dvetter
Reply With Quote
Old Jan 08, 2011, 11:36 PM
Registered User
Joined Apr 2008
11 Posts
Yep v2 kit! Another guy I know is having the same problem in our club. I have sent back my Thunderbird-9 and invited CC to look at this thread. I also posted in their support thread. Everybody I talk to thinks its a timing issue. I installed a older T-9 with software version 1.02 and all works well. Hope CC can help us all out.
steinywi is offline Find More Posts by steinywi
Reply With Quote
Old Jan 09, 2011, 09:03 AM
MY '75 CZ "FALTA REPLICA" 2010
TopDave's Avatar
Waterford, Michigan
Joined May 2006
1,253 Posts
Quote:
Originally Posted by steinywi View Post
Yep v2 kit! Another guy I know is having the same problem in our club. I have sent back my Thunderbird-9 and invited CC to look at this thread. I also posted in their support thread. Everybody I talk to thinks its a timing issue. I installed a older T-9 with software version 1.02 and all works well. Hope CC can help us all out.
I installed Phoenix 10 in mine and had the same no start with the Hacker A10-15s motor as we have with the T-9 esc. I upgraded to the newest software with no improvement, THEN I went back to the original software version 1.55 and she runs fine. Hacker A10 or Phoenix? ....I'm going flying!! Thanks All for the help, Dave
TopDave is offline Find More Posts by TopDave
Reply With Quote
Old Jan 09, 2011, 10:26 PM
200 mph club
r/cmark's Avatar
United States, AZ, Fort Mohave
Joined Mar 2005
869 Posts
I have had several requests for a tutorial on how I make pushrods. I made this crude 'how to' pushrod video. It's a bad video but will probally get the 'how to' point across. Enjoy the CNBC audio commentary in the background.

I am going to make a 'better' version, stay tuned!

Osiris pushrods (11 min 56 sec)
r/cmark is online now Find More Posts by r/cmark
RCG Plus Member
Latest blog entry: FrSky Taranis misc stuff
Reply With Quote
Old Jan 11, 2011, 10:38 PM
200 mph club
r/cmark's Avatar
United States, AZ, Fort Mohave
Joined Mar 2005
869 Posts
Finished Osiris V2 kit number 2. It came out about the same weight as number 1 with at 320 pack. I think you could make one with a 250 mAh pack that weight less than 4 oz.
-
r/cmark is online now Find More Posts by r/cmark
RCG Plus Member
Latest blog entry: FrSky Taranis misc stuff
Reply With Quote
Old Jan 12, 2011, 06:55 AM
Registered User
Joined Apr 2008
11 Posts
Mine came in at 4oz without a battery.
Steiny
steinywi is offline Find More Posts by steinywi
Reply With Quote
Old Jan 13, 2011, 05:43 PM
200 mph club
r/cmark's Avatar
United States, AZ, Fort Mohave
Joined Mar 2005
869 Posts
I striped all three packs. When flying I can not tell the differance between the Rhinos and the Hyperinons. When I use the Thunderpowers you can tell they have more power. If you get used to flying the Thunderpowers it is hard to go back to the Rhinos or the Hyperinons. In flying the F3P-AP pattern the Rhinos and the Hyperinons have enough power. If you are flying a 'advanced' pattern like Andrew I think you would like the TP's. The TP's are 4 times the price of the Rhinos and they weigh 3 grams more.
r/cmark is online now Find More Posts by r/cmark
RCG Plus Member
Latest blog entry: FrSky Taranis misc stuff
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion SPEED LIST - Speed, Plane, Pilot, Location, Date, Witness, Gyro?(Yes/No) daboz Dynamic Soaring 2554 Today 09:06 PM
Discussion Twisted Hobbys - 32" Xtra Slick - Build, Fly, Vid hercdriver7777 3D Foamies 3018 Jul 03, 2014 01:53 PM
New Product Osiris V2 eli5539 Indoor Pattern/F3P 1 Dec 14, 2010 08:08 PM
Help! thread Not used any more yiny0730 FPV Talk 4 Oct 15, 2010 09:46 AM