SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Feb 26, 2013, 03:26 PM
Fly Straight Fly High
tengarang's Avatar
San Jose, California
Joined Aug 2010
3,798 Posts
Quote:
Originally Posted by Joe 1320 View Post
The hybrid fan I would tent to build would be to start with the Haoye housing and do the proper trimming to accept the stock JPower motor, followed by the AEO rotor.
Thank you...absorbing this idea
tengarang is online now Find More Posts by tengarang
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 26, 2013, 09:49 PM
efflux RC's Avatar
United States, CA, Santa Clarita
Joined Aug 2009
8,848 Posts
We have the Wemotec 50mm Microfans and HET 3s and 4s motors are on sale.
efflux RC is offline Find More Posts by efflux RC
Site Sponsor
Latest blog entry: Updated blog Oct 2014
Reply With Quote
Old Feb 26, 2013, 10:17 PM
Registered User
Joined Nov 2012
391 Posts
what is the fastest setup for these planes with a 50mm edf? has anybody gone over 100mph?
rcfisherman is offline Find More Posts by rcfisherman
Reply With Quote
Old Feb 26, 2013, 10:48 PM
Registered User
Mike20's Avatar
Joined Sep 2012
544 Posts
Quote:
Originally Posted by rcfisherman View Post
what is the fastest setup for these planes with a 50mm edf? has anybody gone over 100mph?
I think only dons setup is close to that speed.
Mike20 is offline Find More Posts by Mike20
Reply With Quote
Old Feb 27, 2013, 12:20 AM
Wonderfully Wicked
The Don's Avatar
Willoughby, Ohio
Joined Jan 2002
13,222 Posts
Quote:
Originally Posted by rcfisherman View Post
what is the fastest setup for these planes with a 50mm edf? has anybody gone over 100mph?
I am just over 100 mph on 3S with the Wicked 6000 and Wemo micro fan unit when built per my build thread.

Wicked Powered 50mm Screamer EDF Jet (3 min 36 sec)


There is also a video earlier in this thread of the Screamer flying the Wicked 6000 Wemotec combo on 4S that was close to 120 mph but that is a use at your own risk setup!

Don
The Don is offline Find More Posts by The Don
RCG Plus Member
Old Feb 27, 2013, 08:48 AM
Registered User
Mike20's Avatar
Joined Sep 2012
544 Posts
I gotta say the 6 blade sounds a lot better and is quieter then the stock 5 blade. I don't notice much improvement on speed though.
Mike20 is offline Find More Posts by Mike20
Reply With Quote
Old Feb 27, 2013, 09:46 AM
Registered User
gooniac33's Avatar
Sunnyvale
Joined Feb 2009
5,131 Posts
Quote:
Originally Posted by The Don View Post
I am just over 100 mph on 3S with the Wicked 6000 and Wemo micro fan unit when built per my build thread.

http://www.youtube.com/watch?v=4Uqq0...IfGF9Lzylzf4hw

There is also a video earlier in this thread of the Screamer flying the Wicked 6000 Wemotec combo on 4S that was close to 120 mph but that is a use at your own risk setup!

Don
You sell good stuff Don!! There are currently 2 of these combos running on 4s at my field and they haven't missed a beat! Insane fast but really reliable! This airframe is the best thus far! I just need to break down and get one already....
gooniac33 is offline Find More Posts by gooniac33
Reply With Quote
Old Feb 27, 2013, 10:08 AM
Registered User
United Kingdom, Warrington
Joined Feb 2013
1 Posts
Hi all, this is my first post after a long time lurking.

I gotta say, these 50mm EDF's are superb. I've been loving my T-45 since I got it last September. Its got well over 100 flights in stock form and I'm now in the process of upgrading it.

I've been lucky enough to only have the one mishap, but it was a corker! Check it out:

RC Jet Tree "Landing" (50mm EDF T-45) (3 min 12 sec)


It took a while to find all the bits but the repair was pretty easy and it flies like new again.

This was the resulting damage:
MoDolph is offline Find More Posts by MoDolph
Reply With Quote
Old Feb 27, 2013, 10:47 AM
Registered User
gooniac33's Avatar
Sunnyvale
Joined Feb 2009
5,131 Posts
Quote:
Originally Posted by MoDolph View Post
Hi all, this is my first post after a long time lurking.

I gotta say, these 50mm EDF's are superb. I've been loving my T-45 since I got it last September. Its got well over 100 flights in stock form and I'm now in the process of upgrading it.

I've been lucky enough to only have the one mishap, but it was a corker! Check it out:

http://youtu.be/2kPGwurf_oU

It took a while to find all the bits but the repair was pretty easy and it flies like new again.

This was the resulting damage:
It amazes me how easy it is to repair these lil buggers! I have seen a similar incident with the exact same plane and it was back flying in less than 10 minutes. And just last week I got my L-39 caught up in a kite string. About 10 minutes and it was back together as well. And I flew it again a couple days ago and it is as good as new!
gooniac33 is offline Find More Posts by gooniac33
Reply With Quote
Old Feb 27, 2013, 12:30 PM
Registered User
Mike20's Avatar
Joined Sep 2012
544 Posts
Quote:
Originally Posted by Mike20 View Post
I gotta say the 6 blade sounds a lot better and is quieter then the stock 5 blade. I don't notice much improvement on speed though.
Well I was enjoying the T45 a bit too much and did a low loop. I had just enough space for it to plop on the ground on its belly. When it did that it broke off one of the blades. So look like I'm back to the stock rotor until someone can restock these rotors.
Mike20 is offline Find More Posts by Mike20
Reply With Quote
Old Feb 27, 2013, 02:49 PM
Registered User
Mrgeorgedoors's Avatar
United Kingdom, Warrington
Joined Nov 2012
553 Posts
Decided to take my 4s sabre out today get back into the edf's not flew for a bit. Gets to the field and forgot my battery connection converter plug so had to fly my t28. Around 4 pm we decided to head home for a quick charge and come back out and grab the last hour of light.

Launched on 1st battery had a sticky moment but did an amazing save and up and away she went. Did a few laps of the park loops n rolls etc loved it, brought it down and stuck another battery on as light was fading, after one lap of the park it lost all power no controls or anything so I ad to watch it fall out of the sky and crash. I'm getting fed up of mishaps that I don't know what's causing them. I have never crashed this before and had been fine no problems. I tested back on The ground and it lost connection from esc and it rebooted then I gave it some throttle it seemed ok BUT then the throttle stuck on and had to disconnect battery to shut it off.


So what do I do now? Replace esc or cud it be the rx? And why has it done this

Was expecting a lot worse to be honest.



Bit of hot water and some glue be right as rain again


Rod
Mrgeorgedoors is offline Find More Posts by Mrgeorgedoors
Reply With Quote
Old Feb 27, 2013, 03:46 PM
Fly Straight Fly High
tengarang's Avatar
San Jose, California
Joined Aug 2010
3,798 Posts
Quote:
Originally Posted by Mrgeorgedoors View Post
Decided to take my 4s sabre out today get back into the edf's not flew for a bit. Gets to the field and forgot my battery connection converter plug so had to fly my t28. Around 4 pm we decided to head home for a quick charge and come back out and grab the last hour of light.

Launched on 1st battery had a sticky moment but did an amazing save and up and away she went. Did a few laps of the park loops n rolls etc loved it, brought it down and stuck another battery on as light was fading, after one lap of the park it lost all power no controls or anything so I ad to watch it fall out of the sky and crash. I'm getting fed up of mishaps that I don't know what's causing them. I have never crashed this before and had been fine no problems. I tested back on The ground and it lost connection from esc and it rebooted then I gave it some throttle it seemed ok BUT then the throttle stuck on and had to disconnect battery to shut it off.


So what do I do now? Replace esc or cud it be the rx? And why has it done this

Was expecting a lot worse to be honest.



Bit of hot water and some glue be right as rain again


Rod
Try duplicating this issue on a different rx. hopefully its a known good rx unit as a point of reference. the culprit will show
tengarang is online now Find More Posts by tengarang
Reply With Quote
Old Feb 27, 2013, 03:58 PM
Registered User
Mrgeorgedoors's Avatar
United Kingdom, Warrington
Joined Nov 2012
553 Posts
Quote:
Originally Posted by tengarang View Post
Try duplicating this issue on a different rx. hopefully its a known good rx unit as a point of reference. the culprit will show
Ill swap rx and esc I think. Makes me think its the esc with it rebooting itself and throttle sticking on when tested after the crash. All electrics are only couple of months old as is the plane. Ill try rx 1st as they're all the same I use in all my jets ar400's and that's easier to swap than the esc as I glued the wings on.


Rod
Mrgeorgedoors is offline Find More Posts by Mrgeorgedoors
Reply With Quote
Old Feb 27, 2013, 04:03 PM
Registered User
Vienna, Austria
Joined Apr 2007
2,090 Posts
Quote:
Originally Posted by Mrgeorgedoors View Post
Ill swap rx and esc I think. Makes me think its the esc with it rebooting itself and throttle sticking on when tested after the crash...
Did you measure the amps? Is the ESC rated for that kind of current? The AEOs (with stock motors) are known to be amp hogs...
mopetista is online now Find More Posts by mopetista
Reply With Quote
Old Feb 27, 2013, 04:07 PM
Fly Straight Fly High
tengarang's Avatar
San Jose, California
Joined Aug 2010
3,798 Posts
Quote:
Originally Posted by Mrgeorgedoors View Post
Ill swap rx and esc I think. Makes me think its the esc with it rebooting itself and throttle sticking on when tested after the crash. All electrics are only couple of months old as is the plane. Ill try rx 1st as they're all the same I use in all my jets ar400's and that's easier to swap than the esc as I glued the wings on.


Rod
On my older futaba that I do not use anymore....ithe aileron port on the rx was faulty and glitches from time to time. ...and locks full bank right aileron. I lost my FMS hellcat this way from very high up...thought it was a brown out...nope...

I know this because at the time of the crash I concluded it was a brown out...then several weeks later I bought the same kit and built her up again...flew and landed fine...but it was right after i taxied her in...she started the aileron lock again(on the ground with power on while I was talking to another dude)....thinking back in the first incident...it did spiral in screw pattern....

That Rx unit went in the bin....i correlate the same issue on your throttle channel ....may be
tengarang is online now Find More Posts by tengarang
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Adelaide & SA flying & chat #2 Zootster Australia 21134 Today 12:59 AM
Help! Where can I buy Genkem Nova 27 in SA? MegaTesla South Africa 2 May 14, 2011 04:25 PM
Discussion SAL-SA Glider in Gobi dune romanticus Slope 11 Nov 30, 2010 11:40 PM
Question SA 2010-02 Castle ICE 100 "failed cut off" ?? LandCruiser Castle Creations 2 Oct 20, 2010 12:07 AM
T-33 Spring-air minis HW609 Derrek Curtis Electric Ducted Fan Jet Talk 3 Apr 25, 2001 04:42 PM