HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 20, 2010, 01:57 PM
Registered User
United States, TX, McKinney
Joined Oct 2009
18 Posts
Discussion
Evolution Alpha engine not holding high throttle

Hi everyone. Newbie here, second post. Been flying my trainer all summer with no problems. However, since last week I have been having problems with the engine holding hi revs. It starts fine, accelerates ok up to 2/3 throttle but after that it struggles to keep high revs and then dies.

I have tightened the head screws, changed plug, all the plumbing, filters new fuel, and even new gas tank, ruling everything out but the engine itself. Nothing has helped so far.

To give you a better idea of how the engine runs, I have posted a short video at
Problems with Evolution alpha engine (4 min 24 sec)
.

The first two runs are with the engine all leaned up with the needle as far as the limiter will allow. For the 3rd run I enriched it 1/8th of a turn, which seemed to improve how it runs overall, but same problem in the end (I have done other runs enriching 1/4 and 1/3 turns to no avail). Any help would be greatly appreciated. And my apologies for the derriere shots... hope you don't go blind.. LOL

Thanks in advance

Moises
moisesh is online now Find More Posts by moisesh
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 20, 2010, 03:59 PM
Registered User
DGrant's Avatar
United States, CA, Clovis
Joined Mar 2004
3,212 Posts
There could be some "micro-garb" lodged in the path to the engine somewhere. It does sound like its lean... but really only struggles when it should need everything the system can deliver.

You said you flew all summer with no probs.. hmm... did you try to back-flush the system at all... pump some fuel the opposite way through the system, starting from where it enters the engine and going back to the inlet on the tank.. just plug your fuel-pump to it, make sure it won't flush out onto anything, or get something to catch it.. (even the fuel tank).. I'm thinking it might dis-lodge something.. maybe. I've also taken some micro tools, and fished every inlet/outlet those things have.. and actually pulled garbage out.. it does'nt take much to affect.. and by only the slight problem you have.. it just stands to reason in my mind. Hope this helps. )
DGrant is offline Find More Posts by DGrant
Reply With Quote
Old Nov 20, 2010, 04:01 PM
Registered User
Standish, Maine
Joined Mar 2008
38 Posts
The high end needle sounds lean to me, like the engine is starving for fuel. The Evolution engines I have run into at our club all have had to have the limiters removed to get optimum settings. Just pull the pins out of the limiters. If it is getting colder where you are, you will need to richen up the mixtures to compensate for the colder, denser air.
schizm is offline Find More Posts by schizm
Reply With Quote
Old Nov 20, 2010, 04:59 PM
Registered User
United States, TX, McKinney
Joined Oct 2009
18 Posts
Thanks Schizm and Dgrant for the prompt response. So I went back to the plane and played with enriching it 1/2 and one full turn. That seemed to help. With the 1/2 turn it sustained more and with the full turn I was able to hold full revs at WOT. However, when went to idle and quickly revved up, the engine would die.

Now, I noticed something: the Evolution engines have the high needle behind the cylinder and is connected to the carburetor with a fuel line. What I notice while running the engine this time was that I would see bubbles running from the needle to the carburetor, but not from the tank to the needle. Is this normal or do i have an air leak at the needle valve?
moisesh is online now Find More Posts by moisesh
Reply With Quote
Old Nov 21, 2010, 04:30 PM
Will fly for food
Maryland
Joined Sep 2004
8,424 Posts
YOu have an air leak. Cut a short piece of fuel line, remove the needle valve and slip the fuel line over the needle valve and reinstall.

I have also found that I have had to remove the limit pin on Evolution engines to get them tuned properly.
Pinecone is offline Find More Posts by Pinecone
Reply With Quote
Old Nov 22, 2010, 03:57 PM
Registered User
United States, TX, McKinney
Joined Oct 2009
18 Posts
Thanks pinecone. I'll try your advice on my engine and will report back... once I figure how to remove the damn pin. Does it srew out or do I just yank it out / cut it / push it?

EDIT: Ok. Just yanked out the pin. Will try the fuel line fix with the blue collar on and if that doesn't work then the collar is coming off next.
moisesh is online now Find More Posts by moisesh
Last edited by moisesh; Nov 22, 2010 at 04:23 PM.
Reply With Quote
Old Nov 22, 2010, 05:16 PM
Registered User
United States, TX, McKinney
Joined Oct 2009
18 Posts
IT WORKED! Well, I'm happy to report that the fuel line in the HS needle as described by pinecone worked. Also, as Dgrant and schizm pointed out, the engine was too lean. So I enriched half of a turn from the factory set upper limit (total 1 and 1/2 turns from fully closed), applied Pinecone's fix and also put a rubber ring around the needle handle and the "clicker", to prevent it from walking. After that, I ran it up and down, idle, fully revved and back without it dying. Not sure if the fix will hold, but I have a set of gaskets on order, so this should keep me in the air until it arrives. Thanks a lot for your help guys!

Moises
moisesh is online now Find More Posts by moisesh
Last edited by moisesh; Nov 22, 2010 at 11:47 PM.
Reply With Quote
Old Nov 22, 2010, 06:32 PM
Registered User
RCMikeofIndiana's Avatar
United States, IN, Griffith
Joined Sep 2010
80 Posts
I had the same problem. After two weekends of the club pros working on it ( and not getting any where) I sent it to Horizon for warranty repair. They replaced the entire high speed needle valve assembly, fuel line and glow plug. Works like a champ now.
RCMikeofIndiana is offline Find More Posts by RCMikeofIndiana
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Blade Msr Tail not holding and main blades 'sticking' pbusanga Micro Helis 10 Nov 10, 2010 12:36 PM
Question Alpha 40 Trainer .45 Evolution engine markh29 Engines 12 Apr 18, 2009 04:17 AM
Discussion Gyro not holding when I throttle up The Steve-O Mini Helis 25 Sep 29, 2008 04:44 PM
Sold Evolution 45 engine alpha SPCustoms Aircraft - Fuel - Engines and Accessories (FS/W) 2 Apr 09, 2008 04:55 PM
Question Throttle hold - not really holding... CodeToad Mini Helis 13 Feb 12, 2007 01:59 PM