HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 03, 2011, 03:05 PM
Row 0, Seat A
G550Ted's Avatar
Savannah, GA
Joined Jan 2008
2,705 Posts
I received my latest board from Steven today, YAY! Oh, wait... It's smashed and ruined. Oh feces!

It is obvious that the box it was shipped in had been run over by what looks to have been a small wheel (mail cart?). On the positive side at least is that he still has some in stock (for now).

Ted
G550Ted is online now Find More Posts by G550Ted
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 03, 2011, 04:56 PM
Registered Loser
Canada, BC, Central Okanagan H
Joined Jun 2010
3,251 Posts
Holy crap! That's nuts. Send me an email (use my contact page if you don't have my email) with your order number or full name and I'll send another.

- Steven
s_mack is offline Find More Posts by s_mack
Reply With Quote
Old Dec 03, 2011, 08:20 PM
Row 0, Seat A
G550Ted's Avatar
Savannah, GA
Joined Jan 2008
2,705 Posts
Quote:
Originally Posted by s_mack View Post
Holy crap! That's nuts. Send me an email (use my contact page if you don't have my email) with your order number or full name and I'll send another.

- Steven
Steven,

Email sent, and thank you.

For everyone reading this, here is the email I got from Steven:

"Hi Ted,

Yeah, I just saw your photos online! That's a first lol. Sorry it happened to you, but its kinda funny in a way There's insurance on the item but frankly its a real headache to put in a claim, especially at this time of the year - I'd be on hold for 3 hours! I'll just send out a new one. Please... don't bother sending the original back The picture is good enough for me. Can you confirm that the 4 spacers and 4 screws are there and in good shape?

Steven Morehouse
SmartieParts.com "

And my response:

"Hi Steven,

Thank you for the quick reply. The spacers and screws survived undamaged.

I had to laugh, too, because this is a bit of deja vu. 42 or so years ago I received a book mailed to me when I was in Viet Nam. Wrapped in sturdy brown paper, it was stamped multiple times "Fragile" in red. Diagonally across that package was the clear track of a military Jeep tread, kinda like the wheel track across your package.

Now, here is where this gets into the "Twilight Zone" realm. Two or three days ago the memory of receiving that book so many yeas ago just popped into my mind, completely out of nowhere and related to nothing I was or had been doing! Da dah, da dah, da dah, da dah...=-O

I very much appreciate your support.

Ted"

I post this because I think everyone should know of the upstanding customer support that Steven provides his customers for his great product, abuse by US/Canadian postal services notwithstanding.

Ted
G550Ted is online now Find More Posts by G550Ted
Reply With Quote
Old Dec 03, 2011, 08:43 PM
You can't take the sky from me
scott page's Avatar
United States, WA, Richland
Joined May 2009
5,866 Posts
Quote:
Originally Posted by G550Ted View Post
I post this because I think everyone should know of the upstanding customer support that Steven provides his customers for his great product, abuse by US/Canadian postal services notwithstanding.

Ted

+1 for Smartieparts customer support. I have absolutely NO reservations recommending is products to anybody. I had a smaller issue and he took very good care of me.


@ Steven -- how is the baby? You getting any sleep yet?
scott page is offline Find More Posts by scott page
RCG Plus Member
Old Dec 03, 2011, 09:53 PM
Registered Loser
Canada, BC, Central Okanagan H
Joined Jun 2010
3,251 Posts
Thanks Ted, Scott. I take care of my customers cause they take care of me! And, well, because... its the right thing to do. Thankfully this sort of thing doesn't happen very often.

My son is doing well. Sleep is still infrequent, but getting better. Thanks for asking!

- Steven
s_mack is offline Find More Posts by s_mack
Reply With Quote
Old Dec 03, 2011, 11:54 PM
59 years of RC flying
Daedalus66's Avatar
Canada, ON, Ottawa
Joined Feb 2006
16,027 Posts
Quote:
Originally Posted by scott page View Post
+1 for Smartieparts customer support. I have absolutely NO reservations recommending is products to anybody. I had a smaller issue and he took very good care of me.
Add me to the list of happy clients. Glad to hear things are improving on the family front.
Daedalus66 is online now Find More Posts by Daedalus66
Reply With Quote
Old Dec 04, 2011, 09:41 AM
Lipoly Killer
Frank Hurd's Avatar
Gulfport/Biloxi Biloxi Reg, Mississippi, United States
Joined Dec 2000
1,503 Posts
Steven

I'm sorry to bother you again but I still can't get my tx flashed. I re-installed the board after cleaning it with denatured alcohol, my device manager shows the USBasp device plus I get the sound notification when I plug in.
When I go to the EEPEe program I make sure that the program is set up for AVIdude and USBasp. However, when I go to read or burn, the AVIdude window opens but nothing happens. Is this a computer problem or something else? How can I tell if my smartieparts board is working?
Thanks for your patience.
Frank
Frank Hurd is offline Find More Posts by Frank Hurd
Reply With Quote
Old Dec 04, 2011, 10:24 AM
Registered Loser
Canada, BC, Central Okanagan H
Joined Jun 2010
3,251 Posts
The fact that it shows up in device manager goes a long way to knowing the device is working. It also means you got the drivers in and communication between the device and the PC is good. So now its a matter of communication between the device and the radio and/or simply a software mis-use.

"nothing happens" concerns me. What does that mean, exactly? Like... nothing? You choose read and there is absolutely no response to that action? If so, that's gotta be software. Even if the board isn't installed in the radio at all you should get some message about Target not responding.

- Steven
s_mack is offline Find More Posts by s_mack
Reply With Quote
Old Dec 04, 2011, 11:52 AM
Lipoly Killer
Frank Hurd's Avatar
Gulfport/Biloxi Biloxi Reg, Mississippi, United States
Joined Dec 2000
1,503 Posts
Steven

When I click"Read flash memory from tx", A window appears "AVRDUDE- Read flash from tx" and the contents section is blank. When I first tried this.a while ago" I got a window that appears to be scanning and then the message can't find USBasp. Now nothing. I checked to make sure that the pins were straight and snug.
Thank you.
Frank
Frank Hurd is offline Find More Posts by Frank Hurd
Reply With Quote
Old Dec 04, 2011, 12:38 PM
Row 0, Seat A
G550Ted's Avatar
Savannah, GA
Joined Jan 2008
2,705 Posts
Quote:
Originally Posted by Frank Hurd View Post
When I click"Read flash memory from tx", A window appears "AVRDUDE- Read flash from tx" and the contents section is blank. When I first tried this.a while ago" I got a window that appears to be scanning and then the message can't find USBasp. Now nothing. I checked to make sure that the pins were straight and snug.
Thank you.
Frank
Frank,

I get the same (or similar) message if I plug into a different USB port on my 'puter than the port I used when I first configured my setup.

Beware! I am a computer challenged binary idiot and have never been to a Holiday Inn Express.

Ted
G550Ted is online now Find More Posts by G550Ted
Reply With Quote
Old Dec 04, 2011, 01:42 PM
Registered Loser
Canada, BC, Central Okanagan H
Joined Jun 2010
3,251 Posts
It really shouldn't, but some times it does matter which port on your computer you use. I'm no USB expert, but it seems to me that the drivers are installed for a specific device on a specific port and when you plug it into a different port, the drivers need to be reinstalled. Now, Windows *should* take care of that seemlessly with no action required by the user... but it is Windows, afterall. Also, it seems not all ports are created equal. On my wife's laptop, one of the ports WILL NOT recognize the USBasp no matter what I do. That same port works fine for other devices I've tried, except one of my many USB drives. I can't figure that out for the life of me.

Anyway, Ted... I'm probably not the person to provide assistance to you at this point. Probably one of the people more familiar with how the software works. Normally when its a connection issue, you get an error about the Target (meaning radio's CPU) not being found. However, its not impossible that its a faulty board either. I'm really not sure what to suggest. One option could be that you get another board from me and if that one magically works, then return the original. But if neither work, then it must be something else. If you wish to try that, contact me directly by email and we'll get it sorted.

- Steven
s_mack is offline Find More Posts by s_mack
Reply With Quote
Old Dec 04, 2011, 02:07 PM
Row 0, Seat A
G550Ted's Avatar
Savannah, GA
Joined Jan 2008
2,705 Posts
Quote:
Originally Posted by s_mack View Post
It really shouldn't, but some times it does matter which port on your computer you use. I'm no USB expert, but it seems to me that the drivers are installed for a specific device on a specific port and when you plug it into a different port, the drivers need to be reinstalled. Now, Windows *should* take care of that seemlessly with no action required by the user... but it is Windows, afterall. Also, it seems not all ports are created equal. On my wife's laptop, one of the ports WILL NOT recognize the USBasp no matter what I do. That same port works fine for other devices I've tried, except one of my many USB drives. I can't figure that out for the life of me.

Anyway, Ted... I'm probably not the person to provide assistance to you at this point. Probably one of the people more familiar with how the software works. Normally when its a connection issue, you get an error about the Target (meaning radio's CPU) not being found. However, its not impossible that its a faulty board either. I'm really not sure what to suggest. One option could be that you get another board from me and if that one magically works, then return the original. But if neither work, then it must be something else. If you wish to try that, contact me directly by email and we'll get it sorted.

- Steven
Steven,

My setup works fine when plugged into the "correct" USB port. Frank is the one having problems getting his to work.

Ted
G550Ted is online now Find More Posts by G550Ted
Reply With Quote
Old Dec 04, 2011, 02:37 PM
Registered Loser
Canada, BC, Central Okanagan H
Joined Jun 2010
3,251 Posts
Yeah, I know... I meant "Frank" in the 2nd paragraph, sorry.
s_mack is offline Find More Posts by s_mack
Reply With Quote
Old Dec 04, 2011, 04:32 PM
Registered User
Naperville, IL
Joined Mar 2009
832 Posts
Quote:
Originally Posted by Frank Hurd View Post
I'm sorry to bother you again but I still can't get my tx flashed. I re-installed the board after cleaning it with denatured alcohol, my device manager shows the USBasp device plus I get the sound notification when I plug in.
When I go to the EEPEe program I make sure that the program is set up for AVIdude and USBasp. However, when I go to read or burn, the AVIdude window opens but nothing happens. Is this a computer problem or something else? How can I tell if my smartieparts board is working?
Thanks for your patience.
Frank
Frank,
the path that you put in for AVRdude in the Eepe configuration. Go to that spot in your computer and make sure that avrdude is there. If it is not you might have to find out where it is, or install avrdude. So far your board is connected in the Tx just fine. That problem is in the computer. Typically if there is nothing in the avrdude window that means that Eepe cannot find avrdude.
-Gohst
gohsthb is offline Find More Posts by gohsthb
Reply With Quote
Old Dec 04, 2011, 07:38 PM
Just a yard bird
kd4wen's Avatar
Las Vegas Nv.
Joined Mar 2007
1,826 Posts
Ok folks it is really time for me to upgrade my battery. And to make sure I am correct this battery does a good job and fits in the 9X battery compartment along with the Smartieparts Board USB port.

http://www.hobbyking.com/hobbyking/s...arehouse_.html

Am I correct before I buy more stuff that I cannot use in my still somewhat newbeeness.
Thanks to anyone that can let me know.
kd4wen is offline Find More Posts by kd4wen
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Download RCDeskpilot Add-on Planes In Post #1 UPDATED MARCH 7 2011 Wilfor Simulators 197 Jul 23, 2014 09:01 AM
Sold RealFlight G3.5 With Controller and Vol. 3 Add-On Rob02Aggie Aircraft - General - Miscellaneous (FS/W) 3 Nov 13, 2010 02:13 PM
Question Searching RC Car with transmitter having the pots NOT soldered directly on the board Nase Electric Power Cars 0 Nov 07, 2010 08:46 AM
Discussion Built-in-Balancer: Replace a 14.4 nihm pack with 5S LiFE leveraging original charger? coreyfro DIY Electronics 0 Nov 05, 2010 09:33 AM