HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 07, 2010, 01:15 AM
Registered User
Joined Nov 2010
7 Posts
Help!
AR6200 binding problem?

I just bought a dx6i and when i try to bind it the led just stays solid.Heres what i did i put the bind plug in the bind/batt and the esc in the thro and plugged in a random servo in rudder but when i power it on the led just stays solid.Has anyone had this problem?How do i get it to bind?
hellsrage619 is offline Find More Posts by hellsrage619
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 07, 2010, 06:47 AM
Will fly for food
Maryland
Joined Sep 2004
8,424 Posts
Make sure the bind plug is fully inserted. If you put it in the wrong way, the bevels may make it not go in fully.

Check the bind plug with a volt meter for continuity between the outer pins.

Try another bind plug, or just short the Bind/Batt port outer two pins.

If none of this works, the Rx may be bad. Return to hobby shop or directly to Horizon.
Pinecone is offline Find More Posts by Pinecone
Reply With Quote
Old Nov 07, 2010, 07:32 AM
60 years of RC flying
Daedalus66's Avatar
Canada, ON, Ottawa
Joined Feb 2006
16,730 Posts
Most of the time, such problems are caused by reversing the plugs. The light will come on even if the ESC connector is the wrong way round.

Try again with the ESC connector reversed. Don't plug in the servo till you've got the receiver to flash as it's just one more possible source of problems. Make sure the transmitter is OFF. The receiver should flash rapidly when you apply battery to the ESC.

If that doesn't do it, disconnect and reconnect the satellite receiver at both ends of the cable. Sometimes you get oxidation on the contacts.
Daedalus66 is online now Find More Posts by Daedalus66
Reply With Quote
Old Nov 07, 2010, 09:31 AM
Registered User
Joined Nov 2010
7 Posts
Quote:
Originally Posted by Daedalus66 View Post
Most of the time, such problems are caused by reversing the plugs. The light will come on even if the ESC connector is the wrong way round.

Try again with the ESC connector reversed. Don't plug in the servo till you've got the receiver to flash as it's just one more possible source of problems. Make sure the transmitter is OFF. The receiver should flash rapidly when you apply battery to the ESC.

If that doesn't do it, disconnect and reconnect the satellite receiver at both ends of the cable. Sometimes you get oxidation on the contacts.
Thank you i needed to reverse all the plugs guess i was way to tiered and irritated last night as yesterday i had my first flight with a hawk sky it went horrible i was about 150ft up when my stock 72mhz radio got interference and dived to the ground nothing broke but i was sad and made the decision to buy a dx6i cause i will never have interference again .I did get video of it from a fpv here have a laugh and tell me what you think happened beside me over correcting and making it stall in the beginning and i think it was nose heavy cause with no power it really wanted to dive.
First flight with bad results (1 min 20 sec)
hellsrage619 is offline Find More Posts by hellsrage619
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion FUTABA 6EX, 7C and TM7 Binding Problem global344 Radios 0 Nov 01, 2010 12:24 PM
Discussion Another DX6i/AR6200 binding problem... cjsharp1 Radios 13 Oct 31, 2010 04:47 PM
Discussion binding ar6200 tole82 Radios 1 Oct 21, 2010 04:44 PM
Discussion Problem Binding AR6200 Heeeelllppp!!! crazy train Radios 6 Mar 17, 2009 03:51 PM
Help! Dx6i AR6200 Binding Problem serpent46 Radios 3 Feb 15, 2009 10:17 AM