HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 05, 2011, 03:34 PM
Suspended Account
Brunswick, OH
Joined Nov 2005
5,547 Posts
If you use HyperTerminal or another terminal program (like Termite) can you type $Q,0,0*FF<carriage return> and see what the result is?
HappyKillmore is offline Find More Posts by HappyKillmore
Reply With Quote  (Disabled)
Sign up now
to remove ads between posts
Old Nov 05, 2011, 03:50 PM
Lift is cheap - Drag sucks
Tom Harper's Avatar
Socorro, NM
Joined Jul 2004
3,590 Posts
Paul,

I'm confused - I am using the GSC in my laptop and clicking on the 'Connect' button. Do I need an additional terminal program?

Where is the command line to enter $Q,0,0,*FF?

Thanks,

Tom
Tom Harper is offline Find More Posts by Tom Harper
Reply With Quote
Old Nov 05, 2011, 04:06 PM
Suspended Account
Brunswick, OH
Joined Nov 2005
5,547 Posts
The additional terminal program is to eliminate the issue with the GCS. If you connect using a regular terminal program and send the command $Q,0,0,*FF you should get a readable response with A1, A2, A3 and A4 commands back from the Atto. If you don't get that back, then you either have the wrong baud rate, the wrong serial port or bad cabling.
HappyKillmore is offline Find More Posts by HappyKillmore
Reply With Quote  (Disabled)
Old Nov 05, 2011, 04:50 PM
Lift is cheap - Drag sucks
Tom Harper's Avatar
Socorro, NM
Joined Jul 2004
3,590 Posts
Paul,

Thanks, good plan. When I go to HyperTerminal and set it for com7, it reports that it is connected but when I try to type in the window nothing happens.

Could we try to trouble shoot the GCS:

Are the connections I described above correct?

What should be the state of Atto when you communicate with it?

If I try to communicate at one baud rate and it fails, do I need to restart Atto before I try another rate?

Thanks,

Tom
Tom Harper is offline Find More Posts by Tom Harper
Reply With Quote
Old Nov 05, 2011, 05:51 PM
Lift is cheap - Drag sucks
Tom Harper's Avatar
Socorro, NM
Joined Jul 2004
3,590 Posts
Paul,

My connections were not correct. It should be:

Vsss-->Ground
/Res-->Open
Tx---->Tx
Rx---->Rx

I corrected the cable connection but I still do not get a response from Atto at any baud rate.

Tom
Tom Harper is offline Find More Posts by Tom Harper
Reply With Quote
Old Nov 05, 2011, 06:46 PM
Lift is cheap - Drag sucks
Tom Harper's Avatar
Socorro, NM
Joined Jul 2004
3,590 Posts
Ah___it seems to be working.

Thanks,

Tom
Tom Harper is offline Find More Posts by Tom Harper
Reply With Quote
Old Nov 05, 2011, 09:52 PM
Suspended Account
Brunswick, OH
Joined Nov 2005
5,547 Posts
Cool. I assume you found that Tx ---> Rx and Rx --> Tx?
HappyKillmore is offline Find More Posts by HappyKillmore
Reply With Quote  (Disabled)
Old Nov 05, 2011, 11:06 PM
Lift is cheap - Drag sucks
Tom Harper's Avatar
Socorro, NM
Joined Jul 2004
3,590 Posts
No, I used Res instead of Vss.

Tom
Tom Harper is offline Find More Posts by Tom Harper
Reply With Quote
Old Nov 06, 2011, 06:10 PM
Lift is cheap - Drag sucks
Tom Harper's Avatar
Socorro, NM
Joined Jul 2004
3,590 Posts
Paul,

Communication with the Atto 3.0 seems OK.

I am still not having any success with the v2.0 units. My set up must be OK because it works with the v3.0. I have tried 9600, 19200 and 38400 baud rates.

Any thoughts?

Tom
Tom Harper is offline Find More Posts by Tom Harper
Reply With Quote
Old Nov 06, 2011, 07:19 PM
Suspended Account
Brunswick, OH
Joined Nov 2005
5,547 Posts
I can't make any guarentees on v2. I don't own one.
HappyKillmore is offline Find More Posts by HappyKillmore
Reply With Quote  (Disabled)
Old Nov 06, 2011, 08:17 PM
Registered User
Near Austin
Joined Dec 2001
5,380 Posts
Tom,

Serial communication can be some of the most aggravating of issues with any autopilot. I have been successful with both my V2.0 and V3.0 units - BUT - only with Xbee modems. I have several 9Xtends that I can get talking between computers, no problem. But try to get Atto to talk through them seems to be a lost cause.

My SET files are at the warehouse, but make sure you have the baud rate selected in the SET file the same as the modems.

Gene
CenTexFlyer is online now Find More Posts by CenTexFlyer
Reply With Quote
Old Nov 06, 2011, 08:28 PM
Suspended Account
Brunswick, OH
Joined Nov 2005
5,547 Posts
Actually, maybe I do have a V2 instead of a V3. Not sure what to tell you. What firmware version do you have?
HappyKillmore is offline Find More Posts by HappyKillmore
Reply With Quote  (Disabled)
Old Nov 06, 2011, 09:01 PM
Lift is cheap - Drag sucks
Tom Harper's Avatar
Socorro, NM
Joined Jul 2004
3,590 Posts
Gene,

Thanks, I'll check it.

Paul,

The firmware may be the problem. I have an email in to Chris for an update.

Tom
Tom Harper is offline Find More Posts by Tom Harper
Reply With Quote
Old Nov 22, 2011, 11:12 PM
Registered Crasher
Bilox's Avatar
Melbourne, Australia
Joined Jul 2008
1,108 Posts
Hey!

Happy Birthday Happy!!
Bilox is offline Find More Posts by Bilox
Reply With Quote
Old Dec 02, 2011, 02:42 PM
Lift is cheap - Drag sucks
Tom Harper's Avatar
Socorro, NM
Joined Jul 2004
3,590 Posts
Paul,

GCS is working with both Atto V2.0s and V3.0.

Next question:

When I upload a WP file to Atto does the GCS store it in Eprom location 0? As I understand it, Atto can store multiple WP files. Can this be done through the GCS?

My first priority is simply to upload a WP file that will be held by Atto after a power off. I need to hike into the field and fly a WP pattern without dragging the laptop along.

Tom
Tom Harper is offline Find More Posts by Tom Harper
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Show Us Your Ground Station !!!! FPV Ground Station Design and Idea's found here :) JettPilot FPV Equipment 4054 Yesterday 04:39 PM
Discussion Ground station wiring harness ziomatrixacs FPV Talk 3 Oct 07, 2010 05:48 PM
Discussion DIY Continuous Rotating FPV Ground Station Moosthegoose FPV Talk 37 Sep 29, 2010 04:27 AM
Discussion Aerial Photography request an Autopilot system & Ground Control Station Atflying Aerial Photography 7 Jun 27, 2010 02:13 AM