SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Apr 01, 2011, 06:20 PM
Suspended Account
Brunswick, OH
Joined Nov 2005
5,547 Posts
Have you tried that code on your ArduPilot Mega with the IMU connected? I haven't seen that code, it might work just fine.
HappyKillmore is offline Find More Posts by HappyKillmore
Reply With Quote  (Disabled)
Sign up now
to remove ads between posts
Old Apr 01, 2011, 06:37 PM
Registered User
Joined Oct 2010
74 Posts
Quote:
Originally Posted by HappyKillmore View Post
Have you tried that code on your ArduPilot Mega with the IMU connected? I haven't seen that code, it might work just fine.

i ordered it Arduinopilot ready, i didnt try to re install the code. do i need to use this code in arduino or U-center?
alz3abi is offline Find More Posts by alz3abi
Reply With Quote
Old Apr 01, 2011, 06:42 PM
Suspended Account
Brunswick, OH
Joined Nov 2005
5,547 Posts
You need to plug your IMU into your ArduPilot Mega. Then open a new sketch in Arduino and copy and paste the code from the link above. Then compile and upload using your UDB cable connected to your ArduPilot Mega IMU board (just like how you program the ArduPilot Mega normally). Then connect using uCenter with your GPS connected to the ArduPilot Mega.
HappyKillmore is offline Find More Posts by HappyKillmore
Reply With Quote  (Disabled)
Old Apr 01, 2011, 07:01 PM
Registered User
Joined Oct 2010
74 Posts
this part not clear for me

Quote:
and connect u-Center to the USB serial port at 38400 baud. The GPS should work. Once the configuration is uploaded for the first time, you need to change the baud rate in the sketch and upload it again. Restart u-center, and proceed.

after i uploaded the code and i opened the U-center and connected to my com port at 38k i got red light blinking in the u-center not sure what to do to upload the configuration?
alz3abi is offline Find More Posts by alz3abi
Reply With Quote
Old Apr 01, 2011, 07:18 PM
Registered User
Joined Feb 2005
473 Posts
Quote:
Originally Posted by HappyKillmore View Post
Sorry Billy, that was my fault 1.2.48 is uploading now. Melih's servo driver works great....got one here on my desk... I see what you mean. I had an extra CrLf that was messing things up.
That did the trick!

Thanks for the quick response!!!
cass3825 is offline Find More Posts by cass3825
Reply With Quote
Old Apr 02, 2011, 01:21 PM
Registered User
Joined Oct 2010
74 Posts
what Message should i get from GPS MSG and how much is the percentage?
alz3abi is offline Find More Posts by alz3abi
Reply With Quote
Old Apr 02, 2011, 01:48 PM
Suspended Account
Brunswick, OH
Joined Nov 2005
5,547 Posts
alz3abi, we're about as far off topic as we can get. I think you need to ask these questions at DIYDrones.com or start another thread asking how to test which messages your uBlox is sending. I'm afraid I've gone as far as I can.
HappyKillmore is offline Find More Posts by HappyKillmore
Reply With Quote  (Disabled)
Old Apr 02, 2011, 02:28 PM
Registered User
Joined Oct 2010
74 Posts
Quote:
Originally Posted by HappyKillmore View Post
alz3abi, we're about as far off topic as we can get. I think you need to ask these questions at DIYDrones.com or start another thread asking how to test which messages your uBlox is sending. I'm afraid I've gone as far as I can.

im actually looking for sat's fix @_@
alz3abi is offline Find More Posts by alz3abi
Reply With Quote
Old Apr 02, 2011, 03:41 PM
Suspended Account
Brunswick, OH
Joined Nov 2005
5,547 Posts
I just did a test and your uBlox is not sending NAV-STATUS and NAV-VELNED because your heading is not changing and you don't get any values for satellites. It is sending NAV-POSLLH because lat and long are updating and it's sending NAV-SOL because GPS lock is getting sent.

Your uBlox needs to send NAV-POSLLH, NAV-STATUS, NAV-VELNED and NAV-SOL to work correctly. This is not a GCS problem. It's a GPS problem.
HappyKillmore is offline Find More Posts by HappyKillmore
Reply With Quote  (Disabled)
Old Apr 03, 2011, 03:42 PM
Registered User
Joined Oct 2010
74 Posts
Quote:
Originally Posted by HappyKillmore View Post
I just did a test and your uBlox is not sending NAV-STATUS and NAV-VELNED because your heading is not changing and you don't get any values for satellites. It is sending NAV-POSLLH because lat and long are updating and it's sending NAV-SOL because GPS lock is getting sent.

Your uBlox needs to send NAV-POSLLH, NAV-STATUS, NAV-VELNED and NAV-SOL to work correctly. This is not a GCS problem. It's a GPS problem.
Dear HK,

i would like to know how to enable these things in my GPS or my GPS is broken?


the problem im not expert but i try to follow steps or guides. thanks in advance.
alz3abi is offline Find More Posts by alz3abi
Reply With Quote
Old Apr 03, 2011, 04:37 PM
Suspended Account
Brunswick, OH
Joined Nov 2005
5,547 Posts
Alz, your GPS is not broken. I'm investigating how to set your GPS correctly....
HappyKillmore is offline Find More Posts by HappyKillmore
Reply With Quote  (Disabled)
Old Apr 03, 2011, 05:01 PM
Registered User
Joined Oct 2010
74 Posts
Quote:
Originally Posted by HappyKillmore View Post
Alz, your GPS is not broken. I'm investigating how to set your GPS correctly....
thank you waiting your solution.

while im checking U-center software i came across this COnfig page it showing that that baud rate is 57k, im not sure if i have to change this baud rate to 38k or keep it as it is?
alz3abi is offline Find More Posts by alz3abi
Reply With Quote
Old Apr 03, 2011, 09:46 PM
Suspended Account
Brunswick, OH
Joined Nov 2005
5,547 Posts
No, there's a bug in that source code. Try using this:
Code:
void setup()
{
pinMode(19, INPUT);    //RX1
pinMode(18,OUTPUT); //TX1
pinMode(0,INPUT);      //RX0
pinMode(1,OUTPUT);  //TX0
}
void loop()
{
digitalWrite(18,digitalRead(0)); // RX0 --> TX1                
//digitalWrite(1,digitalRead(19)); // TX0 <-- RX1                
}
And you should be able to see the uBlox messages, but you can't send any messages to change settings using that code.
HappyKillmore is offline Find More Posts by HappyKillmore
Reply With Quote  (Disabled)
Old Apr 03, 2011, 11:02 PM
Suspended Account
Brunswick, OH
Joined Nov 2005
5,547 Posts
So far, I have no solution. The code posted to use the APM as a pass-through makes use of both digitalRead and digitalWrite which take something like 16 cycles each. So that's 64 cycles to act as the pass-through. Apparently, that's not fast enough because as soon as the second line in the loop is added, it doesn't work anymore. So at this point, without an FTDI cable or a USB to serial converter, I don't have any way to set your GPS to the right settings. Again, I'd suggest posting your issue on DIYDrones or buying a cable....
HappyKillmore is offline Find More Posts by HappyKillmore
Reply With Quote  (Disabled)
Old Apr 04, 2011, 03:22 AM
Registered User
Joined Oct 2010
74 Posts
Quote:
Originally Posted by HappyKillmore View Post
So far, I have no solution. The code posted to use the APM as a pass-through makes use of both digitalRead and digitalWrite which take something like 16 cycles each. So that's 64 cycles to act as the pass-through. Apparently, that's not fast enough because as soon as the second line in the loop is added, it doesn't work anymore. So at this point, without an FTDI cable or a USB to serial converter, I don't have any way to set your GPS to the right settings. Again, I'd suggest posting your issue on DIYDrones or buying a cable....


i already post but no solution. i will try to work with the FTDI cable .
alz3abi is offline Find More Posts by alz3abi
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Show Us Your Ground Station !!!! FPV Ground Station Design and Idea's found here :) JettPilot FPV Equipment 4154 Dec 17, 2014 08:58 AM
Discussion Ground station wiring harness ziomatrixacs FPV Talk 3 Oct 07, 2010 06:48 PM
Discussion DIY Continuous Rotating FPV Ground Station Moosthegoose FPV Talk 37 Sep 29, 2010 05:27 AM
Discussion Aerial Photography request an Autopilot system & Ground Control Station Atflying Aerial Photography 7 Jun 27, 2010 03:13 AM