HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 05, 2010, 09:48 AM
Registered User
BRISVEGAS BABY
Joined Mar 2010
120 Posts
Discussion
Help with CE OSD

I am having a problem with my CE OSD. Every feature of the OSD is working perfectly except the current meter does not seem to be working. When i have my plane at full throttle it still reads 0.0A. It is reading the correct voltage which i have confirmed with a voltmeter but it is not reading amp current at all. Is there something that i might have to adjust or check, or is this a manufacturing fault.


Cheers
nathan089 is offline Find More Posts by nathan089
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 05, 2010, 10:34 AM
Registered User
Netherlands
Joined Sep 2007
414 Posts
Is the input and output correct (maybe you switched sides)?
marco899 is online now Find More Posts by marco899
Reply With Quote
Old Oct 05, 2010, 10:41 AM
Registered User
USA, NY, Yonkers
Joined Aug 2002
1,636 Posts
I have a similar problem with mine also. The Voltage is correct but the current will not go above 4 amps on mine even though my watt meter shows 14amps.
pc_pilot is offline Find More Posts by pc_pilot
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Ce osd Neo360 FPV Talk 1 Sep 21, 2010 12:54 PM
Help! Help with broken Eagle Tree OSD Pro StealthWorkx FPV Talk 1 Dec 13, 2009 09:52 AM
Discussion Newb Alert! Help with Fatshark Teleporter cam and ET OSD Pro djinni69 FPV Talk 1 Dec 07, 2009 11:28 AM
Discussion Need help with Eagle Tree OSD RTH! Ellis108 FPV Talk 2 Nov 30, 2009 10:28 PM
Discussion Help with my ET OSD Pro & RangeVideo Tx harness Cralis FPV Talk 122 Sep 11, 2009 10:35 AM