Espritmodel.com Telemetry Radio
Reply
Thread Tools
Old Sep 10, 2010, 06:54 AM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Discussion
Mikrokopter ME 2.0 Okto Build

First a summary of parts and tools used.

Frame: Big-X Alu V2 Okto 2010 - lcc-shop.de
Motors: 8x Turnigy 2217/20 - hobbycity.com
Propellers: 8x APC 10*4.7 - cnc-modellsport.de
Battery(s): 4s 14.8v Nano-tech 25-50c - hobbycity.com

Electronics - www.mikrokopter.de
Escs: 8x MK BL-ctrl 1.2
Board: Mikrokopter Flight Control V2.0 ME
Communication: MK Usb
Leds: Blå, Grønn og Rød
Shrink wrap: Gjennomsiktig + Rød
Altitude sensor
Extra RECOM
4x Vibration dampeners - the long ones
4x Black plastic screws M3 short ones
8x Black plastic nuts M3

Etc.
16awg red and black cable between board and battery
18awg red and black cable between escs and board
18awg black cable between escs and motors
20awg yellow cable between escs and board (i2c bus)
20awg blue cable between escs and board (i2c bus)
24awg red and black cable between escs and leds.
24awg red and black cable to Buzzer
Connector to battery
6mm x 3000m carbonfiber rods/tubes

Tools
Soldering Iron 30w - clas ohlsson
Solder - clas ohlsson
Heat Gun - clas ohlsson
Screwdriver star medium size(M3-M4)
Screwdriver star small(M1-M2)
Wrench
Drill + Drillbits
Cablestripper
Knife

The list will be updated.....

More info to come..
robin4 is online now Find More Posts by robin4
Last edited by robin4; Sep 11, 2010 at 07:21 AM.
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 11, 2010, 07:13 AM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Out of the box

The Okto frame arms are of diameter 10x10mm(standard mk size) and motor to motor length is about 80cm, while my quad frame that i have previously used(Lcc-shop Big Alu X Quad) has arm diameter of 15x15mm and motor to motor length of 60cm.

I don't know why he used 10x10mm on the okto, but probably to save some weight.. Personally i like the sturdy 15x15mm that my quad has.

The center hub supports 15x15mm arms, so it is possible to upgrade

I will use the 10x10mm which came with the package - drilled arms and ready for use.

I forgot to buy "support rods/bars that sits between the frame arms. This is optional, and do not include in the package. I like the look that these give so I ordered some 6mm carbontubes that im gonna use for this.

Frame out of box:
robin4 is online now Find More Posts by robin4
Last edited by robin4; Sep 11, 2010 at 07:20 AM.
Reply With Quote
Old Sep 11, 2010, 07:18 AM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Assembled the frame

Assembled the frame. I got a pickup notice for the carbonfiber tubes in the mail today, but the postoffice hadn't gotten the package yet? Pickup on monday.
robin4 is online now Find More Posts by robin4
Reply With Quote
Old Sep 11, 2010, 03:34 PM
Registered User
Ireland
Joined Apr 2001
4,027 Posts
why did you choose to go seperate instead of the milrokopter sets ?
cmulder is offline Find More Posts by cmulder
Reply With Quote
Old Sep 12, 2010, 05:05 AM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Quote:
Originally Posted by cmulder View Post
why did you choose to go seperate instead of the milrokopter sets ?
Because of the overall design and looks basicly. It has a protective roll cage and has alot of accessories that can be mountet underneath too
robin4 is online now Find More Posts by robin4
Reply With Quote
Old Sep 13, 2010, 03:25 PM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Ledstrips

Since its been some delays regarding the carbonfiber tubes, I used my time mounting leds to the frame instead. I also finished up the wiring from the leds to the escs.

A pretty easy task, used a short amount of time to attach. Soldering the wires to the leds went quick too. I used doublesided tape between the ledstrips and the frame just to be on the safe side, in case of shortage etc(you never know what can happen...)

Found an easy solution to keep wiring to a minimum. See picture.
robin4 is online now Find More Posts by robin4
Reply With Quote
Old Sep 16, 2010, 10:27 AM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Things moving along :)

Finally some progress. I have had limited time to build these last couple of days, but i have been effective and still managed to do some work.

I started by cutting the first carbonrod, then mounting it, then cut the next, then mounting it etc etc. This ensures that the lengths won't come up short if you cut all at once. Before i mounted the 2 front bars/rods, I sprayed the red, so it will be easier to see whats front and rear in flight. I used hotglue between the gaps between the rods/bars to keep them in place.

Then it was time to mount the motors, but before I could do that i had to solder on some bulletconnectors. Pretty easy task but a boring process. Mounted the motors onto the frame. I used a pretty strong superglue on the screwmounts for the motors to ensure that they dont get loose.

So far i have soldered 62 solderjoints/points, and even more to come
robin4 is online now Find More Posts by robin4
Reply With Quote
Old Sep 19, 2010, 05:34 AM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Wiring

Today I soldered together the wires that provide power(18awg) and the wires that provide info to/from escs - i2c bus(24awg).
In total 4 wireharnesses. Each harness with a total of 8 wires leading to escs and 1 wire leading to ME board.

I used the simplest method of making the wireharnesses. I know there is alot of great solutions on how to do this, but found this is the easiest way if you don't have anything other than wire and shrinkwrap availible. Remember to use more wire than you actually need.

"How to make a basic wireharness" in this link, bottom of page: http://mikrokopter.de/ucwiki/en/ElectronicConnections

Also mounted vibration dampeners to the board onto the frame.
robin4 is online now Find More Posts by robin4
Reply With Quote
Old Sep 19, 2010, 05:58 AM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Bl-ctrl 1.2

Ive finished adressing, soldering elko, and wires to the motors on the escs with the "extra-sw", or adress 5-8. See picture - notice the white label that indicates that its with "extra-sw"

I have also disassembled the old escs with the adresses 1-4 from my lcc-shop quad frame. I found that the wires leading from escs to motors was to short since my oktoframe arms are somewhat longer than on the quad. I didn't have anymore 18awg in stock, so I made an order today, hopefully i get to start on tuesday.

I have also run into a bit of a problem actually. I you see one of the attached pictures, my motor positioning is somewhat different from the stock mikrokopter setup.

Luckly for me, we have alot of helpful people here on rcgroups. Thanks to Rusty aka 13brv3 for this solution.

Ill come back later in this thread on how i solve the problem, but for you guys that are in middle of a build, or don't like to wait, heres a link:
http://www.rcgroups.com/forums/showp...ostcount=15361
robin4 is online now Find More Posts by robin4
Last edited by robin4; Sep 26, 2010 at 02:46 PM.
Reply With Quote
Old Sep 26, 2010, 02:51 PM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Hi

I have mounted everything(will make a post with pics etc), and did a powerup.

Everything worked except esc 7. I thought it was some connection error, so i resoldered every wireconnection, but when I did this I accidently got solder on one of those small capasitators(or whatever its called). When I tried to remove the solder, i managed to solder off one of those.

I have ordered 1 new esc, so hopefully i will get it shortly.
robin4 is online now Find More Posts by robin4
Reply With Quote
Old Oct 03, 2010, 05:32 AM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Me board soldered

FC is finished, only modification is that ive used foam on the altitude sensor + shrinkwrap to keep it in place. Hopefully this will help when using altitude hold - that i wont get to big variations in height because of wind..
robin4 is online now Find More Posts by robin4
Reply With Quote
Old Oct 03, 2010, 05:55 AM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
impatience....

Doesnt help to be impatience!

I did actually have 2 std bl-ctrl 1.2 with the 1-4 address software in reserve here at home. So I did try to program one of these with address 5-8 software, without luck..

But I did finally manage to program the bl-ctrl, the day after i ordered a new one with the 5-8 address software...

I thought the problems was with the pins on the bl-ctrl, but after further inspection, i found that one of the pins on the mkusb had a shabby solderjoint. resoldered it.

Mktools guide:
http://mikrokopter.de/ucwiki/en/Mikr...L-Ctrl-Program


Connected with mktools 0.70, but got the errormessage that it was wrong controller. Reconnected with Mktools 0.68c and the programming worked flawlessly!

software to Bl-ctrl 1.2
http://svn.mikrokopter.de/listing.ph...c44443f0e1999c

Everything is now nice and dandy, all bl-ctrl are found by mktools.

But now i got an errormessage in mktools that says "quadro mixing error", this is because my previous setup i used a quad.
Anyways, i used "alt" key + left mouse click on "settings" in mktools, Then you get an expanded menu. Chose "mixer-setup" - here you can either use your own values http://www.rcgroups.com/forums/showp...ostcount=15361
or you can use presets. In my case i used "okto2"

After that, i did a motortest on each single motor to see which way the rotated. Noted the motors that turned the wrong way, switched off mk, reconnected motorwires, turned on mk, and did the test again to be sure

The day of maiden flight is approaching!
robin4 is online now Find More Posts by robin4
Reply With Quote
Old Oct 07, 2010, 01:58 PM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Maiden

Well, after several days with crappy weather, the time for maiden flight has finally arrived.

Went to the flyzone to test the kopter. Connected the battery, og went through the usual stick movements after gyroes had done their selftesting. Left up on throttlestick, then Right Up on throttlestick to save the information to the board that the placement of the okto is level and this is what the board has to use as reference(only has to be done once, if no other settings has been changed in mktools for example)
I used lower right throttle to start the motors, but only got beeping sound, tried with another battery, but no luck...

Went home a bit mad and pissed off, hooked up the mk to mktools, and got errormessage "i2c error"

Did a quick look at the last bl-ctrl that i did some soldering on, and what do you know, some solder between one of the i2c bus lines and one of the small capasitors on the board. Full speed to the "solderhut", and 5 minutes later the solder was gone thanks to my soldering iron.
Connected up to mktools again, and no error message!!

Then to the flyzone again!
robin4 is online now Find More Posts by robin4
Last edited by robin4; Oct 07, 2010 at 03:58 PM.
Reply With Quote
Old Oct 07, 2010, 02:10 PM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Maiden part II

Everything is in order, and im one step closer to maiden flight... finally

Did a quick startup at home to check if the motors would start, and they did.
Put all the gear in my car, and drove to the flyzone. Got there, and unpacked everything.
Connected the battery to the mk, and went through the stick movements. Motors started... Throttle up, and the okto started moving. Its throwing itself forward and to the side, so i have to counter with the stick. More throttle to gain height, went well. The okto is overresponsive, so i takes alot of consentration to get it trimmed in. Finally got it trimmed in, and it hovers almost without any input. so much more stable than my quad! After a short flight, i land. Didn't have the guts to fly towards myself because it was so overresponsive.

Video:
Okto Maiden (3 min 7 sec)


Dig a second flight, but the video was bad, since i flew outside the area the camera filmed. Tried full throttle, damn that thing moves! Got that famous beeping sound when i applied full throttle. Also tested the altitude hold feature, and it worked perfectly now after i covered up the heightsensor with some foam.

Thing to do - Program the stickcontrols to be less sensitive via mktools and maybe use a thicker wire from batteryplug to board, to get ridd of beeping sound?

All in all, a successful flight - no damage at all!
Maiden ble iallefall en suksess! Ingen ting ødelagt!
robin4 is online now Find More Posts by robin4
Reply With Quote
Old Oct 10, 2010, 07:21 AM
Registered User
Stavern/Larvik - Norway
Joined Dec 2008
797 Posts
Cameraholder with nick and roll

Mounted the camholder that I also bought at lcc-shop.de This holder is equipped with 2 servoes which enables roll and nick compensation via connections to the ME board. You also have full control to correct the startoutpoint-angle of nick and roll via the radiotx.(if you link them up to channels on your tx via mktools). AUW without cam and batteries is now 1972gr.

In Mktools you have to do some changes in the camera and controls settings(see cameramenu and controlsmenu pictures). To see if your cameraholder compensation is correct, enable the cameraholder by using upperleft-throttle on your radiotx. Move the mk in different angles. If it corrects to slow or to fast change the values in "nick compensation" or "roll compensation" to correct the speed. I had to increase values on roll compensation till i got satisfied.

I also decreased the sensitivity of my mk, due to it overresponded to my stickmovements. (see stickmenu picture)
robin4 is online now Find More Posts by robin4
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale Norvel engines 049 through 0.4, R/C or CL. Brandnew. Contact me for prices klondike17 Aircraft - Fuel - Engines and Accessories (FS/W) 6 Oct 15, 2010 08:05 PM
Discussion Flight-Ctrl 2.0-ME or UVAX? 5artist5 Multirotor Talk 19 Jul 22, 2010 10:51 AM
Build Log mikrokopter Okto Build Time-lapse Beauregard Multirotor Talk 4 Apr 19, 2010 06:03 PM
Build Log P-51-5NA Caviler MK II Prototype (Ver. 2.0) Build killerproblem Electric Warbirds 9 Apr 03, 2010 09:55 PM
60" LEG ME-109 Build Version 2.0! Tawg Slope 70 Sep 10, 2004 12:22 AM