HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old May 01, 2011, 12:21 PM
Registered User
Spain.
Joined Jul 2009
303 Posts
Hi all, i need some help.

Does anyone knows the forward direction of the HMC5883L??

I have this board, but im not sure the right orientation.

Thanks

Nosepo is offline Find More Posts by Nosepo
Reply With Quote
Sign up now
to remove ads between posts
Old May 01, 2011, 12:24 PM
Flying a Chipmunk in Portugal
jhsa's Avatar
NRW, Germany
Joined Sep 2010
3,413 Posts
Quote:
Originally Posted by Flyingfool View Post
Hey Guys,

Does the software support this configuration of a Y4 with the rear motors stacked?
Attachment 3983034
that looks niiiiiccceeee..
jhsa is online now Find More Posts by jhsa
Reply With Quote
Old May 01, 2011, 12:25 PM
Registered User
Norway Haugesund
Joined Jun 2010
329 Posts
Multiwii fun flying hehe, im not the best pilot but itīs going the right direction

Multiwii 1mai (2 min 22 sec)
culexus is offline Find More Posts by culexus
Reply With Quote
Old May 01, 2011, 12:25 PM
Registered User
Flyingfool's Avatar
Belle Chasse Southern, Louisiana, United States
Joined Apr 2002
877 Posts
Thanks
Flyingfool is offline Find More Posts by Flyingfool
Reply With Quote
Old May 01, 2011, 02:20 PM
RTFM // copter damaged
warthox's Avatar
Joined Aug 2009
1,726 Posts
some onboard footage shot with the mwc mini hexa with flyduino + ff imu.

mwc mini hexa - flyduino + ff imu onboard (2 min 22 sec)
warthox is offline Find More Posts by warthox
Reply With Quote
Old May 01, 2011, 02:25 PM
My RC builds in my profile.
daign's Avatar
United States, CA, Los Angeles
Joined Feb 2011
2,563 Posts
I am running a new RTF Paris 3 Multiwiicopter board and using a Hitec Aurora 9 transmitter, I cannot get it to arm or respond to any throttle inputs. I have tried to reverse the throttle and upped the subtrim 100 with no luck. Stock endpoints are at 150% and cannot go higher on throttle.

Any help?
daign is offline Find More Posts by daign
Reply With Quote
Old May 01, 2011, 02:35 PM
Registered User
Nederland, Gelderland, Meteren
Joined Dec 2010
202 Posts
Quote:
Originally Posted by Nosepo View Post
Hi all, i need some help.

Does anyone knows the forward direction of the HMC5883L??

I have this board, but im not sure the right orientation.

Thanks

The 4 connection holes is front.
KeesvR is offline Find More Posts by KeesvR
Reply With Quote
Old May 01, 2011, 02:37 PM
Fly, Crash, Learn, Fly
AdrenaCo's Avatar
France (Beaujolais-Vert)
Joined Nov 2008
318 Posts
Quote:
Originally Posted by daign View Post
I am running a new RTF Paris 3 Multiwiicopter board and using a Hitec Aurora 9 transmitter, I cannot get it to arm or respond to any throttle inputs. I have tried to reverse the throttle and upped the subtrim 100 with no luck. Stock endpoints are at 150% and cannot go higher on throttle.

Any help?
Where does the Gui show that you are with your throttle?
AdrenaCo is offline Find More Posts by AdrenaCo
Reply With Quote
Old May 01, 2011, 02:46 PM
Registered User
Spain.
Joined Jul 2009
303 Posts
Quote:
Originally Posted by KeesvR View Post
The 4 connection holes is front.
Many Thanks KeesvR.
Nosepo is offline Find More Posts by Nosepo
Reply With Quote
Old May 01, 2011, 02:49 PM
MultiWiiHead
Centurian's Avatar
Corvallis OR
Joined Apr 2004
258 Posts
I could be wrong, but I think 1.7 final is the first release using the new IMU code http://wbb.multiwii.com/viewtopic.ph...8&hilit=vector I was setting up a Mega yesterday and noticed some interesting results. Even if not the case, remember that any horizontal acceleration (result of a tilted copter) results in the net acceleration vector not pointing straight down. The old IMU uses only the net accel vector for correction. The new IMU somehow integrates the gyro & accel data to come up with a vector (I think) I have not flown the new IMU yet, but I think it's a good thing. Anyway, I'm guessing the change you are sensing is a result of the new IMU.

When you refer to "heading hold" I think you are talking about gyro only. Once again, the IMU is processing sensor data differently.

From what I understand, the bottom line is there is a significant change in 1.7 final.

Quote:
Originally Posted by BlueAngel2000 View Post
Okay, i have a problem with my Hexa X Copter.

I have built a Hexa X Copter:
more details in this post:
http://www.rcgroups.com/forums/showp...ostcount=13596

a video i made earlier:
http://vimeo.com/22883244


The problem is, that the Copter flies in head holding mode, like in a slow leveling mode.
That means i give pitch forward and it flies forward, but slowly changes back to level.
Thats not head hold flying any more, and i don't know whats the problem here.

Flying in the ACC mode, works as expected. If i release sticks, it does immediately level.

I had this wii board before in my Quadro Copter in X mode and it flew in head holding mode completely as it should.

The only thing i changed is:
1. use it on my Hexa X Copter
2. add the BMP095 with a Level Converter
3. changed code from 1.7pre to 1.7 final

So what can i do?
Centurian is offline Find More Posts by Centurian
Reply With Quote
Old May 01, 2011, 02:52 PM
MultiWiiHead
Centurian's Avatar
Corvallis OR
Joined Apr 2004
258 Posts
Quote:
Originally Posted by Jakub J View Post
And the winner is Centurian !
When should I expect the arrivial of the Really BIG prize???

Just kidding, Glad you figured it out... enjoy!!!
Centurian is offline Find More Posts by Centurian
Reply With Quote
Old May 01, 2011, 03:09 PM
Flying like an Angel.
BlueAngel2000's Avatar
Austria
Joined Sep 2007
1,488 Posts
Quote:
Originally Posted by Centurian View Post
I could be wrong, but I think 1.7 final is the first release using the new IMU code http://wbb.multiwii.com/viewtopic.ph...8&hilit=vector I was setting up a Mega yesterday and noticed some interesting results. Even if not the case, remember that any horizontal acceleration (result of a tilted copter) results in the net acceleration vector not pointing straight down. The old IMU uses only the net accel vector for correction. The new IMU somehow integrates the gyro & accel data to come up with a vector (I think) I have not flown the new IMU yet, but I think it's a good thing. Anyway, I'm guessing the change you are sensing is a result of the new IMU.

When you refer to "heading hold" I think you are talking about gyro only. Once again, the IMU is processing sensor data differently.

From what I understand, the bottom line is there is a significant change in 1.7 final.
No, i think this is just for ACC (level) mode, which does work very good.

In "head holding" (gyro only) mode, the accel data should not be used and the copter should stay at his present angle. (position)
BlueAngel2000 is offline Find More Posts by BlueAngel2000
Reply With Quote
Old May 01, 2011, 03:55 PM
Registered User
Joined May 2010
96 Posts
Hello ppl, i am flying my tricopter fine without nk, when i plug the nk, the tricopter stay unstable, with the nk turned off, the same with nk turned on, what i can do to solve this problem? please help me
axskin is offline Find More Posts by axskin
Reply With Quote
Old May 01, 2011, 04:28 PM
manuLRK
Belgium
Joined Sep 2004
1,529 Posts
Hello warthox,

You tried sooo many boards, which board is yous favorite one? ... Choose only 1!

manuLRK
PS: Nice video!

I see you have nice mountains not so far. Do you never go for RC-soaring or dynamic soaring?


Quote:
Originally Posted by warthox View Post
some onboard footage shot with the mwc mini hexa with flyduino + ff imu.

http://vimeo.com/23119446
alll is online now Find More Posts by alll
Reply With Quote
Old May 01, 2011, 05:14 PM
Registered User
TheQuadLaser's Avatar
United States, UT, Provo
Joined Feb 2011
49 Posts
I am using an arduino 2560 mega with an aeroquad 2.0 shield and wii sensors running on multiwii 1.7 flight software. I have flown my quad before on aeroquad sorfware, but i have heard multiwii software is better with wii sensors so i am giving it a try. This video shows how my flights have gone so far.

http://www.youtube.com/watch?v=aTpwPrI-HUE

In this video i am flying on level mode. I have gotten a few longer flights than this, but nothing longer than 15 seconds, when I get the quad off of the ground it just sort of drifts around, it is not twichy, but it is not stable. when I give the quad full throttle it just bounces around in the air and doesnt get any higher than a few feet off the ground. Any suggestions?
TheQuadLaser is offline Find More Posts by TheQuadLaser
Reply With Quote