SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Oct 12, 2013, 01:28 AM
Registered User
Joined May 2013
4 Posts
hi all
i have 10DOF GY80 IMU and a Arduino uno i want to connect between them and after that control quadrotor orientation with programming not RC.
please help me to connect between GY80 and Arduino uno from Multiwii.
TNX
ehsanware is offline Find More Posts by ehsanware
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 12, 2013, 05:34 AM
Registered User
Joined May 2013
4 Posts
I got the data from GY80 and saw them into the MultiWii conf but i want to write some code such controller and out put PWM for 4 brushless motor by myself and dont want to use other codes of Multiwii just reading from IMU.is there any body help me???
ehsanware is offline Find More Posts by ehsanware
Reply With Quote
Old Oct 13, 2013, 02:07 AM
Registered User
Joined May 2013
4 Posts
there is no one to help me???
ehsanware is offline Find More Posts by ehsanware
Reply With Quote
Old Oct 14, 2013, 04:37 AM
throw new IOPilotException();
IceWind's Avatar
Ireland, County Dublin, Dublin
Joined Feb 2005
2,659 Posts
This thread is pratically dead...
All Multiwii work and discussion moved the MWC forums: http://www.multiwii.com/forum/
IceWind is offline Find More Posts by IceWind
Reply With Quote
Old Nov 10, 2013, 11:50 AM
Hamburger
hamburger's Avatar
Joined Jan 2010
850 Posts
for those who may still follow this thread

MultiWii version 2.3 is available now.

Have fun flying
hamburger is online now Find More Posts by hamburger
Reply With Quote
Old Nov 10, 2013, 07:38 PM
has an opinion
Felixrising's Avatar
Australia, VIC, Southbank
Joined Jan 2013
390 Posts
Great work!
Felixrising is offline Find More Posts by Felixrising
Reply With Quote
Old Nov 10, 2013, 07:53 PM
DiaLFonZo - UAV/Drone
Dialfonzo's Avatar
Canada, QC
Joined Oct 2007
6,826 Posts
Another thing on the to-do list...!
Thanks for the great work
Dialfonzo is online now Find More Posts by Dialfonzo
RCG Plus Member
Old Nov 10, 2013, 09:35 PM
If it flies, I can crash it!
djdavid60's Avatar
Naperville, IL
Joined Aug 2010
1,154 Posts
Quote:
Originally Posted by IceWind View Post
This thread is pratically dead...
All Multiwii work and discussion moved the MWC forums: http://www.multiwii.com/forum/
This thread is not dead, we are just all experts now, so no more questions.
djdavid60 is offline Find More Posts by djdavid60
Reply With Quote
Old Nov 11, 2013, 01:24 AM
Registered User
Joined Aug 2012
28 Posts
This version 2.3 is great work and i hunger for tring.
But, The MultiWiiConf is no-response (It can't read the data from IMU, but Ver. 2.2 is OK). I had enabled the Internal i2c Pullups (#define INTERNAL_I2C_PULLUPS) & sellected IMU board (GY-86).
SUMPRO is offline Find More Posts by SUMPRO
Reply With Quote
Old Nov 11, 2013, 01:53 AM
Registered User
Rust's Avatar
Bulgaria, Sofija-Grad, Sofia
Joined Apr 2013
746 Posts
Quote:
Originally Posted by hamburger View Post
for those who may still follow this thread

MultiWii version 2.3 is available now.

Have fun flying
Already tried one of the latest betas. It flew very nice!
The biggest difference I immediately saw is the YAW. It's a lot more snappy and it locks in place.
Rust is offline Find More Posts by Rust
Reply With Quote
Old Nov 14, 2013, 05:17 PM
Registered User
Joined May 2012
13 Posts
hi guys i'm a newby in multicopter, i'm trying to connect everything on desk.
I have an arduino uno board and a gy-80 imu well connected and functioning, giving right data in the gui.
The trouble is that when i connect the radio receiver (turnigy 9x not modded) i cannot read the data from the stick in the gui, what it happen is the stick moving crazy on left and right,
I tried two different receiver and get the same results.
I olso tested each pin of the receiver with an esc connected with motor and il function properly.
Could someone give mi some advice?
I'm going crazy.
Thank's a lot.
Andrea
andreaontheweb is offline Find More Posts by andreaontheweb
Reply With Quote
Old Nov 14, 2013, 05:44 PM
Registered User
Joined May 2012
13 Posts
Quote:
Originally Posted by andreaontheweb View Post
hi guys i'm a newby in multicopter, i'm trying to connect everything on desk.
I have an arduino uno board and a gy-80 imu well connected and functioning, giving right data in the gui.
The trouble is that when i connect the radio receiver (turnigy 9x not modded) i cannot read the data from the stick in the gui, what it happen is the stick moving crazy on left and right,
I tried two different receiver and get the same results.
I olso tested each pin of the receiver with an esc connected with motor and il function properly.
Could someone give mi some advice?
I'm going crazy.
Thank's a lot.
Andrea
SOLVED

I don't understand why but appen when power the receiver from external battery, when powered from arduino everything it's ok..
strange???
thank's anyway.
andreaontheweb is offline Find More Posts by andreaontheweb
Reply With Quote
Old Nov 14, 2013, 06:02 PM
DiaLFonZo - UAV/Drone
Dialfonzo's Avatar
Canada, QC
Joined Oct 2007
6,826 Posts
Quote:
Originally Posted by andreaontheweb View Post
SOLVED

I don't understand why but appen when power the receiver from external battery, when powered from arduino everything it's ok..
strange???
thank's anyway.
Most board are like that.
USB only power the Flight Controler, if you want to power the receiver, you have to power it externally.
Dialfonzo is online now Find More Posts by Dialfonzo
RCG Plus Member
Old Nov 14, 2013, 08:32 PM
Multi Rotor Maniac
Stunt Double's Avatar
Australia, VIC, Melbourne
Joined Oct 2007
2,843 Posts
v2.3 thoughts....

I very much like the option to use the gui to configure tricopter yaw servo travel and reversing. No more repeated arduino uploads for minor adjustments.

Yaw stick scaling - about time!! No more messing with P's and travel or linkage settings. Will be testing this soon.

Flight feels much the same as previous firmwares. Have tested 2.3 on a v-tail and a tri, can't feel anything different yet.

The only negative I can think of is no more bluetooth android app compatibility (that is until the developers get up to speed)

There is a massive list of changes this time around so congrats to all involved and keep up the good work.
Stunt Double is offline Find More Posts by Stunt Double
Reply With Quote
Old Dec 03, 2013, 03:17 AM
Registered User
Bking1340's Avatar
South Africa
Joined Jan 2010
477 Posts
Good day all
I have posted this in the witespy ez3 thread as I use this board on my tri - Greg suggest that I rather ask my question here.

Just replaced my ez3 multiwii 2.2 with 2.3 on my tricopter and used the advise from Picard to change #define MEGA_HW_PWM_SERVOS to //#define MEGA_HW_PWM_SERVOS in config.h and that will bring back the tri servo to D2.
It`s working - so there`s no need to change any wires around from 2.2 to 2.3 on a tri. Thanks Picard.

One problem I do need help with is that my yaw speed to the left are twice as much as the right. If not armed and I give full yaw deflection left or right, the prop almost touch the ground on both sides, so they seem equal.
In wingui left yaw input are 1000, middle 1500 and right 2000. (Tried to play with these in wingui - left input changed to 1350 - still no change)
With or without mag enabled my tri does not yaw without input, it`s just that my right yaw are half the speed of left yaw.
Any advice will be apreciated.
Thanks
Bking1340 is online now Find More Posts by Bking1340
Reply With Quote
Reply


Thread Tools